cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
15447
Views
6
Helpful
21
Replies

4G LTE Configuration

johann1p1
Level 1
Level 1

Need help with 4G LTE configuration on IR809 AT&T router. I am totaly new to this 

21 Replies 21

Hello,

 

below is a sample configuration (important 4G related lines in bold). See how far you get, and let us know:

 

boot-start-marker
boot system flash:/ir800-universalk9-mz.SPA.156-3.M2
boot system flash ir800-universalk9-mz.SPA.156-3.M2
boot-end-marker
!
chat-script lte "" "AT!CALL" TIMEOUT 60 "OK"
!
controller Cellular 0
lte sim data-profile 1 attach-profile 1 slot 0
lte sim max-retry 0
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
!
interface Cellular0
no ip address
encapsulation slip
dialer in-band
dialer string lte
dialer-group 1
async mode interactive
!
interface Cellular1
no ip address
encapsulation slip
!
dialer-list 1 protocol ip permit
!
line con 0
stopbits 1
line 1 2
stopbits 1
line 3
script dialer lte
modem InOut
no exec
transport preferred none
transport output none
line 8
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 1/3 1/6
transport preferred none
transport output none
stopbits 1

Thanks, i will let you know.

At present this is what I have.

 

Current configuration : 2397 bytes
!
version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname IR800
!
boot-start-marker
boot system flash:/ir800-universalk9-mz.SPA.156-3.M
boot-end-marker
!
!
enable secret 5 $1$ZHUA$jGYnfnZnRrQejLXQ3Ubj8.
enable password detek1
!
no aaa new-model
ethernet lmi ce
!
!
!
!
!
!
!
!
!
!
!


!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"
!
!
license udi pid IR809G-LTE-NA-K9 sn JMX2052X06X
!
!
!
redundancy
!
!
!
!
!
controller Cellular 0
lte sim data-profile 1 attach-profile 1 slot 0
lte sim max-retry 20
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0
ip address 172.1.2.3 255.255.0.0
duplex auto
speed auto
no mop enabled
!
interface GigabitEthernet1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet2
no ip address
shutdown
duplex auto
speed auto
!
interface Cellular0
ip address negotiated
encapsulation slip
dialer in-band
dialer string lte
dialer-group 1
!
interface Cellular1
no ip address
encapsulation slip
!
interface Async0
no ip address
encapsulation scada
!
interface Async1
no ip address
encapsulation scada
!
interface Dialer1
ip address negotiated
encapsulation slip
dialer pool 1
dialer idle-timeout 30
dialer string lte
dialer-group 1
!
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 2 interface Cellular0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0
!
dialer-list 1 protocol ip list 1
ipv6 ioam timestamp
!
!
snmp-server community public RO
access-list 1 permit any
!
control-plane
!
!
!
!
line con 0
script dialer lte
stopbits 1
line 1 2
stopbits 1
line 3
script dialer lte
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 8
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 1/3 1/6
transport preferred none
transport output none
stopbits 1
line vty 0 4
password detek2
login
transport input none
!
no scheduler max-task-time
!
!
!
!
!
!
end

Hello,

 

below is the sanitized config. After you are finished configuring, issue the command 'show cellular 0 profile'.

 

Current configuration : 2397 bytes
!
version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname IR800
!
boot-start-marker
boot system flash:/ir800-universalk9-mz.SPA.156-3.M
boot-end-marker
!
enable secret 5 $1$ZHUA$jGYnfnZnRrQejLXQ3Ubj8.
enable password detek1
!
no aaa new-model
ethernet lmi ce
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"
!
license udi pid IR809G-LTE-NA-K9 sn JMX2052X06X
!
redundancy
!
controller Cellular 0
lte sim data-profile 1 attach-profile 1 slot 0
lte sim max-retry 20
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
!
interface GigabitEthernet0
ip address 172.1.2.3 255.255.0.0
ip nat inside
duplex auto
speed auto
no mop enabled
!
interface Cellular0
ip address negotiated
encapsulation slip
dialer in-band
dialer pool-member 1
dialer-group 1
async mode interactive
!
interface Dialer1
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer pool 1
dialer string lte
dialer-group 1
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
dialer-list 1 protocol ip permit
!
access-list 1 permit 172.1.0.0 0.0.255.255
!
ipv6 ioam timestamp
!
snmp-server community public RO
control-plane
!
line con 0
script dialer lte
stopbits 1
line 1 2
stopbits 1
line 3
script dialer lte
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 8
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 1/3 1/6
transport preferred none
transport output none
stopbits 1
line vty 0 4
password detek2
login
transport input none
!
no scheduler max-task-time
!
end

Hi George,

I get this.

IR800(config-if)#dialer pool-member 1
%Remove Legacy DDR Configuration first
IR800(config-if)#exit
IR800(config)#default interface cellular 0
Interface Cellular0 set to default configuration
IR800(config)#interface cellular 0
IR800(config-if)#ip address negotiated
IR800(config-if)#encapsulation slip
IR800(config-if)#dialer pool-member 1
%Configure a "dialer in-band" first.
IR800(config-if)#dialer in-band
IR800(config-if)#dialer pool-member 1
IR800(config-if)#dialer-group 1
%Remove Dialer Profile Configuration first
IR800(config-if)#

this is driving me crazy. 

 

 

 

Hello,

 

erase the entire configuration and start over again, that is probably a lot faster than messing with that message:

 

IR800#wr erase

Hi George,

                would it be better if i give you access to the computer I am working on and you do the configuration will I follow along. we can us TeamViewer for this purpose. 

Hi,

is this something I have to resolve?

 

IR800#cellular 0 lte plmn select manual 310 410 lte power-cycle
IR800#
*Dec 28 17:42:04.653: %CELLWAN-4-MANUAL_PLMN_SELECTION_FAILED: Manual/Force PLM
N Selection Failed. Error[1037]

Hi, i also added the info after a show cell 0 all command.

Hardware Information
====================
Modem Firmware Version = SWI9X15C_05.05.58.00
Modem Firmware built = 2015/03/04 21:30:23
Hardware Version = 1.0
Device Model ID: MC7354
Package Identifier ID: 1102037_9903214_MC7354_05.05.58.00_00_Cisco_005.009_000
International Mobile Subscriber Identity (IMSI) =
International Mobile Equipment Identity (IMEI) = 356734060428194
Integrated Circuit Card ID (ICCID) = 89014104279512334343
Mobile Subscriber Integrated Services
Digital Network-Number (MSISDN) =
Modem Status = Online
Current Modem Temperature = 0 deg C
PRI SKU ID = 9903214, PRI version = 005.025, Carrier = Generic

Profile Information
====================

Profile 1 = INACTIVE* **
--------
PDP Type = IPv4
Access Point Name (APN) = Broadband
Authentication = None

* - Default profile
** - LTE attach profile


Configured default profile for active SIM 0 is profile 1.


Data Connection Information
===========================
Profile 1, Packet Session Status = INACTIVE
Profile 2, Packet Session Status = INACTIVE
Profile 3, Packet Session Status = INACTIVE
Profile 4, Packet Session Status = INACTIVE
Profile 5, Packet Session Status = INACTIVE
Profile 6, Packet Session Status = INACTIVE
Profile 7, Packet Session Status = INACTIVE
Profile 8, Packet Session Status = INACTIVE
Profile 9, Packet Session Status = INACTIVE
Profile 10, Packet Session Status = INACTIVE
Profile 11, Packet Session Status = INACTIVE
Profile 12, Packet Session Status = INACTIVE
Profile 13, Packet Session Status = INACTIVE
Profile 14, Packet Session Status = INACTIVE
Profile 15, Packet Session Status = INACTIVE
Profile 16, Packet Session Status = INACTIVE

Network Information
===================
Current System Time = Sun Jan 6 0:45:59 1980
Current Service Status = No service
Current Service = Unknown
Current Roaming Status = Home
Network Selection Mode = Automatic
Network =
Mobile Country Code (MCC) = 310
Mobile Network Code (MNC) = 410
Packet switch domain(PS) state = Not attached
Location Area Code (LAC) = 0
Cell ID = 0

Radio Information
=================
Radio power mode = online
Channel Number = 0
Current Band = Unknown
Current RSSI(RSCP) = -90 dBm
Current ECIO = -13 dBm
Primary Scrambling Code = 0x100
Radio Access Technology(RAT) Preference = AUTO
Radio Access Technology(RAT) Selected = UMTS

Modem Security Information
==========================
Active SIM = 0
SIM switchover attempts = 0
Card Holder Verification (CHV1) = Enabled
SIM Status = Locked
SIM User Operation Required = Enter CHV1
Number of CHV1 Retries remaining = 3

GPS Information
==========================

GPS Info
-------------
GPS Feature: enabled
GPS Port Selected: Dedicated GPS port
GPS Status: GPS location cannot be acquired
GPS auto tracking status: unknown
GPS auto tracking config: disabled
GPS Mode Configured: not configured/unknown
Last Location Fix Error: Offline [0x0]

SMS Information
===============
SMS Service is not available
SMS Service is not available

Error Information
=================

This command is not supported on this platform.


Modem Crashdump Information
===========================
WIC type is 00
Cellular0 is MC73xx based
Modem crashdump logging: off

Hi, I get this if I want to change the dialer pool.

IR800(config)#interface cellular 0
IR800(config-if)#ip address negotiated
IR800(config-if)#encapsulation slip
IR800(config-if)#dialer in-band
IR800(config-if)#dialer pool-member 1
%Remove Legacy DDR Configuration first
IR800(config-if)#

Hello,

 

default the cellular interface and enter everything again:

 

IR800(config)#default interface cellular 0

 

 

You config looks good but there are a few things that are missing, and some other things that aren't required.

 

Here is the Cell 0 config we use:

!
interface Cellular0
 ip address negotiated
 ip nat outside
 ip virtual-reassembly in
 encapsulation slip
 dialer in-band
 dialer idle-timeout 0
 dialer enable-timeout 6
 dialer string lte
 dialer-group 1
 async mode interactive
!

The second thing that looks like it is missing and does not show up in the sho run is the APN setting for the wireless provider.

 

 

I'm not sure what the APN setting is for your carrier (I am up in Canada, different providers) but the command is:

cell 0 lte profile create 1 <APN>

For example we use Bell as a service provider and their APN is inet.bell.ca

 

 

For things that look unnecessary, the dialer interface is not required at all, the Cell 0 interface handles everything required for network access.

Hi Ben

can you post all of your config (erase all ip address)

i try to config my 891lte but nothing append

today i call bell to map sim card with the router imei

and i still not have access to internet

 

here my config 

 

Building configuration...

Current configuration : 3278 bytes
!
! Last configuration change at 21:24:46 EDT Wed Apr 25 2018
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ST-MET_ST03
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$a0KU$KGm3YyeMofkE32tokJtoO1
!
aaa new-model
!
!
aaa authentication login EXEC local
aaa authentication login Liste-Usagers local
aaa authorization exec default local
aaa authorization network default local
aaa authorization network Liste-Groupes local

!

ip dhcp excluded-address 173.10.3.1 173.10.3.99
!
ip dhcp pool Station
import all
network 173.10.3.0 255.255.255.0
dns-server 173.10.3.1 8.8.8.8
default-router 173.10.3.1

!

chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"

!

controller Cellular 0
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6

!

interface Cellular0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer idle-timeout 0
dialer enable-timeout 6
dialer string lte
dialer-group 1
async mode interactive

!

interface Vlan1
ip address 173.10.3.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat inside
ip virtual-reassembly in

!

ip nat inside source list NAT interface Cellular0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0
!
ip access-list extended NAT
permit ip 173.10.3.0 0.0.0.255 any
permit ip any any

 

 

and the return of the profile still not active

 

thanks for help

You ran the cell 0 lte profile create 1 <APN> command?

 

Can you post the output of show cell 0 all?

Review Cisco Networking for a $25 gift card