cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1260
Views
0
Helpful
2
Replies
Highlighted
Beginner

6509 CPU 100% With Jumbo Frames

Problem Details: I have two switches: Nexus 3064 (ver 5.0(3)U1(2)) and Cisco 6509.

The 6509:
1 x WS-x6708-10GE 8 port Ten Gig module version 3.5, firmware 12.2(18r)S1.
2 x sup 720's, with PFC3A.
2 x WS-x6348-rj-45
4 x WS-x6748-ge-tx
The IOS is ipservicesk9-mz 12.2(33)SXH8b.

Both switches have been running fine for quite a while(not connected to each other). I
then ran a fiber connection between port Nexus:1/48 and 6509:Te9/1

The Nexus is configured for jumbo frames:
policy-map type network-qos jumbo
 class type network-qos class-default
  mtu 9000
system qos
 service-policy type network-qos jumbo

interface Vlan323
 no shutdown
 mtu 9000
 ip address 172.19.4.253/24
 ip pim sparse-mode

(all 48 ports are configured the same)
interface Ethernet 1/48 
 switchport access vlan 323
 mtu 9000

The above works on the Nexus switch, I have no problems with jumbo frames inbetween Nexus
users.


On the 6509:
system jumbomtu 9000
interface Vlan 323
 ip address 172.19.4.254 255.255.255.0
 ip pim sparse-mode
 mtu 9000

interface TenGigabit9/1
 switchport
 switchport mode access
 switchport access vlan 323
 mtu 9000


When I ping (of any packet size) from the Nexus to the 6509 @172.19.4.254, the 6509's CPU
goes to 100%. On occasion, we will get 1 out of 20 packets back in the reply.
I reduced the MTU size on the three 6509 parameters until the CPU stopped going 100%.
The magic number is 4175 bytes. 4176 and higher == 100% CPU.
I am willing to put the fiber link to 1500, but how does one change that for just one port on the Nexus? I tried and it refuses to set the mtu. I also tried to setup a new service-policy but that didn't seem to work either. The Nexus users are all jumbo frame users. The users on the 6509 are all 1500 byte frame users, except for one user on a 1 gig port (ws-6748-ge-tx) line card. It is this user whom would like jumbos. I'm more worried about why the 6509's CPU went to 100%! Any idea? thanks! Mark

p.s. I attempted to put in a TAC request, but apparently my devices are not covered under SmartNet

2 REPLIES 2
Beginner

6509 CPU 100% With Jumbo Frames

Are you running sup 720 or 32? What else you have conf on the 6509?If you  have a mile long reflexive acls, extended QoS, or powerful servers feeding in the switch, that's alone can shotup cpu over 75-80%.. Did you check on the fans? Do a sh env and make sure fans are cooling off the modules. Also check cooling in MDF is enough.I don't think the 6748 moduless are "made" to support jumbo frames(not withstahding what Cisco say otherwise).

Beginner

6509 CPU 100% With Jumbo Frames

hi,

Thank you for the reply.

We are running 720's with no ACLs. Normally the 6509 runs at 1% CPU utilization. The CPU only splikes to 100% when we enable jumbo frames past 4175 bytes. We're not even passing traffic yet, just setting the jumbo mtu causes the spike.

Interesting information regarding the 6748's possibly not supporting jumbo frames... I'll have to do some experiments.

Thanks!

Mark

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards