cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Popup Hotspot Using ISR 1000 with WiFi/LTE for Teleworkers and Micro Branchesr
519
Views
0
Helpful
2
Replies
Highlighted
Explorer

7200 - G1 PortChan MTU‏

Hi,

Have a G1, with one active Gig port in a portchan (Second member is currently disconnected, but is also a Gig port on the G1) - No other ports are configured as member ports.

Gi0/1 (Active member) has an mtu of 1998(As does innactive member port) - Portchan doesnt have an mtu configured (So is defaulting to 1500)

Attempting to change the mtu on the portchan, I get the following:

(config)#interface Port-channel1

(config-if)#mtu 1998

% At least one member of the channel group 1 is not a 2FE port adapter

Any suggestions why this is happening?

#sh int gigabitEthernet 0/1

GigabitEthernet0/1 is up, line protocol is up

Hardware is BCM1250 Internal MAC, address is 00d0.bc5b.bc1b (bia 00d0.bc5b.bc1b)

Description: GEC_TO_CSW01_24

MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,

reliability 255/255, txload 6/255, rxload 5/255

#sh int gigabitEthernet 0/3

GigabitEthernet0/3 is down, line protocol is down

Hardware is BCM1250 Internal MAC, address is 00d0.bc5b.bc1b (bia 00d0.bc5b.bc19)

Description: GEC_TO_CSW02_24

MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,

reliability 254/255, txload 1/255, rxload 1/255

#sh int port-channel 1

Port-channel1 is up, line protocol is up

Hardware is GEChannel, address is 00d0.bc5b.bc1b (bia 00d0.bc5b.bc1b)

MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,

reliability 255/255, txload 10/255, rxload 5/255

Phys-int conf:

interface GigabitEthernet0/1

description GEC_TO_CSW01_24

mtu 1998

no ip address

ip mtu 1998

ip flow ingress

duplex auto

speed auto

media-type rj45

no negotiation auto

channel-group 1

end

And portchan1:

interface Port-channel1

no ip address

ip access-group 103 in

ip flow ingress

load-interval 30

duplex full

end


Everyone's tags (4)
2 REPLIES 2
Highlighted
Hall of Fame Expert

7200 - G1 PortChan MTU‏

Hi,

Since gi0/3 is down, can you delete it from portchannel 1 and then try setting the mtu on the portchannel?

interface GigabitEthernet0/3

no channel-group 1

Also, are gi0/1 and 0/3 in the same port adapter?

HTH

Highlighted
Explorer

7200 - G1 PortChan MTU‏

Just an update to this - Replicated the setup on a spare 7200 w/ G1:

(gi0/1 + gi0/3 are on same NPE-G1)

Removing Gi0/3 from channel group made no difference.

Changing mtu on physical Interfaces had no effect (i.e. It remained in the Interface config as "mtu 1998") - I was able to change the mtu on the physical Ints by first issuing:

ip mtu some_other_number_besides_1500 - Once this was done, I was able to set the mtu on the physical Ints to 1500.

But, I was then still unable to change the mtu on the portchan - Still received "

% At least one member of the channel group 1 is not a 2FE port adapter" no matter what value I entered.

So, as a last resort I defaulted the physical Int, then was able to change the mtu on the portchan without it complaining, and then re-added the phyical Int back to the portchan, and I now have 1998 mtu.

(config)#default interface gigabitEthernet 0/3

Building configuration...

GigabitEthernet0/3 taken out of port-channel1

The "[no] negotiation auto" command will have no effect with this interface

GigabitEthernet0/3: Setting default media-type to RJ45

Interface GigabitEthernet0/3 set to default configuration

...

(config)#interface port-channel 1

(config-if)#mtu 1998                            

7200(config-if)#interface GigabitEthernet0/3

7200(config-if)# description GEC_TO_CSW02_24

7200(config-if)# channel-group 1

%Interface MTU set to channel-group MTU 1998.

GigabitEthernet0/3 added as member-1 to port-channel1

%Interface MTU set to channel-group MTU 1998.

7200#sh interfaces port-channel 1

Port-channel1 is up, line protocol is up

  Hardware is GEChannel, address is 0003.e416.7819 (bia 0003.e416.781b)

  MTU 1998 bytes, BW 1000000 Kbit/sec, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation 802.1Q Virtual LAN, Vlan ID  1., loopback not set

  Keepalive set (10 sec)

  Full-duplex, Unknown Speed, media type is unknown media type

  output flow-control is unsupported, input flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

    No. of active members in this channel: 1

        Member 0 : GigabitEthernet0/3 , Full-duplex, 1000Mb/s

7200#sh interfaces gigabitEthernet 0/3

GigabitEthernet0/3 is up, line protocol is up

  Hardware is BCM1250 Internal MAC, address is 0003.e416.7819 (bia 0003.e416.7819)

  Description: GEC_TO_CSW02_24

  MTU 1998 bytes, BW 1000000 Kbit/sec, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255