cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3929
Views
0
Helpful
30
Replies

896 router cannot synchronize for 100Mbit

tsipoulanis
Level 1
Level 1

Hello everyone,

i live in germany and i have a new Internet 100mbit from M-net Provider.

i have found that i need the 30a Profile thats why i configure the next command on the controller.


controller VDSL 0
 operating mode vdsl2
 firmware filename flash:VA_B_38V_d24m.bin

 

and the next commands on the ethernet0.40 because of the tagging to the provider.

interface Ethernet0
 no ip address
!
interface Ethernet0.40
 description DSL Internet Vlan 40tagged
 encapsulation dot1Q 40
 pppoe enable group global
 pppoe-client dial-pool-number 1

 

 

because of the PPPoE i have shutdown the ATM.

 

although the line is all the time down.

 

Router#show controllers vDSL 0
Controller VDSL 0 is DOWN

Daemon Status:           Establishing Link

                        XTU-R (DS)              XTU-C (US)
Chip Vendor ID:         'BDCM'                   'IFTN'
Chip Vendor Specific:   0x0000                   0xC0C8
Chip Vendor Country:    0xB500                   0xB500
Modem Vendor ID:        'CSCO'                   '    '
Modem Vendor Specific:  0x4602                   0x0000
Modem Vendor Country:   0xB500                   0x0000
Serial Number Near:    FCZ214790BM C896VA-K 15.7(3)M1
Serial Number Far:
Modem Version Near:    15.7(3)M1
Modem Version Far:     0xc0c8

Modem Status:            Unknown

DSL Config Mode:         VDSL2
Trained Mode:
TC Mode:                 UNKNOWN
Selftest Result:         0x00
DELT configuration:      disabled
DELT state:              not running

Full inits:             0
Failed full inits:      0
Short inits:            0
Failed short inits:     19

Firmware        Source          File Name
--------        ------          ----------
VDSL            user config     flash:VA_B_38V_d24m.bin

Modem FW  Version:      170321_1253-4.02L.03.B2pvC038v.d24m
Modem PHY Version:      B2pvC038v.d24m
Trellis:                 OFF                      OFF
SRA:                     disabled                disabled
 SRA count:              0                       0
Bit swap:                enabled                 enabled

Training Log :  Stopped
Training Log Filename : flash:vdsllog.bin

Router#

 

 

can anyone help me?

 

best regards,

Thomas

 

 

30 Replies 30

I posted the config from the 897.

thomas 

Hello,

 

just to be sure: you have a standard phone cable connected to the port marked with '12' in the attached image. VDSL uses pins 3 and 4. Have you tried different cables ?

the same cable I connect it and is working on my fritzbox from the provider.

do you think the fritzbox is working with a cable which is not working on cisco router?

and yes i connect to 12 port :)

Hello,

 

here is the thing: I have looked at the M-Net website, and it seems that the only device they actually use (and support) is the Fritz!Box (various models of it). The Fritz!Box uses the Qualcomm Atheros and Lantiq/Intel chipsets, while the Cisco 896/897 uses the Broadcom chipset. I am almost certain that the DSLAMs used by M-Net do not support the Broadcom chipsets. Which means that the hardware is simply not compatible.

 

By the way, I am German myself, so if you feel more comfortable writing in your own language, do so...I don't think anybody else is looking at this thread anyway...

:) if i speak in my own language, you will never understand me :)

i could speak on your own language.

 

it Is so crazy if that is true. i tried so many upgrades of the firmware so that the chipset to be compatible.

and i have to send it back now, which is difficult because we open the box.

 

now i have to sell it , if that is true.

 

and what do you think?

if i go / downgrade from the 100mib to 50Mbit, do i have the same problem? which means my problem is not the profil 30a, but the Chipset of the DSLAM.
right?

 

Vg,

Thomas

like a solution, how do you think if a have a a modem and then try to connect the modem to WAN?
can you please recommend me a modem if that is a solution?

Vg,
Thomas

change provider is a bit difficult. 2 years contract. :(
although, i was thinking something else.
i have to connect the router to a friend office, who wants a second internet Line for a backup.
then we will have an other provider, connect him to VDSL from cisco, like a main internet connection and then i will use the mnet like the backup connection.
then comes the question , how to connect the cisco router to the fritzbox?
is it possible to connect the fritzbox to LAN interface from cisco and create a new vlan for that communication?

VG,
Thomas

Hello,

 

in theory that would be an option. You would need to add the network that runs on the Cisco to the Fritz!Box so it get NATted on the Fritz!Box, and I am not sure if that is possible.

Hello,

 

I have been looking at the Fritz!Box manual, and I think it should be possible to use it as a backup for your Cisco 896/897. It depends on whether you have one or two phone lines available. If you have only one line, you need to use a splitter to connect both devices. What we need to do next is connect the Fritz!Box to one of the GigabitEthernet ports on the Cisco, and when the Cisco connection fails, execute an EEM script on the Cisco that activates the GigabitEthernet port where the Fritz!Box is connected to. It is actually fairly easy to accomplish.

 

If that is what you want to do, I can work out the configuration.

as you explained and understant.... yes that is a solution, so that we finally have some more security features from cisco router and also tools.

can you please send me the config for that interface and nating?
then i will try to have a second interface for the second provider. or ?
or, to have a second provider with DSLAM with the correct chipset. for the vdsl Port.
right?
VG,
Thomas

Hello Thomas,

 

I'll put the configuration together and send it over...

Hello,

 

below the configuration I have pieced together. You need to connect the Fritz!Box to interface GigabitEthernet8, this is your backup. The primary link is configured for O2, you might have to change the VLAN tag if you use another provider.

The EEM script at the bottom clears your NAT entries in case of a failover.

 

Building configuration...


Current configuration : 8600 bytes
!
version 15.7
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname h2h
!
boot-start-marker
boot system flash c800-universalk9-mz.SPA.157-3.M.bin
boot-end-marker
!
logging buffered 51200 warnings
!
aaa new-model
!
!
aaa authentication login local_access local
!
aaa session-id common
clock timezone GMT 1 0
!
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool cvo-pool
import all
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
lease 0 2
!
no ip domain lookup
ip domain name
ip cef
!
multilink bundle-name authenticated
!
cts logging verbose
license udi pid C897VA-K9 sn FCZ2147E3DW
!
username cisco privilege 15 secret 5 aaaaaaaaaaaaa
!
redundancy
!
track 1 ip sla 1 reachability
!
ip local policy route-map SLA_ICMP
!
controller VDSL 0
operating mode auto
firmware filename flash:VA_A_39t_B_38r1_24o_rc1_SDK_4.14L.04A.bin
no cdp run
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
cdp enable
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface Ethernet0
no ip address
!
interface Ethernet0.7
description Primary VDSL Internet Verbindung O2 - VLAN 7 tagged
encapsulation dot1Q 7
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface GigabitEthernet0
no ip address
spanning-tree portfast
!
interface GigabitEthernet1
no ip address
spanning-tree portfast
!
interface GigabitEthernet2
no ip address
spanning-tree portfast
!
interface GigabitEthernet3
no ip address
spanning-tree portfast
!
interface GigabitEthernet4
no ip address
spanning-tree portfast
!
interface GigabitEthernet5
no ip address
spanning-tree portfast
!
interface GigabitEthernet6
no ip address
spanning-tree portfast
!
interface GigabitEthernet7
no ip address
spanning-tree portfast
!
interface GigabitEthernet8
description Backup Link To Fritz!Box
ip address dhcp
duplex auto
speed auto
!
interface Vlan1
description LAN
ip address 10.10.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1412
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname yourhost@yourlogindomain
ppp chap password yourpassword
ppp pap sent-username yourusername
ppp ipcp dns request
ppp ipcp mask request
no cdp enable
ip tcp adjust-mss 1452
!
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip dns server
ip nat inside source route-map WAN_PRIMARY interface Dialer1 overload
ip nat inside source route-map WAN_BACKUP interface GigabitEthernet8 overload
!
ip route 0.0.0.0 0.0.0.0 Dialer1 track 1
ip route 0.0.0.0 0.0.0.0 GigabitEthernet8 dhcp 10
!
ip sla 1
icmp-echo 8.8.8.8 source-interface Dialer1
frequency 10
!
ip sla schedule 1 life forever start-time now
!
access-list 100 permit ip 10.10.10.0 0.0.0.255 any
!
access-list 101 permit icmp any host 8.8.8.8
!
route-map WAN_PRIMARY permit 10
match ip address 100
match interface Dialer1
!
route-map WAN_BACKUP
match ip address 100
match interface GigabitEthernet8
!
route-map SLA_ICMP permit 10
match ip address 101
set interface Dialer1
!
ip ssh time-out 60
ip ssh server algorithm encryption aes128-ctr aes192-ctr aes256-ctr
ip ssh client algorithm encryption aes128-ctr aes192-ctr aes256-ctr
!
dialer-list 1 protocol ip permit
!
event manager applet CLEAR_NAT
event track 1 state down
event syslog pattern “TRACKING-5-STATE”
action 1 cli command “enable”
action 2 cli command “clear ip nat translation forced”
action 3 cli command “exit”
!
event manager applet CLEAR_NAT
event track 1 stateup
event syslog pattern “TRACKING-5-STATE”
action 1 cli command “enable”
action 2 cli command “clear ip nat translation forced”
action 3 cli command “exit”

sorry for the late respond,
i did some changes.... and use your help too.

I use my fritzbox, i connect the cisco router as you said to fritzbox with the interface gigabitethernet 8, without any other vdsl / wan Line.
which means, in that moment i have an IP from the DHCP server of the fritzbox.
i ping from cisco the fritzbox,
i ping from laptop, which is connected to cisco, the fritzbox IP (natting is working).
but i cannot ping 8.8.8.8 , and i dont have internet from LAN of the cisco router.
can you advice?
check my current config.
Building configuration...
Current configuration : 7900 bytes
!
! Last configuration change at 21:22:52 GMT Tue Feb 6 2018 by cisco
!
version 15.7
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname name
!
boot-start-marker
boot system flash c800-universalk9-mz.SPA.157-3.M.bin
boot-end-marker
!
!
logging buffered 51200 warnings
!
aaa new-model
!
!
aaa authentication login local_access local
!
!
!
!
!
aaa session-id common
clock timezone GMT 1 0
!
crypto pki trustpoint TP-self-signed-2593388234
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2593388234
revocation-check none
rsakeypair TP-self-signed-2593388234
!
!
crypto pki certificate chain TP-self-signed-2593388234
certificate self-signed 01
3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 32353933 33383832 3334301E 170D3138 30313131 31393134
31325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 35393333
38383233 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100BE76 1A5948FF A724EDD2 3FBAB3FE F04630EF FAEC77CF CA2B64AB EC405E32
E885D252 A0DB59B9 662ADB8B 1EC57A07 CE6D51CA 01EA6E1B EEE7781A 3CDB016F
B684F523 6E75CCB4 59349340 8444681F 038853E1 C468EB1A 0675E3D1 9EBB2586
7457050C 05A701EC 62233918 4DF84F3B E774B4A2 DC9BC22E 537D218B 4E9062CD
4F2B0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
551D2304 18301680 142300A4 37357201 98571FF2 CE523C1E B250B4C9 4E301D06
03551D0E 04160414 2300A437 35720198 571FF2CE 523C1EB2 50B4C94E 300D0609
2A864886 F70D0101 05050003 8181009E 7347D7E7 E32712A3 2D819DD3 9FB8244E
6A9F0594 73C94921 D7E6A17C B0637FFA 130784A9 20A55716 4E2BFA6A CF00BEF4
E1690C2F 35ECE93E 88B444CB 8469E334 F2889C30 1A104637 0C56CA70 1B918932
D5B9205B 55A01248 93629A4E DCAF28EE 7F46BA9B E6F77395 24D56021 87D37008
063E3B45 C1EED5E3 4B2F6272 64BA3C
quit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!


!
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool cvo-pool
import all
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
lease 0 2
!
!
!
no ip domain lookup
ip domain name h2h.com
ip inspect name DEFAULT100 ftp
ip inspect name DEFAULT100 h323
ip inspect name DEFAULT100 icmp
ip inspect name DEFAULT100 netshow
ip inspect name DEFAULT100 rcmd
ip inspect name DEFAULT100 realaudio
ip inspect name DEFAULT100 rtsp
ip inspect name DEFAULT100 esmtp
ip inspect name DEFAULT100 sqlnet
ip inspect name DEFAULT100 streamworks
ip inspect name DEFAULT100 tftp
ip inspect name DEFAULT100 tcp
ip inspect name DEFAULT100 udp
ip inspect name DEFAULT100 vdolive
ip cef
ipv6 unicast-routing
ipv6 cef
ipv6 dhcp pool NODE-DHCPV6
dns-server 2001:A60::53:1
dns-server 2001:A60::53:2
!
ipv6 dhcp pool STATELESS
import dns-server
domain-name Import
!
!
!
flow record nbar-appmon
match ipv4 source address
match ipv4 destination address
match application name
collect interface output
collect counter bytes
collect counter packets
collect timestamp absolute first
collect timestamp absolute last
!
!
flow monitor application-mon
cache timeout active 60
record nbar-appmon
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
cts logging verbose
license udi pid C897VA-K9 sn FCZ2147E3DW
!
!
object-group network local_cws_net
!
object-group network local_lan_subnets
any
!
object-group network vpn_remote_subnets
any
!
username cisco privilege 15 secret aaaaaaaaa
!
redundancy
!
!
!
!
!
controller VDSL 0
firmware filename flash:VA_A_39t_B_38r1_24o_rc1_SDK_4.14L.04A.bin
no cdp run
!
track 1 ip sla 1 reachability
!
zone security LAN
zone security WAN
zone security VPN
zone security DMZ
!
!
!
!
!
!
!
!
!
!
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
cdp enable
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface Ethernet0
no ip address
!
interface GigabitEthernet0
no ip address
spanning-tree portfast
!
interface GigabitEthernet1
no ip address
spanning-tree portfast
!
interface GigabitEthernet2
no ip address
spanning-tree portfast
!
interface GigabitEthernet3
no ip address
spanning-tree portfast
!
interface GigabitEthernet4
no ip address
spanning-tree portfast
!
interface GigabitEthernet5
no ip address
spanning-tree portfast
!
interface GigabitEthernet6
no ip address
spanning-tree portfast
!
interface GigabitEthernet7
switchport mode access
no ip address
spanning-tree portfast
!
interface GigabitEthernet8
description Backup Link To Fritz!Box
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Vlan1
ip address 10.10.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ipv6 address prefix-from-provider ::100:0:0:0:1/64
ipv6 enable
!
interface Dialer2
no ip address
!
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip dns server
ip nat inside source route-map WAN_BACKUP interface GigabitEthernet8 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet8
ip ssh time-out 60
ip ssh server algorithm encryption aes128-ctr aes192-ctr aes256-ctr
ip ssh client algorithm encryption aes128-ctr aes192-ctr aes256-ctr
!
ip access-list extended nat-list
permit ip object-group local_lan_subnets any
!
ip sla auto discovery
ip sla 1
icmp-echo 8.8.8.8 source-interface Dialer1
frequency 10
ip sla schedule 1 life forever start-time now
dialer-list 1 protocol ip permit
ipv6 ioam timestamp
!
route-map WAN_BACKUP permit 10
match ip address 100
match interface GigabitEthernet8
!
route-map SLA_ICMP permit 10
match ip address 101
!
route-map WAN_PRIMARY permit 10
match ip address 100
!
access-list 1 permit 10.10.10.0 0.0.0.255
access-list 100 permit ip 10.10.10.0 0.0.0.255 any
access-list 101 permit icmp any host 8.8.8.8
access-list 197 permit icmp any host 8.8.8.8
!
!
!
control-plane
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
!
line con 0
login authentication local_access
no modem enable
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
login authentication local_access
transport input telnet ssh
line vty 5 15
access-class 23 in
privilege level 15
transport input telnet ssh
!
scheduler allocate 20000 1000
!
!
!
!
!
event manager applet CLEAR_NAT
event syslog pattern "b"
action 1 cli command "b"
action 2 cli command "b"
action 3 cli command "b"
!
end
Review Cisco Networking for a $25 gift card