cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
277
Views
0
Helpful
3
Replies
Highlighted
Beginner

Accessing exteral address internally

Accessing exteral address internally.

Hi, hopefully someone can point me in the right direction here...

I have a mail server, with external access which works fine for external access thorugh our router (a 1941). I have a laptop which connects to a wireless network that is inside our router. When attempting to navigate to the webmail or use outlook, it cannot connect.

The laptop is configured to access the mail through the external path as it would be offsite occasionally.

I think the problem seems to be that the traffic is not leaving the router to come back internally. The laptop can ping the external address ok.

I read about something called hairpinning - is this what i need to be looking at?

thanks for any help

3 REPLIES 3
Highlighted
Advisor

Hi,

as already discussed in a lot of threads here on CSC, NAT hairpinning is not implemented on Cisco routers.

There are multiple workarounds:

1) use a DNS record on an inside DNS server

2) use local hosts file on the machine

3) use an external server and a static NAT entry which will leverage the DNS rewrite feature

4) use NAT on a stick

I think in your case as you only have one PC you can safely use option 2.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Highlighted

hi thanks for the reply,

If i used option 2, that would allow the connection internally, but then when the laptop left the site and tried to connect from externally the hosts file would be redirecting it to an internal address that it wouldn't be able to see would it not?

that was why i was looking at something on the router side, so that it would work when on or off site without making changes.

thanks

Highlighted

Hi,

then option 4 is probably what you are searching for.

http://ccie-in-3-months.blogspot.be/2008/12/nat-hairpinning-using-nat-pools-pbr.html

I've never implemented but it seems to be working,

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.