01-03-2011 10:27 AM - edited 03-04-2019 10:56 AM
Hi
I have a question , I have a cisco router with an rj-11 interface thats connected to the internet.
first of all I would like a breif explenation about all the interfaces that I have and what does it all mean , I have a Dialer interface
an ATM interface and a virtual-access interface , I dont understand what role each interface plays.
second of all I would like to "update" the interface bandwidth to the correct value. on which interface should I configure this ?
and which value am I supposed to input , the download or upload bandwidth ?
also , I want to apply QoS on the internet facing interface , which is it ?
many thanks , this whole issue is a little complicated for me .
01-03-2011 12:34 PM
RJ-11 is Registered Jack most commonly associated with plain old telephone services.
Virtual access -
http://www.networkers-online.com/blog/2008/07/what-is-a-virtual-templateaccess-interface/ has a good answer.
The atm interface is the physical transport for your dsl signal
The dialer interface is the Logical entities that use a per-destination dialer profile. Any number of dialer interfaces can be created in a router. All configuration settings specific to the destination go in the dialer interface configuration. Each dialer interface uses a dialer pool, which is a pool of physical interfaces (ISDN BRI and PRI, asynchronous-modem, and synchronous serial). Usually does the authentication with the ISP, IP addressing....
Your bandwidth issue indicates you have an asnychronous environment, with more download speed than up load speed.
What to use would depend on what your needs are, I'd suggest using upload.
What are your intentions with QOS ? Is there something in place with your ISP?
01-03-2011 11:54 PM
hi , thanks for your reply , I also asked about the virtual-access interface , would appriciate if you could tell me what its used for and why it was created
I want to implement a QoS policy that preffers traffic coming from 2 stations in the LAN going to the internet
and also another policy that prefers traffic from the internet going back to those stations
I want to reserve bandwidth in case of congestion , so I looked at the bandwidth configured on the interface , its 56k
I want to change that to the real value of the ADSL link , its 1.5M download and 0.5M upload
If I understood correctly all the configuration of the bandwidth and of the QoS takes place only on the dialer interface (?).
so basically I want to know which value should I configure
and also I need to apply a policy map that identifies and reserve bandwidth for the 2 stations , if I apply it outbound on the dialer
interface how would I be able to recognize traffic trom the staitions ? ( I cant use mac-address and cant use IP addresses because of nat on the
dilaer interface )
about the internet download control I understand I have to work with the ISP , what do I need to ask them to do , and what do I have to do
on my end?
thanks for all the help
01-04-2011 07:57 AM
here is a link to the description of a virtual template, Cisco writes better than I do.
http://www.cisco.com/en/US/docs/ios/12_0/dial/configuration/guide/dcvtemp.html
As far as your other concerns, what model router are you using ?
can you post a copy of the current config (removing any details that no one needs to know.)
01-04-2011 09:14 AM
here is my config of the 837 router
I used a class-map to identify the 2 stations by their mac-address
I then used a policy-map to mark their packets
I used another class-map to identify the markings
I then used a policy-map to set the bandwidth and applied it outbound on the dialer interface for the upload traffic
============
ip dhcp pool pool1
import all
network x.x.x.x 255.255.255.0
default-router x.x.x.x
dns-server x.x.x.x
lease infinite
!
class-map match-all shob-stations1
match source-address mac aaaa.bbbb.cccc
match source-address mac aaaa.bbbb.cccc
class-map match-any station-traffic
match dscp af41
!
!
policy-map mark-shob
class shob-stations1
set dscp af41
policy-map QoS_upload
class station-traffic
!
interface Ethernet0
ip address x.x.x.x 255.255.255.0
ip nat inside
ip virtual-reassembly
service-policy input mark-shob
load-interval 30
no cdp enable
hold-queue 1000 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
pvc 8/48
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly
service-policy output QoS_upload
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp pap sent-username xxxxx
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
no ip http secure-server
ip nat inside source list 100 interface Dialer0 overload
access-list 100 permit ip any any
!
dialer-list 1 protocol ip permit
========================
thanks for your time
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide