09-08-2017 02:58 AM - edited 03-05-2019 09:06 AM
I am receiving route on each router but its showing inaccessible
"inaccessible"
Router-1
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
no ip address
ipv6 address 2001:101:1:1::1/128
!
interface FastEthernet0/0
ip address 172.16.1.1 255.255.255.252
duplex half
ipv6 address 2001::1/64
ipv6 enable
!
!
router bgp 101
bgp router-id 1.1.1.1
bgp log-neighbor-changes
neighbor 172.16.1.2 remote-as 102
!
address-family ipv4
no neighbor 172.16.1.2 activate
exit-address-family
!
address-family ipv6
network 2001:101:1:1::1/128
neighbor 172.16.1.2 activate
neighbor 172.16.1.2 route-map SET_IPV6_NEXT_HOP_OUT out
exit-address-family
!
route-map SET_IPV6_NEXT_HOP_OUT permit 10
set ipv6 next-hop 2001::1
Router 2
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
no ip address
ipv6 address 2001:102:2:2::2/128
!
interface FastEthernet0/0
ip address 172.16.1.2 255.255.255.252
duplex half
ipv6 address 2001::2/64
ipv6 enable
!
!
router bgp 102
bgp router-id 2.2.2.2
bgp log-neighbor-changes
neighbor 172.16.1.1 remote-as 101
!
address-family ipv4
no neighbor 172.16.1.1 activate
exit-address-family
!
address-family ipv6
network 2001:102:2:2::2/128
neighbor 172.16.1.1 activate
neighbor 172.16.1.1 route-map SET_IPV6_NEXT_HOP_OUT out
exit-address-family
!
!
route-map SET_IPV6_NEXT_HOP_OUT permit 10
set ipv6 next-hop 2001::2
router -1 o/p
R1#sh bgp ipv6 unicast
BGP table version is 2, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, x best-external, f RT-Filter
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 2001:101:1:1::1/128
:: 0 32768 i
* 2001:102:2:2::2/128
2001::2 0 0 102 i
R1#sh bgp ipv6 unicast 2001:102:2:2::2/128
BGP routing table entry for 2001:102:2:2::2/128, version 0
Paths: (1 available, no best path)
Not advertised to any peer
102
2001::2 (FE80::C802:B8FF:FE46:0) (inaccessible) from 172.16.1.2 (2.2.2.2)
Origin IGP, metric 0, localpref 100, valid, external
router 2
R2#sh bgp ipv6 unicast
BGP table version is 3, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, x best-external, f RT-Filter
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
* 2001:101:1:1::1/128
2001::1 0 0 101 i
*> 2001:102:2:2::2/128
:: 0 32768 i
R2#sh bgp ipv6 unicast 2001:101:1:1::1/128
BGP routing table entry for 2001:101:1:1::1/128, version 0
Paths: (1 available, no best path)
Not advertised to any peer
101
2001::1 (FE80::C801:B8FF:FE45:0) (inaccessible) from 172.16.1.1 (1.1.1.1)
Origin IGP, metric 0, localpref 100, valid, external
Solved! Go to Solution.
09-17-2017 08:59 PM
Because of the IPv4 to IPv6 next hop conversion, older IOS software versions considered the next hop not to be directly connected and required either "ebgp multihop" or the "disable-connected-check" knob to be configured.
This is not the case with more recent IOS software versions.
As a side note, it is generally considered best practice to use an IPv6 BGP session (IPv6 transport) to carry IPv6 updates. This way if the ipv6 dataplane fails (ACL, software bug, etc) the IPv6 updates will stop being conveyed.
Regards,
09-08-2017 05:55 AM
I just loaded the config you posted on 2 7200 (gns3) running IOS 15.2 and it worked fine:
R1#sh ipv6 route
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination
NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, l - LISP
C 2001::/64 [0/0]
via FastEthernet0/0, directly connected
L 2001::1/128 [0/0]
via FastEthernet0/0, receive
LC 2001:101:1:1::1/128 [0/0]
via Loopback0, receive
B 2001:102:2:2::2/128 [20/0]
via FE80::C802:2AFF:FE3C:8, FastEthernet0/0
L FF00::/8 [0/0]
via Null0, receive
R1#sh ip bgp ipv6 u 2001:102:2:2::2/128
BGP routing table entry for 2001:102:2:2::2/128, version 3
Paths: (1 available, best #1, table default)
Not advertised to any peer
Refresh Epoch 1
102
2001::2 (FE80::C802:2AFF:FE3C:8) from 172.16.1.2 (2.2.2.2)
Origin IGP, metric 0, localpref 100, valid, external, best
rx pathid: 0, tx pathid: 0x0
R1#
You might have hitted a bug in the IOS you are running.
09-08-2017 05:56 AM
Hi
You should verify if the router who is receiving the inaccessible prefix knows the point to point networks into the BGP table. You could try advertising them into BGP.
09-16-2017 10:28 AM
Actually after adding ebgp multihop under BGP ipv6 address-family it worked, found this solution on the Cisco forum itself.
But don't understand the need to do this.
09-17-2017 03:26 PM
Hi,
Please let me check the configuration again.
Regards.
09-17-2017 08:59 PM
Because of the IPv4 to IPv6 next hop conversion, older IOS software versions considered the next hop not to be directly connected and required either "ebgp multihop" or the "disable-connected-check" knob to be configured.
This is not the case with more recent IOS software versions.
As a side note, it is generally considered best practice to use an IPv6 BGP session (IPv6 transport) to carry IPv6 updates. This way if the ipv6 dataplane fails (ACL, software bug, etc) the IPv6 updates will stop being conveyed.
Regards,
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide