cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

272
Views
0
Helpful
10
Replies
Highlighted
Beginner

Allow Core2 to see static route from Core1 for IPSLA

So this post is somewhat related to another post : https://community.cisco.com/t5/routing/using-ipsla-and-track-for-multiple-static-routes/td-p/3915680

 

However the question is different now since we've determined that we don't have 2 MPLS links (1 into each core). We've discovered that our datacenter is only giving us 1 MPLS handoff so I only have 1 path for the MPLS into Core1. I'm using IPSLA's with static routes to determine if datacenter to datacenter traffic will traverse the MPLS link or our Internet VPN link. I have everything working great on Core1. However my problem is that Core2 can't 'see' the L3 port at the other datacenter. I'm stuck on what I need to set up on Core1 to allow Core2 to see its directly connected route for the IPSLA. Relevant configs are below.

(Please keep in mind I'm not focused on IPSLA's on Core2 just yet. Once I get the routing sorted I can get the IPSLA's without issue.)

 

############ CORE 1 ##############

vlan 150
name MPLS-TEST-VLAN
!
interface vlan 150
desc MPLS-TEST-VLAN
ip add 10.101.150.2 255.255.255.0
standby version 2
standby 150 ip 10.101.150.1
standby 150 pri 200
standby 150 pre
!
int gig0/20
desc MPLS
no switchport
ip add 10.255.255.1 255.255.255.252
!
!
ip sla 150
icmp-echo 10.255.255.2 source-interface gig0/20
threshold 150
timeout 1000
frequency 2
ip sla schedule 150 life forever start-time now
!
track 150 ip sla 150 reachability
delay down 15 up 30
!
!
ip route 10.101.0.0 255.255.0.0 10.255.255.2 track 150
ip route 10.101.0.0 255.255.0.0 10.219.254.10 200
!
ip route 0.0.0.0 0.0.0.0 10.219.254.10
!

############# CORE 2 ###############

vlan 150
name MPLS-TEST-VLAN
!
interface vlan 150
desc MPLS-TEST-VLAN
ip add 10.101.150.3 255.255.255.0
standby version 2
standby 150 ip 10.101.150.1
standby 150 pri 150
standby 150 pre
!
!
ip route 10.102.0.0 255.255.0.0 10.219.0.1 (IP of Core1)
ip route 10.102.0.0 255.255.0.0 10.219.254.10 200
!
ip route 0.0.0.0 0.0.0.0 10.219.254.10
!

 What I need is for Core2 to be able to ping the other side of the MPLS (10.255.255.2). Once Core2 can ping that interface I can get my IPSLA set up.

Everyone's tags (2)
10 REPLIES 10
VIP Mentor

Re: Allow Core2 to see static route from Core1 for IPSLA

Hello,

 

so from 10.255.255.2, you cannot 'see' 10.255.255.1, and vice versa ?

Beginner

Re: Allow Core2 to see static route from Core1 for IPSLA

On core2, when I try and ping 10.255.255.2 it does not reply.

I need core2 to be able to ping 10.255.255.2 (which is the directly connected route on core1)

VIP Mentor

Re: Allow Core2 to see static route from Core1 for IPSLA

Hello,

 

what if you add 'mpls ip' to both interfaces ?

 

int gig0/20
desc MPLS
no switchport
ip add 10.255.255.1 255.255.255.252

mpls ip

Beginner

Re: Allow Core2 to see static route from Core1 for IPSLA

that is not an available command for me.

I wouldn't focus so much on the fact it's an mpls. It's a routing issue of some kind, I just dont know whats needed to make core2 be able to ping through core1 over to the other side of the point to point link.

VIP Mentor

Re: Allow Core2 to see static route from Core1 for IPSLA

Hello,

 

try and change the static routes to specify the interface AND the next hop:

 

ip route 10.101.0.0 255.255.0.0 GigabitEthernet0/20 10.255.255.2 track 150

VIP Mentor

Re: Allow Core2 to see static route from Core1 for IPSLA

Hello

can you post the following form both rtrs

Sh ip in brief

Sh ip route 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: Allow Core2 to see static route from Core1 for IPSLA

######## CORE 1 ###############

core01#sh ip in br | i Vlan150
Vlan150                10.101.150.2    YES manual up                    up
core01#sh ip in br | i 0/20
GigabitEthernet0/20    10.255.255.1    YES manual up                    up
core01#sh run | s route
ip route 10.102.0.0 255.255.0.0 10.255.255.2 track 150
ip route 0.0.0.0 0.0.0.0 10.219.254.10
ip route 10.102.0.0 255.255.0.0 10.219.254.10 200


S*    0.0.0.0/0 [1/0] via 10.219.254.10
      10.0.0.0/8 is variably subnetted, 17 subnets, 5 masks
C        10.101.150.0/24 is directly connected, Vlan150
L        10.101.150.2/32 is directly connected, Vlan150
S        10.102.0.0/16 [1/0] via 10.255.255.2
C        10.255.255.0/30 is directly connected, GigabitEthernet0/20
L        10.255.255.1/32 is directly connected, GigabitEthernet0/20



############ CORE 2 ################

core02#sh run | s route
ip route 0.0.0.0 0.0.0.0 10.219.254.10
ip route 10.102.0.0 255.255.0.0 10.219.0.1
ip route 10.255.255.0 255.255.255.0 10.219.0.1


S*    0.0.0.0/0 [1/0] via 10.219.254.10
      10.0.0.0/8 is variably subnetted, 20 subnets, 4 masks
C        10.101.150.0/24 is directly connected, Vlan150
L        10.101.150.3/32 is directly connected, Vlan150
S        10.102.0.0/16 [1/0] via 10.219.0.1
S        10.255.255.0/24 [1/0] via 10.219.0.1
VIP Mentor

Re: Allow Core2 to see static route from Core1 for IPSLA

Hello

Can you post the output without any pipe and include for both switches.

 

sh ip int brief
sh ip route 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: Allow Core2 to see static route from Core1 for IPSLA

No.

These are the relevant routes and interfaces pertaining to this problem. Other information is confidential.

VIP Mentor

Re: Allow Core2 to see static route from Core1 for IPSLA

Hello

So you have static routing and no directly connected interfaces between the to switches

so the next question is does your specified next hops from both cores have the correct routing.

 

 

core 1
0.0.0.0/0 [1/0] via 10.219.254.10 <---

 

core 2
10.255.255.0/24 [1/0] via 10.219.0.1 <---

 

When you traceroute whats the output where does it fail?



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
CreatePlease to create content
Content for Community-Ad
FusionCharts will render here