04-27-2024 01:36 PM
Hello,
Very new to the world of ASA. I just purchased a 5516 model to use as my router for my home lab. The goal is to replace my ISP-provided router with the ASA.
When I try to connect the ethernet cable from the ONT to my outside interface on the ASA, it does not pull an IP address. When I revert the connection to the ISP-provided router, it works just fine.
Here are the commands that I entered to try to accomplish this connection on the ASA:
*****************************************************
config t
!
interface GigabitEthernet1/1
description to Intenet
nameif outside
security-level 0
ip address dhcp setroute
!
!
interface GigabitEthernet1/2
description to LAN
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
dhcpd dns 8.8.8.8
dhcpd auto_config outside
!
dhcpd address 192.168.11.20-192.168.1.100 inside
dhcpd enable inside
!
object network INSIDE_NETWORK
nat (inside,outside) dynamic interface
!
*****************************************************
As you can tell, I want G1/1 to be my WAN interface, and G0/2 to be my LAN's default gateway.
Here is my ISP rotuer's WAN interface configuration. On it, I notice that 802.1q encapsulation is configured, along with an IGMP proxy.
What am I missing in my ASA WAN interface configuration?
Solved! Go to Solution.
04-27-2024 01:46 PM
Hello,
it looks like your ISP is using Vlan 201. Try the config below:
interface GigabitEthernet1/1.201
vlan 201
description to Intenet
nameif outside
security-level 0
ip address dhcp setroute
04-27-2024 01:46 PM
Hello,
it looks like your ISP is using Vlan 201. Try the config below:
interface GigabitEthernet1/1.201
vlan 201
description to Intenet
nameif outside
security-level 0
ip address dhcp setroute
04-28-2024 06:22 AM
Thank you!! I will try this as soon as I can handle some downtime, and then update the thread.
04-27-2024 02:12 PM
You can try as below :
clear interface GigabitEthernet1/1
interface GigabitEthernet1/1.201
description to Intenet
vlan 201
nameif outside
security-level 0
ip address dhcp setroute
no shutdown.
other note check your DHCP information not correct.
dhcpd address 192.168.11.20-192.168.1.100 inside
04-28-2024 06:23 AM
I appreciate the response, if the first method proposed doesn't work I will try this!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide