08-23-2023 03:32 AM - edited 08-23-2023 03:37 AM
My ASA configuration
ASA Version 8.4(2)
!
hostname ASA
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface GigabitEthernet0
nameif outside
security-level 0
ip address 172.168.1.2 255.255.255.0
!
interface GigabitEthernet1
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet2
nameif INSIDE
security-level 100
ip address 10.10.10.1 255.255.255.0
!
interface GigabitEthernet3
nameif DMZ
security-level 90
ip address 20.20.20.1 255.255.255.0
!
ftp mode passive
access-list INSIDE extended permit icmp any any
access-list INSIDE extended permit icmp any any echo-reply
pager lines 24
mtu outside 1500
mtu INSIDE 1500
mtu DMZ 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
access-group INSIDE in interface INSIDE
access-group INSIDE in interface DMZ
!
router ospf 1
router-id 3.3.3.3
network 10.10.10.0 255.255.255.0 area 0
network 11.11.11.0 255.255.255.0 area 0
network 20.20.20.0 255.255.255.0 area 1
network 21.21.21.0 255.255.255.0 area 1
log-adj-changes
redistribute static
!
route outside 0.0.0.0 0.0.0.0 172.168.1.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
telnet timeout 5
ssh timeout 5
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
!
!
prompt hostname context
no call-home reporting anonymous
call-home
profile CiscoTAC-1
no active
destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
destination address email callhome@cisco.com
destination transport-method http
subscribe-to-alert-group diagnostic
subscribe-to-alert-group environment
subscribe-to-alert-group inventory periodic monthly
subscribe-to-alert-group configuration periodic monthly
subscribe-to-alert-group telemetry periodic daily
crashinfo save disable
Cryptochecksum:0d97b54f91d2b923aba6434d3e066395
: end
ASA#
My R7 config
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R7
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.10.10.2 255.255.255.0
duplex full
!
interface FastEthernet1/0
ip address 11.11.11.1 255.255.255.0
duplex full
!
interface FastEthernet2/0
no ip address
shutdown
duplex full
!
interface FastEthernet3/0
no ip address
shutdown
duplex full
!
interface FastEthernet4/0
no ip address
shutdown
duplex full
!
router ospf 1
router-id 1.1.1.1
redistribute static
network 10.10.10.0 0.0.0.255 area 0
network 11.11.11.0 0.0.0.255 area 0
network 0.0.0.0 255.255.255.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 10.10.10.1
ip route 11.11.11.0 255.255.255.0 10.10.10.1
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
My R8 config,
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R8
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 20.20.20.2 255.255.255.0
duplex full
!
interface FastEthernet1/0
ip address 21.21.21.1 255.255.255.0
duplex full
!
interface FastEthernet2/0
no ip address
shutdown
duplex full
!
interface FastEthernet3/0
no ip address
shutdown
duplex full
!
interface FastEthernet4/0
no ip address
shutdown
duplex full
!
router ospf 1
router-id 2.2.2.2
redistribute static
network 20.20.20.0 0.0.0.255 area 1
network 21.21.21.0 0.0.0.255 area 1
network 0.0.0.0 255.255.255.255 area 1
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 20.20.20.1
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
i am unable to ping the windows-server from the firefox why?
Kindly provide your assistance Thanks in advance.
08-23-2023 05:43 AM
Hi @ashz14387
Can I see "show ip route" from devices ? If you run tracert from windows to firefox where does it stops?
08-23-2023 05:50 AM
For R7,
S* 0.0.0.0/0 [1/0] via 10.10.10.1
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
O IA 2.2.2.2 [110/12] via 10.10.10.1, 01:17:15, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.10.10.0/24 is directly connected, FastEthernet0/0
L 10.10.10.2/32 is directly connected, FastEthernet0/0
11.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 11.11.11.0/24 is directly connected, FastEthernet1/0
L 11.11.11.1/32 is directly connected, FastEthernet1/0
20.0.0.0/24 is subnetted, 1 subnets
O IA 20.20.20.0 [110/11] via 10.10.10.1, 01:17:10, FastEthernet0/0
21.0.0.0/24 is subnetted, 1 subnets
O IA 21.21.21.0 [110/12] via 10.10.10.1, 01:17:10, FastEthernet0/0
For R8,
S* 0.0.0.0/0 [1/0] via 20.20.20.1
1.0.0.0/32 is subnetted, 1 subnets
O IA 1.1.1.1 [110/12] via 20.20.20.1, 01:17:42, FastEthernet0/0
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 1 subnets
O IA 10.10.10.0 [110/11] via 20.20.20.1, 01:17:42, FastEthernet0/0
11.0.0.0/24 is subnetted, 1 subnets
O IA 11.11.11.0 [110/12] via 20.20.20.1, 01:17:42, FastEthernet0/0
20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 20.20.20.0/24 is directly connected, FastEthernet0/0
L 20.20.20.2/32 is directly connected, FastEthernet0/0
21.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 21.21.21.0/24 is directly connected, FastEthernet1/0
L 21.21.21.1/32 is directly connected, FastEthernet1/0
For ASA,
Inside,
O 1.1.1.1 255.255.255.255 [110/11] via 10.10.10.2, 1:18:22, INSIDE
C 10.10.10.0 255.255.255.0 is directly connected, INSIDE
O 11.11.11.0 255.255.255.0 [110/11] via 10.10.10.2, 1:18:22, INSIDE
Outside,
C 172.168.1.0 255.255.255.0 is directly connected, outside
S* 0.0.0.0 0.0.0.0 [1/0] via 172.168.1.1, outside
DMZ,
O 2.2.2.2 255.255.255.255 [110/11] via 20.20.20.2, 1:19:03, DMZ
O 21.21.21.0 255.255.255.0 [110/11] via 20.20.20.2, 1:19:03, DMZ
C 20.20.20.0 255.255.255.0 is directly connected, DMZ,
Traceroute from Firefox and windows stops once it reaches ASA
08-23-2023 06:08 AM
All seems ok to me. I would remove the security level on the asa inside and dmz interfaces just to make sure this is the ASA denying the traffic or not.
09-05-2023 06:13 AM
Thanks it works, i have configured the security level as 100 for both INSIDE & DMZ and i forgot to include inter-traffic command.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide