cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
912
Views
0
Helpful
10
Replies
Hubert Kupper
Beginner

asr 1001-x and catalyst 4510+R

Hi, we had a WS-C3750X-12S-S and a 3800 router configured with hsrp for the Internet. Both routers were attached to a WS-C3750E-24TD-E switch. The router from our provider is attached to a 4510+R switch. The 4510+R was attached to the WS-C3750E-24TD-E with a routed port at local side and a switchport (same for both routers) on the 3750 side. This worked fine. Now we changed our internet routers to 2 asr1001-X routers. In a few month we get a 10Gig connection to our provider so we have to connect both asr1001-X to the 4510+R. With the same interface configuration like on the 3750E it won't work. When we set the interface on the 4510+R as a routed port then one asr is reacheble but the second not.

 

Here are the interface configs:

 

3750E:

interface GigabitEthernet1/0/8
description Uplink Router1 0/1
switchport mode access
switchport nonegotiate
spanning-tree guard loop
end

 

interface GigabitEthernet1/0/9
description Uplink Router1 0/0
spanning-tree guard loop
end

interface GigabitEthernet1/0/10
description Uplink 4510 4/0/2 routed port
spanning-tree portfast
spanning-tree guard loop
end

 

4510+R:

interface GigabitEthernet1/2
description uplink 3750E
no switchport
ip address X.X.X.X X.X.X.X
no ip redirects
no ip proxy-arp
ip ospf network point-to-multipoint
end

interface GigabitEthernet0/0/1
description LAN
ip flow monitor Netflow-Mon-v5 input
ip flow monitor Netflow-Mon-v5 output
ip address X.X.X.X X.X.X.X
no ip redirects
no ip proxy-arp
ip nbar protocol-discovery
standby version 2

standby 0 ip X.X.X.X
standby 0 timers 20 60
standby 0 preempt
ip ospf network point-to-multipoint
ip ospf cost 100
negotiation auto
cdp enable
!
interface GigabitEthernet0/0/2
description Anschluss an Provider
ip flow monitor Netflow-Mon-v5 input
ip flow monitor Netflow-Mon-v5 output
ip address X.X.X.X X.X.X.X
no ip redirects
no ip proxy-arp
ip access-group ingress in
ip access-group egress out
standby version 2
standby 1 ip X.X.X.X
standby 1 timers 20 60
standby 1 preempt
negotiation auto

What can be wrong?

 

Cheers, Hubert

1 ACCEPTED SOLUTION

Accepted Solutions

You topology could look something like this.

HSRP.JPG

View solution in original post

10 REPLIES 10
danielh22185
Beginner

I've read your post a few times over and am having troubles visualizing what you are trying to convey.  Can you post a quick diagram?

paul driver
VIP Expert

Hello

Can you post a topology diagram of this please?


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul
Hubert Kupper
Beginner

Sorry for my confusing post. The basic thing, I want to do is to connect our 2 new ASR-1001-X routers to a 4510+R Switch for HSRP. The connected interfaces on the routers and the switch are coming up after connection and cdp neighbour shows all fine.  The IPs of the active asr are not reacheble before I changed the port on th 4510 to "no switchport" and give it a IP in the same range as the asr. For the port to the "standby" asr I cannot do this, because I cannot set 2 IPs for "no switchport" ports on the 4510 in the same subnet.

In our old setup the both old routers were connected to switchports on a 3750E switch with no routing enabled. The new asr routers are connected to a 4510+R switch with routing enabled for the vlans in our LAN.

 

So with your old setup it sounds like the routers were doing the routing for the vlans and using HSRP whereas now the 4510 is doing the routing for the vlans. 

 

If that is the case why are you trying to use HSRP on the new ASRs, why not just have routed links from the 4500 and either run a routing protocol or use static routes. 

 

Perhaps I am still not following but what exactly are you trying to setup HSRP on the ASRs for ?

 

Jon

Hi,

on our old setup the old routers where attached to a non routing 3750 switch and the 4510 did the vlan routing and had a routed port attached to the 3750 switch. In our new setup the both new routers are attached to the 4510 directly and the 4510 do the vlan routing always. In the old setup HSRP worked fine. In the new setup the standby router isn't reachable.

We want HSRP on both asr routers for the case that the active router to the internet fails. This worked fine in the past.

Ok now I think I am getting it a bit more.  Sounds like although your 4500 switch is capable of routing there is no need for it to do much.  So let's keep it simple.  Have the 4500 switch downstream from new ASRs point a default route at the VIP address of the two HSRP routers.  This way if you have an uplink fail on either HSRP router (which you introduce as a tracking item within HSRP) you will fail over to the proper router.

You topology could look something like this.

HSRP.JPG

Ok here a thumb question about the config of the 4510 interface for the link to the asr:

 

interface GigabitEthernet1/2
description uplink asr1
no switchport
ip address X.X.X.X X.X.X.X
no ip redirects
no ip proxy-arp
ip ospf network point-to-multipoint

end

 

I can reache the first asr with no problems. When I configure the interface to the second asr in the same way I get a error "int gig 1/3 overlaps with gi 1/2". If I set no ip address on gig 1/3, the asr2 is not reacheble.

When I configure both interfaces as switchports, both asr are not reacheble.