cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
401
Views
1
Helpful
7
Replies

ASR1001-X Thruput only 750 meg Interfaces10G both sides -Circuit 10G

jroy777
Level 1
Level 1

We have a Cisco ASR1001-X and it can only pass 750 megs of traffic thru it on a 10 Gig circuit. I looked at licensing levels and they seem correct. Anyone have any ideas of what I can look at? Both Lan and Wan interfaces are 10 gig and Wan is using Single Mode Fiber (Megaport with AWS Direct Connect requirement). Lan is 10GB to HP. When I login to all devices they all say 10GB.

Here are router details:

cisco ASR1001-X (1NG) processor (revision 1NG) with 3853112K/6147K bytes of memory.
Processor board ID FXS2033Q3N6
6 Gigabit Ethernet interfaces
2 Ten Gigabit Ethernet interfaces
32768K bytes of non-volatile configuration memory.
8388608K bytes of physical memory.
6594559K bytes of eUSB flash at bootflash:

Index 26 Feature: throughput_5g
Period left: Not Activated
Period Used: 0 minute 0 second
License Type: EvalRightToUse
License State: Active, Not in Use, EULA not accepted
License Count: Non-Counted
License Priority: None
Index 27 Feature: throughput_5g_to_10g
Index 28 Feature: throughput_5g_to_20g
Index 29 Feature: throughput_10g
Period left: 4 weeks 4 days
Period Used: 3 weeks 6 days
License Type: EvalRightToUse
License State: Active, In Use
License Count: Non-Counted
License Priority: Low
Index 30 Feature: throughput_10g_to_20g
Index 31 Feature: throughput_20g
Period left: Not Activated
Period Used: 0 minute 0 second
License Type: EvalRightToUse
License State: Active, Not in Use, EULA not accepted
License Count: Non-Counted
License Priority: None

interface TenGigabitEthernet0/0/0
mtu 3800
no ip address
!
interface TenGigabitEthernet0/0/0.2900
description "Direct Connect to Amazon VPC or Transit Gateway on AWS Cloud"
encapsulation dot1Q 2900
ip address 169.254.38.182 255.255.255.252
!
interface TenGigabitEthernet0/0/1
description "Prod DBNET access"
ip address 192.168.51.249 255.255.254.0
no ip proxy-arp
ip nbar protocol-discovery
!
router bgp 65***
bgp log-neighbor-changes
neighbor 169.254.38.181 remote-as 65***
neighbor 169.254.38.181 password *******
!
address-family ipv4
network 169.254.38.180 mask 255.255.255.252
network 192.168.50.0 mask 255.255.254.0
neighbor 169.254.38.181 activate
exit-address-family


 

7 Replies 7

smithco64
Level 1
Level 1

How are you doing you testing for this? Are you just iperfing from your AWS VPC? @jroy777 

For instantance if you were running a T2.nano EC2 instance and running IPERF off that max you can squeeze out is about 70meg, it goes up from there If you are running an iperf from AWS to check this out set up a second server  and run both iperfs at the same time. If you get double the bandwidth on your interface then the issue is with the size of your EC2 not your router. 

Yes, 750meg is what iperf is showing

Screenshot 2024-04-18 at 3.21.19 PM.png

If you put up two IPERF on two seperate boxes do you get double?

jroy777
Level 1
Level 1

As a test, I plugged in two servers with 10g ports into 10g switch and reconfigured router. Of course no traffic to sub interface side of router (subif is for link going to AWS) and moved IP to physical interface, we get full 10gb speed but lots of retransmissions. Bad transciver?

jroy777_0-1713552643589.png

 

 

@jroy777 You can test that out and swap the transceivers out. If it follows it then it's the transceiver if that doesn't change it. Swap the servers on the port itself and see if it follows the server. Last you can move the "bad" to a new port and see if its the ASIC. 

Hello,

I have not followed the entire thread, but I am just thinking, have you checked AWS CloudWatch Metrics ?

Review Cisco Networking for a $25 gift card