cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
523
Views
0
Helpful
3
Replies

Assistance with IGMP Group Membership

mumbles202
Level 5
Level 5

I'm working on a 3650 w/ the following configuration but not seeing anything when I enter "show ip igmp groups" even though devices are attached that should be using multicast:

 

Router_3650#sh run
Building configuration...

Current configuration : 5889 bytes
!
 Last configuration change at 13:37:25 UTC Wed May 5 2021 by admin
!
version 16.6
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no platform punt-keepalive disable-kernel-core
!
hostname Router_3650
!
!
vrf definition Mgmt-vrf
!
address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
!
no aaa new-model
switch 1 provision ws-c3650-24pd
!
!
!
!
ip routing
!
ip dhcp excluded-address 192.168.200.0 192.168.200.9
ip dhcp excluded-address 192.168.200.50 192.168.200.254
!
ip dhcp pool Router
 network 192.168.200.0 255.255.255.0
default-router 192.168.200.1 
!
!
!
ip igmp snooping vlan 200 querier version 2
ip igmp snooping vlan 200 querier address 192.168.200.1  
no ip igmp snooping vlan 1
no ip igmp snooping vlan 50
ip igmp snooping vlan 200 immediate-leave
no login on-success log
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-275486518
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-275486518
 revocation-check none
 rsakeypair TP-self-signed-275486518
!
!
crypto pki certificate chain TP-self-signed-275486518
!
!
!
diagnostic bootup level minimal
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
username admin privilege 15 secret 5 $1$MD3P$1tN7go01hfVhy5Slg8hdN
!
redundancy
  mode sso
 !
 !
 transceiver type all
  monitoring
!
vlan configuration 1,50,200
!
!
class-map match-any system-cpp-police-topology-control
  description Topology control
class-map match-any system-cpp-police-sw-forward
 description Sw forwarding, L2 LVX data, LOGGING
class-map match-any system-cpp-default
  description DHCP Snooping, EWLC control, EWCL data 
class-map match-any system-cpp-police-sys-data
 description Learning cache ovfl, Crypto Control, Exception, EGR Exception, NFL SAMPLED DATA, RPF Failed
class-map match-any system-cpp-police-punt-webauth
  description Punt Webauth
class-map match-any system-cpp-police-l2lvx-control
  description L2 LVX control packets
class-map match-any system-cpp-police-forus
  description Forus Address resolution and Forus traffic
class-map match-any system-cpp-police-multicast-end-station
 description MCAST END STATION
class-map match-any system-cpp-police-multicast
 description Transit Traffic and MCAST Data
class-map match-any system-cpp-police-l2-control
  description L2 control
class-map match-any system-cpp-police-dot1x-auth
  description DOT1X Auth
class-map match-any system-cpp-police-data
 description ICMP redirect, ICMP_GEN and BROADCAST
class-map match-any system-cpp-police-stackwise-virt-control
 description Stackwise Virtual
class-map match-any non-client-nrt-class
class-map match-any system-cpp-police-routing-control
 description Routing control
class-map match-any system-cpp-police-protocol-snooping
 description Protocol snooping
class-map match-any system-cpp-police-system-critical
 description System Critical and Gold
!
policy-map system-cpp-policy
!
! 
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0
 vrf forwarding Mgmt-vrf
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet1/0/1
 switchport access vlan 200
 switchport mode access
!
interface GigabitEthernet1/0/2
 switchport access vlan 200
 switchport mode access
!
interface GigabitEthernet1/0/3
 switchport access vlan 200
 switchport mode access
!
interface GigabitEthernet1/0/4
 switchport access vlan 200
 switchport mode access
!
interface GigabitEthernet1/0/5
 switchport access vlan 200
 switchport mode access
!
interface GigabitEthernet1/0/6
 switchport access vlan 200
 switchport mode access
!
interface GigabitEthernet1/0/7
 switchport access vlan 200
 switchport mode access
!
interface GigabitEthernet1/0/8
 switchport access vlan 200
 switchport mode access
!
interface GigabitEthernet1/0/9
 switchport access vlan 200
 switchport mode access
!
interface GigabitEthernet1/0/10
 switchport access vlan 200
 switchport mode access
!
interface GigabitEthernet1/0/11
 switchport access vlan 200
 switchport mode access
!
interface GigabitEthernet1/0/12
 switchport access vlan 200
 switchport mode access
!
interface GigabitEthernet1/0/13
 switchport access vlan 200
 switchport mode access
!
interface GigabitEthernet1/0/14
 switchport access vlan 200
 switchport mode access
!
interface GigabitEthernet1/0/15
 switchport access vlan 200
 switchport mode access
!
interface GigabitEthernet1/0/16
 switchport access vlan 200
 switchport mode access
!
interface GigabitEthernet1/0/17
 switchport access vlan 200
 switchport mode access
!
interface GigabitEthernet1/0/18
 switchport access vlan 200
 switchport mode access
!
interface GigabitEthernet1/0/19
 switchport access vlan 200
 switchport mode access
!
interface GigabitEthernet1/0/20
 switchport access vlan 200
 switchport mode access
!
interface GigabitEthernet1/0/21
 switchport access vlan 50
 switchport mode access
!
interface GigabitEthernet1/0/22
 switchport access vlan 50
 switchport mode access
!
interface GigabitEthernet1/0/23
 switchport mode access
!
interface GigabitEthernet1/0/24
 switchport mode access
!
interface GigabitEthernet1/1/1
!
[interface GigabitEthernet1/1/2
!
interface TenGigabitEthernet1/1/3
!
interface TenGigabitEthernet1/1/4
!
interface Vlan1
 description MGMT
ip address 192.168.10.1 255.255.255.0
!
interface Vlan50
 description Cameras
 ip address 192.168.50.1 255.255.255.0
!
interface Vlan1200
 description Router
 ip address 192.168.200.1 255.255.255.0
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
!
!
!
!
control-plane
 service-policy input system-cpp-policy
!
!
line con 0
 login local
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login local
 transport input all
line vty 5 15
 login local
 transport input all
!
!
!
!
!
!
!
end


Am I missing something that's required?  Devices should be connected to the first 10 ports on the switch.

3 Replies 3

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello @mumbles202 ,

your device is configured for IGMP snooping only.

However, someone a multicast router or an IGMP snooping querier needs to send out periodic IGMP query messages so that hosts interested in multicast traffic can answer in each subnet / VLAN / broadcast domain.

 

So either you enable full IPv4 multicast routing using:

ip multicast routing

+

ip pim sparse-dense mode under each SVI interface (VLAN 50 for example and VLAN 200)

 

Or you enable the IGMP snooping querier at least in VLAN 50.

 

To be noted if the router connected to VLAN 200 is multicast enabled it is able to send queries in VLAN 200 but it cannot do it in VLAN 50.

When you enable PIM under an interface you are also enabling IGMP on the same interface.

 

Hope to help

Giuseppe

Thanks for the reply.  I only need IGMP working in vlan 200 which is where all the devices that need to be plugged in will be.  Do I need to add something else other than:

 

ip igmp snooping vlan 200 querier version 2
ip igmp snooping vlan 200 querier address 192.168.200.1  
ip igmp snooping vlan 200 immediate-leave

Hello @mumbles202 ,

if there is no multicast router in vlan 200 then you need the IGMP snooping querier and your proposed configuration is enough

 

Hope to help

Giuseppe

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card