cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1881
Views
0
Helpful
5
Replies

Bandwidth Limit/Restriction for a specific source<>destination

Hello All,

 

I have two sites. We have router 4451x at site A and 2911 at site B. there is a job scheduled between host A(192.168.10.55)<>host B (172.16.20.101) on daily basis which is bandwidth intensive. I want to restrict the bandwidth for the traffic between these 2 hosts to 2 Mbps. Could anyone suggest that below configuration is correct or need any changes. I was thinking to apply these configuration on router 4451. Please suggest

 

ip access-list extended 105
permit ip host 192.168.10.55 host 172.16.20.101

 

class-map 10.55<>20.101
match access-group 105

 

policy-map A<>B
class 10.55<>20.101 (class-map name)
shape average 2000000(2 Mbps)


policy-map BW_A<>B
class class-defaults
shape average 2000000
service-policy A<>B

 

int gig0/1
service-policy output BW_A<>B

5 Replies 5

balaji.bandi
Hall of Fame
Hall of Fame

 

I use below exmaple for testng.  ( change the source and interace accordingly)

 

SITE A

Acces-list 100 permit ip host 192.168.10.55 host 172.16.20.101
!
class-map match-any TEST
match access-group 100
!
policy-map LIMIT-2MB
class TEST
bandwidth 2000
!
!
interface Gigx/x
Service-policy output LIMIT-2MB

 

SITEB

=======================================================

Acces-list 100 permit ip host 172.16.20.101 host 192.168.10.55
!
class-map match-any TEST
match access-group 100
!
policy-map LIMIT-2MB
class TEST
bandwidth 2000
!
!
interface Gix/x
Service-policy output LIMIT-2MB

 

https://www.cisco.com/c/en/us/support/docs/quality-of-service-qos/qos-packet-marking/10100-priorityvsbw.html

 

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Hello balaji,

 

Thanks for your suggestion. I will try and update it meets our goal.

Joseph W. Doherty
Hall of Fame
Hall of Fame

Hmm, unclear why you're using a two level policy.  Just using

int gig0/1
service-policy output A<>B

should meet your goal.

That said, something like what Balaji posted might be a "better" approach.  Balaji's approach doesn't limit this traffic to 2Mbps, it guarantees (2 Mbps).  I.e. the restricted class can use more bandwidth if it's otherwise not being used.  (NB: although Balaji's class-name is "LIMIT-2MB", the class bandwidth statement sets a floor not a ceiling for bandwidth usage.)

Personally, if the intensive bandwidth usage flow isn't time sensitive, I place it into a class with minimum bandwidth allocation.  This keeps it "behind" other traffic but allows it to use all otherwise unused bandwidth.

E.g.:
policy-map A<>B
class 10.55<>20.101 (class-map name)
bandwidth 1 percent
class class-default
bandwidth 99 percent

Hello Joseph,

 

This scheduled job has to be completed within a time frame So I was thinking to give it 2-3 Mbps bandwidth. As per your suggestion below configuration should work:

 

ip access-list extended 105
permit ip host 192.168.10.55 host 172.16.20.101

 

class-map 10.55<>20.101
match access-group 105

 

policy-map A<>B
class 10.55<>20.101 (class-map name)
shape average 2000000(2 Mbps)

 

int gig0/1
service-policy output A<>B

If you have a time constraint, you can still use a policy, w/o a shaper (or policer), to guarantee whatever minimum bandwidth allowance you believe you need.  Again, such a policy will allow this traffic to take advantage of otherwise unused bandwidth.  I.e. the data transfer might complete sooner but it should always complete in its time allowance.  Also again, even though you're not capping this flows bandwidth usage, such a policy will also guarantee other traffic can have all but the 2 (or 3) Mbps you've guaranteed for this traffic.  I.e. basically the same behavior/guarantee for all the other traffic without capping some traffic.

The forgoing aside, yes to your question.  I.e. your latest configuration should work too.