cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1331
Views
20
Helpful
9
Replies

Bandwidth problem over l2tpv3 with back to back 1841 cisco router

Hope someone can give me any idea or suggestion.

 

I have to make a 80MB data connection (upstream 80mb and downstream 80mb) over end to end L2 transparent connectivity from A-End to B-End and for that i have chosen to make the L2TPV3 between the connection. before doing something over the live network, i have decided to make a back to back connection with the test routers. the router i have are Cisco 1841 and i have configured it as below.

 

A-End Cisco 1841 Router: (1500 MTU Supported Only)


interface Loopback1

ip address 1.1.1.1 255.255.255.255

!

pseudowire-class R1

encapsulation l2tpv3

ip local interface Loopback1

!

interface FastEthernet0/0

ip address 192.168.50.1 255.255.255.252
duplex full
speed 100

!

interface FastEthernet0/1

duplex full
speed 100
xconnect 2.2.2.2 500 encapsulation l2tpv3 pw-class R1

!

router eigrp 20

network 192.168.50.0
network 1.1.1.1

!

-----------------------------------------------------------------------------------------------------------

B-End Cisco 1841 Router: (1500 MTU Supported Only)


interface Loopback1

ip address 2.2.2.2 255.255.255.255

!

pseudowire-class R1

encapsulation l2tpv3

ip local interface Loopback1

!

interface FastEthernet0/0

ip address 192.168.50.2 255.255.255.252
duplex full
speed 100

!

interface FastEthernet0/1

duplex full
speed 100
xconnect 1.1.1.1 500 encapsulation l2tpv3 pw-class R1

!

router eigrp 20

network 192.168.50.0
network 2.2.2.2

!

 

The connection has established successfully and i'm able to ping same network IP on laptops at both side. however, when i connect the A-End interface with RFC2544 BERT and B-End interface with Looping device the BERT are not able to verify the bandwidth more than 28 MB and there is bandwidth variation over different different frames i.e (512 byte frame pass 10MB, 1280 byte frame pass 24 MB, 1450 byte frame pass 28 MB).

 

So my question is, am i doing something wrong or missed something ? I would be very grateful with any suggestion. Thanks. 

 

NOTE: All the connections between devices are with straight UTP cables and ports speed/duplex are 100/Full. RFC 2544 BERT only verify same upstream and downstream bandwidth.

1 Accepted Solution

Accepted Solutions

Again, I cannot really say whether the 2911 will be "powerful" enough, or not. Just be aware a BERT test may not be too representative of what you want/need to do. Another take away from that Cisco whitepaper, is how much throughput can vary based on traffic mix and features being used.

That noted, the 2911 is rated for 353 Kpps vs. the 1841's 75 Kpps, so the 2911 is about (almost) 5x faster.

If you already have the 2911, give it a try, it might work for you just fine. But if it doesn't, don't be shocked either. ;)

View solution in original post

9 Replies 9

Joseph W. Doherty
Hall of Fame
Hall of Fame
An 1841 is rated as a 75 Kpps router, so it might just have the performance capacity you need.

Hi Joseph,

Thank for the response.

the 1841 is my test router only and the Live scenario will be implemented over Cisco 2911. so my question is, am i face the same issue on cisco 2911 or not.. i never faced this kind of bandwidth degradation issue and it is first time i'm applying the L2TPV3.

Cisco recommends a 2911 for up to 35 Mbps (WAN, i.e. duplex) bandwidth. So a 2911 might too have an issue with 80 Mbps duplex.

See attachment.

Hi Joseph,

I have read the white paper and as per the recommendation the cisco 3925 router would the ideal for this. but the cisco 2911 was recommended by my company for this scenario as one of our competitor doing the same over the 2911. they made 3 xconnect connection on sub interfaces and the back end aggregation port is single GigaEthernet lease line connection.
Those 3 connection Bandwidths are 100Mb, 10MB and 6Mb with same upstream and downstream. so my question is how they are doing than ? if the 2911 CPU usage can't support more than 35 Mbps :/

Please guide me on this critical matter, I would be very thankful to you.

If you carefully read the whole white paper, you'll see router throughput capacity varies much based on the traffic mix and router configuration.

It's not that a 2911 cannot do more than 35 Mbps, that's just a very conservative recommendation, by Cisco (which will also gladly sell you a more powerful router), to help insure no matter your traffic or your configuration, you won't exceed the capacity of the router. As they say "your mileage might vary." ;)

Hi Joseph,

so your saying the recommended router would resolved my issue permanently and provide me the required bandwidth over L2VPN.


No, I'm not saying the Cisco recommended router would solve your issue because the impact of your traffic with your overall configuration that determines the actual need. I.e. any recommendation is really a bit of a guess. Cisco's recommendation might still be insufficient, or even more than you actually need.

Ideally you would like a test with different "size" routers.

BTW, since you're using a tunnel technology, if there's fragmentation, that generally will increase CPU loading. Since you're doing a L2 tunnel over L3, off the top of my head, I don't know if there is anything you can do to easily avoid fragmentation.

Also BTW, when you doing your tests on the 2911, check the CPU usage. If you're hitting 100%, you've hit the performance limit of the router.

Dear Joseph,

Many Thanks for all your help.

i have tested the ISR 2911 router on back to back testing over BERT and able to observe clear 150MB throughput. The CPU usage were hit only 50% in the testing. The cisco recommend 182Mbps throughput for 2911 router and i can feel this router would resolve my issue as i need only 80Mbps connection.

Again, I cannot really say whether the 2911 will be "powerful" enough, or not. Just be aware a BERT test may not be too representative of what you want/need to do. Another take away from that Cisco whitepaper, is how much throughput can vary based on traffic mix and features being used.

That noted, the 2911 is rated for 353 Kpps vs. the 1841's 75 Kpps, so the 2911 is about (almost) 5x faster.

If you already have the 2911, give it a try, it might work for you just fine. But if it doesn't, don't be shocked either. ;)
Review Cisco Networking for a $25 gift card