cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
414
Views
0
Helpful
9
Replies

Bandwidth restricting

Dale_Bosley
Level 1
Level 1

I would like to know if it is possible to set bandwidth on a per user basis ie. user A gets 256k user B 1 meg etc.? If so could you please give me the basic command structure for this.

thanks for any assistance

Dale

9 Replies 9

Hello,

you could use CBWFQ and create a class per user:

class-map match-all User_A

match access-group 1

!

policy-map POLICE_TRAFFIC

class User_A

police cir 256000 bc 8000

!

interface FastEthernet0/0

service-policy output POLICE

!

access-list 1 permit host 192.168.1.1

Create a class for each user you and set the bandwidth to the desired limit...

Regards,

GP

Thanks for your reply, This is pretty advanced stuff for me. I tried the commands on the router using my own map names and the commands take just fine what I don't understand is: do I use the name of the computer to get this to apply or its MAC address or am I missing something here.

thanks

Dale

I was unable to find out where I'm supposed to enter this command:

police cir 256000 bc 8000

I put in

Router(config)#policy-map (name)

Router(config-pmap)#class (name)

also on the access-list does this have to apply to IP addresses or can a computer name or MAC address be substituted.

Thanks

Dale

Hello Dale,

the options you have under your policy map and class map depend somewhat on the IOS version and feature set you are using. So when you type:

policy-map POLICE

class User_A

what are the options you have ?

The access list has to match the IP address of your specific user.

Regards,

GP

GP

Thanks again for your reply. My version is 12.2(7c)

When I put in policy-map POLICE I get the following options:

QoS policy-map configuration commands:

class policy criteria

description Policy-Map description

exit Exit from QoS policy-map configuration

mode

no Negate or set default values of a

command

rename Rename this policy-map

At the next prompt if I put in the class User_A ?

access-group Access group

any Any packets

destination-address Destination address

dscp Match IP DSCP (DiffServ

CodePoints)

input-interface Select an input interface to

match

precedence IP precedence

protocol Protocol

qos-group Qos-group

source-address Source address

Thanks, let me know if you need more info for this

Dale

Hello Dale,

sorry for the confusion, what I meant was:

Router#conf t

Router(config)#class-map match-all User_A

Router(config-cmap)#match access-group 1

Router(config-cmap)#exit

Router(config)#policy-map POLICE

Router(config-pmap)#class User_A

Router(config-pmap-c)#?

What do you get when you type the ? You should see something like ´bandwidth´ or ´priority´ ...

Regards,

GP

GP

Sorry, I hacked away at it and finally got to where I could enter in bandwidth. Here are the commands that I entered for a specific host on my network, please let me know if I did this right because its not working.

The S1 port is the exit point for this network, I really wanted to choke the hell out of the bandwidth to see an obvious result. I will change it to something more reasonable later.

router(config)#class-map match-all User_A

router(config-cmap)#match access-group 1

router(config)#policy-map POLICE_TRAFFIC

router(config-pmap)#class User_A

router(config-pmap-c)#bandwidth 8

router(config-if)#service-policy output POLICE_TRAFFIC

router(config)#access-list 1 permit host 10.6.18.150

Yes I'm a noob at this so hand holding is appreciated ;-)

Thanks

Dale

Hello Dale,

the bandwidth command actually guarantees 8 kbps of bandwidth in case of congestion, but if more bandwidth is available, the user will be able to use it.

So, if you want to give the user 8 kbps and no more, committed access rate (CAR) might be a better option. You configure it at the interface level:

rate-limit input access-group 1 8000 1000 2000

conform-action transmit exceed-action drop

access-list 1 permit 10.6.18.150

Can you try and see if this works for you ?

Regards,

GP

OK I guess my router or ios is not capable of this, It is a 1720.with version 12.2(7c) and under the interface I do not have the rate-limit option. Do I need to upgrade my IOS or is this router even capable of doing this?

Do I understand this right, I can guarantee a minimum rate with the bandwidth command but I need the rate-limit command to put a ceiling on it.

Thanks

Dale

Review Cisco Networking for a $25 gift card