01-27-2023 04:41 AM
Hi there!
I have 2 VLANs which and hosts from these VLANs has access to the Internet.
I need to limit the bandwidth for these VLANs and allow them to use 500Mbps per VLAN since bandwidth is 1Gbit/s
How I can reach this goal? I use CISCO ASR-1001-X router IOS version 16.09.05.
interface TenGigabitEthernet0/0/1.11
encapsulation dot1Q 11 native
ip address
ip nat inside
-
-
interface TenGigabitEthernet0/0/1.101
encapsulation dot1Q 101
ip address
ip nat inside
interface GigabitEthernet0/0/5
description WAN
ip address
ip nat outside
negotiation auto
01-27-2023 04:45 AM
check the below thread :
https://community.cisco.com/t5/routing/qos-bandwidth-limit/td-p/2677251
01-27-2023 08:10 AM
You're sure you truly want to limit each VLAN to 500 Mbps? Reason I ask, generally, I would prefer to guarantee each VLAN would always received 500 Mbps, but could obtain up to the full gig.
Assuming you still want to limit, you can limit via shaping or policing. The former will buffer excess traffic, the latter drops excess traffic. Of the two, I generally recommend to shape.
Also, when choosing between shaping or policing (AKA rate-limiting), the former can only be done upon egress, the latter can be done upon egress or ingress.
Something to understand, we can "guarantee" neither VLAN will effectively obtain more than 500 Mbps, but we cannot truly guarantee either VLAN will obtain 500 Mbps from the Internet (we can guarantee 500 Mbps to the Internet, though).
A simple implementation of policing both VLANs to 500 Mbps, might be:
policy-map RateLimit500Mbps
class class-default
police average 500000000
interface TenGigabitEthernet0/0/1.11
service-policy input RateLimit500Mbps
service-policy output RateLimit500Mbps
interface TenGigabitEthernet0/0/1.101
service-policy input RateLimit500Mbps
service-policy output RateLimit500Mbps
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide