cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1081
Views
1
Helpful
4
Replies

Basic BGP EVPN VXLAN lab

carl_townshend
Spotlight
Spotlight

Hi Guys

I am looking to build a test lab between 2 8000v routers in my CML environment for BGP EVPN VXLAN.

Does anyone have a basic config they can share for this?

Cheers

4 Replies 4

Can you add one more v8000?

You need at least three 

One spine 

Two leafs 

MHM

Yes, we are using Cisco modelling labs

Hi,

Here's a step-by-step guide to configure a test lab for BGP EVPN VXLAN between 3 8000v routers in your CML environment:

1. Topology Overview

  • Routers: Three Cisco 8000v routers.
  • Interfaces: Each router will have two or more interfaces for underlay and overlay networks.
  • Connections: BGP will be used for the EVPN control plane, while VXLAN will be used for data plane encapsulation.

2. Initial Router Configuration

Start by setting up basic connectivity between the routers.

Configure the following on all 3 routers:

# Hostname and basic configurations
hostname R1
no ip domain-lookup
ip domain-name yourdomain.local

# Set up Loopback interface for BGP peering
interface Loopback0
ip address 1.1.1.1 255.255.255.255

Repeat similar configuration for the other routers (R2, R3), using 2.2.2.2 for R2 and 3.3.3.3 for R3.

3. Underlay Network Configuration

Use OSPF or BGP to establish an underlay network between the routers. This will provide reachability between loopback interfaces.

OSPF Configuration:

router ospf 1
router-id 1.1.1.1
network 10.0.0.0 0.0.0.255 area 0

4. VXLAN and NVE Interface Configuration

Next, configure VXLAN. Each router will act as a VTEP (VXLAN Tunnel Endpoint). Use NVE interfaces for the VXLAN encapsulation.

VXLAN configuration:

interface nve1
no shutdown
source-interface Loopback0
member vni 10001
ingress-replication protocol static
peer-ip 2.2.2.2
peer-ip 3.3.3.3

For each router, adjust the peer-ip to reflect the loopback addresses of the other routers.

5. BGP EVPN Configuration

Configure BGP to handle EVPN (Ethernet VPN) as the control plane.

BGP Configuration for EVPN:

router bgp 65000
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 65000
neighbor 3.3.3.3 remote-as 65000
!
address-family l2vpn evpn
neighbor 2.2.2.2 activate
neighbor 3.3.3.3 activate
exit-address-family

Repeat this on all routers, changing the neighbor IPs appropriately. This establishes BGP sessions for the EVPN control plane.

6. VRF and VNI Configuration

Configure VRF and VNI for tenant separation.

vrf definition Tenant-A
rd 1:1
!
address-family ipv4
route-target export 1:1
route-target import 1:1
exit-address-family

Then associate VNIs with this VRF.

interface Vlan100
vrf forwarding Tenant-A
ip address 192.168.1.1 255.255.255.0
vxlan vni 10001

7. Verification

Verify the VXLAN tunnel and BGP EVPN sessions:

VXLAN Verification:

show nve peers
show nve vni

BGP EVPN Verification:

show bgp l2vpn evpn summary

These commands should show active peers and VXLAN tunnels if everything is configured correctly.

8. Final Notes

  • Make sure the underlay network (OSPF/BGP) is fully converged before configuring the overlay.
  • Ensure that the loopback interfaces used as the NVE source are reachable.
  • Test reachability using pings between loopbacks and verify BGP sessions.

This should give you a working VXLAN EVPN setup in your CML environment.