cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3181
Views
0
Helpful
4
Replies
Beginner

BGP: aggregation with suppress-map

Dear Friends,

I'm facing a problem with bgp suppress-map command.

---R1<-------->R2<------->R3---

I've configured loopback in R1 as below,

interface Loopback1
ip address 20.10.10.1 255.255.255.252
!
interface Loopback2
ip address 20.10.10.5 255.255.255.252
!
interface Loopback3
ip address 20.10.10.9 255.255.255.252
!
interface Loopback4
ip address 20.10.10.13 255.255.255.252
!

Configuration on R2,

router bgp 222

!

- - - -

!
aggregate-address 20.10.10.0 255.255.255.0 suppress-map xyz
!

access-list 20 permit 20.10.10.12 0.0.0.3
access-list 20 deny  any
!
route-map xyz permit 10
  match ip address 20

!
-------------------------         -----------------------------         ------------------------

As per the above configuration, I'm expecting R3 to show all routes except 20.10.10.12/30 in bgp table & routing table with a summary route pointing to 20.10.10.0/24. However, what I can see in R3 is, only a summary route, that too, 20.10.0.0/16.

Anyone know the reason pls?

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Advisor

Re: BGP: aggregation with suppress-map

Hi,

R2 can't aggregate as it hasn't got any prefixes for the loopbacks in its BGP RIB.

Can you do sh run | s bgp on R1

Regards.

Alain.

Don't forget to rate helpful posts.

View solution in original post

4 REPLIES 4
Highlighted
Advisor

Re: BGP: aggregation with suppress-map

Hi,

on R2:

-sh ip bgp

- sh run | s bgp

-sh route-map

-sh ip bgp nei x.x.x.x advertised where x.x.x.x is R3

Regards.

Alain.

Don't forget to rate helpful posts.
Highlighted
Beginner

Re: BGP: aggregation with suppress-map

Dear Alain,

The requested logs are given below,

R2#
R2#
R2#sh ip bgp
BGP table version is 4, local router ID is 1.1.1.9
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.4/30       0.0.0.0                  0         32768 i
*> 1.1.1.8/30       0.0.0.0                  0         32768 i
*> 20.10.0.0/16     1.1.1.6                  0             0 111 i
R2#
R2#
R2#sh running-config | be router
router bgp 222
no synchronization
bgp log-neighbor-changes
network 1.1.1.4 mask 255.255.255.252
network 1.1.1.8 mask 255.255.255.252
aggregate-address 20.10.10.0 255.255.255.0 suppress-map xyz
neighbor 1.1.1.6 remote-as 111
neighbor 1.1.1.10 remote-as 333
no auto-summary
!
ip classless
!
ip http server
no ip http secure-server
!
access-list 20 permit 20.10.10.12 0.0.0.3
access-list 20 deny   any
route-map xyz permit 10
match ip address 20
!

R2#
R2#
R2#sh ip bgp  neighbors 1.1.1.10 advertised-routes
BGP table version is 4, local router ID is 1.1.1.9
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.4/30       0.0.0.0                  0         32768 i
*> 1.1.1.8/30       0.0.0.0                  0         32768 i
*> 20.10.0.0/16     1.1.1.6                  0             0 111 i
R2#
R2#
R2#

R3#
R3#sh ip bgp
BGP table version is 211, local router ID is 1.1.1.10
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.4/30       1.1.1.9                  0             0 222 i
r> 1.1.1.8/30       1.1.1.9                  0             0 222 i
*> 20.10.0.0/16     1.1.1.9                                0 222 111 i
R3#
R3#

Thanks,

Ameen Ahmed.

Highlighted
Advisor

Re: BGP: aggregation with suppress-map

Hi,

R2 can't aggregate as it hasn't got any prefixes for the loopbacks in its BGP RIB.

Can you do sh run | s bgp on R1

Regards.

Alain.

Don't forget to rate helpful posts.

View solution in original post

Highlighted
Beginner

Re: BGP: aggregation with suppress-map

Hi Alain,

Thanks alot. There was aggregate command in R1 also which made this problem. When I removed it and everything worked fine.

R1#
R1#
R1#sh run | beg router
router bgp 111
no synchronization
bgp log-neighbor-changes
network 20.10.10.0 mask 255.255.255.252
network 20.10.10.4 mask 255.255.255.252
network 20.10.10.8 mask 255.255.255.252
network 20.10.10.12 mask 255.255.255.252
aggregate-address 20.10.0.0 255.255.0.0 summary-only
neighbor 1.1.1.5 remote-as 222
no auto-summary
!

R1#
R1#

Once agian thanks.

Regards,

Ameen Ahmed.