04-01-2022
08:51 AM
- last edited on
04-02-2022
06:08 PM
by
Translator
trying to get loopback addresses to advertise
*Mar 1 00:44:04.715: %SYS-5-CONFIG_I: Configured from console by console
R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router bgp 500
R2(config-router)#network 192.168.2.1 mask 255.255.255.224
% BGP: Incorrect network or mask configured
R2(config-router)#network 192.168.2.65 mask 255.255.255.192
% BGP: Incorrect network or mask configured
R2(config-router)#exit
R2(config)#do sh ip int br | inc Loopback
Loopback0 192.168.2.1 YES manual up up
Loopback1 192.168.2.65 YES manual up up
R2(config)#
R2#
loopback configs
interface Loopback0
ip address 192.168.2.1 255.255.255.224
ipv6 address FE80::2:3 link-local
ipv6 address 2001:DB8:ACAD:2000::1/64
end
interface Loopback1
ip address 192.168.2.65 255.255.255.192
ipv6 address FE80::2:4 link-local
ipv6 address 2001:DB8:ACAD:2001::1/64
end
don't see why it is not working....
Overall running-config
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 192.168.2.1 255.255.255.224
ipv6 address FE80::2:3 link-local
ipv6 address 2001:DB8:ACAD:2000::1/64
!
interface Loopback1
ip address 192.168.2.65 255.255.255.192
ipv6 address FE80::2:4 link-local
ipv6 address 2001:DB8:ACAD:2001::1/64
!
interface FastEthernet0/0
ip address 10.1.2.2 255.255.255.0
duplex auto
speed auto
ipv6 address FE80::2:1 link-local
ipv6 address 2001:DB8:ACAD:1012::2/64
!
interface Serial0/0
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet0/1
ip address 10.2.3.2 255.255.255.0
duplex auto
speed auto
ipv6 address FE80::2:2 link-local
ipv6 address 2001:DB8:ACAD:1023::2/64
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router bgp 500
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.1.2.1 remote-as 6500
neighbor 10.2.3.3 remote-as 300
neighbor 2001:DB8:ACAD:1012::1 remote-as 6500
neighbor 2001:DB8:ACAD:1023::3 remote-as 300
!
address-family ipv4
neighbor 10.1.2.1 activate
neighbor 10.2.3.3 activate
neighbor 2001:DB8:ACAD:1012::1 activate
neighbor 2001:DB8:ACAD:1023::3 activate
no auto-summary
no synchronization
exit-address-family
!
address-family ipv6
neighbor 2001:DB8:ACAD:1012::1 activate
neighbor 2001:DB8:ACAD:1023::3 activate
network 2001:DB8:ACAD:2000::1/64
network 2001:DB8:ACAD:2001::1/64
exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
Solved! Go to Solution.
04-01-2022 09:08 AM
You are using the address of the interface... you should be using the network.
network 192.168.2.0 mask 255.255.255.224
network 192.168.2.64 mask 255.255.255.192
04-01-2022 09:08 AM
You are using the address of the interface... you should be using the network.
network 192.168.2.0 mask 255.255.255.224
network 192.168.2.64 mask 255.255.255.192
04-01-2022 11:33 AM
network 192.168.2.1 mask 255.255.255.255
network 192.168.2.65 mask 255.255.255.255
only loopback will advertise not all sunbet when using 255.255.255.255
04-01-2022 02:13 PM
network 192.168.2.1 mask 255.255.255.255
network 192.168.2.65 mask 255.255.255.255
That only works if the version of IOS automatically creates a "local route" in the routing table. The correct way is to match the "connected route" or change the subnetting of the loopback interface to a /32 host address and use a /32 netmask in the network statement.
04-01-2022 11:55 AM
Hello
What is the reason you have loopback interfaces with non host ip addressing?
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide