cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1118
Views
0
Helpful
5
Replies

bgp inject-map

Hi,

    I am trying to test bgp inject-map using gns3 and am facing some problem. I am using the following topology.

|R7 AS 1000|-----|R3 AS 1200|-----|R4 AS 1000|

R7 is sending some aggregate 172.16.0.0/16 to R3. I want to generate 172.16.9.0/24 along with aggregate and send to R4.

R3:

==

router bgp 1200

no synchronization

bgp log-neighbor-changes

bgp inject-map advert exist-map check

neighbor 10.1.2.4 remote-as 1300

neighbor 10.1.2.4 ebgp-multihop 2

neighbor 10.1.2.4 update-source Loopback0

neighbor 10.1.2.4 next-hop-self

neighbor 10.1.2.4 send-community

neighbor 10.1.2.7 remote-as 1000

neighbor 10.1.2.7 ebgp-multihop 2

neighbor 10.1.2.7 update-source Loopback0

no auto-summary

R3#show route-map advert

route-map advert, permit, sequence 10

  Match clauses:

  Set clauses:

    ip address (prefix-list) adver

    community no-export

  Policy routing matches: 0 packets, 0 bytes

R3#show ip prefix-list adver

ip prefix-list adver: 1 entries

   seq 10 permit 172.16.7.0/24

R3#

R3#

R3#show route-map check

route-map check, permit, sequence 10

  Match clauses:

    ip address prefix-lists: leanred

    ip route-source prefix-lists: source

  Set clauses:

  Policy routing matches: 0 packets, 0 bytes

R3#

R3#show ip prefix-list learned

ip prefix-list learned: 1 entries

   seq 10 permit 172.16.0.0/16

R3#show ip prefix-list source

ip prefix-list source: 1 entries

   seq 10 permit 10.1.2.7/32

R3#

R3#

R3#show ip bgp

BGP table version is 2, local router ID is 30.1.2.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

*> 172.16.0.0       10.1.2.7                 0             0 1000 i

R3#

R4:

==

R4#show ip bgp

BGP table version is 6, local router ID is 40.1.2.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

*> 172.16.0.0       10.1.2.3                               0 1200 1000 i

R4#

As shown above, I am seeing only aggregate on R4, not specific. What could be wrong with my config? Your help is appreciated.

Thanks,

Balajee

5 Replies 5

Hello Balajee,

Not tested this but can you try perfoming the inject-map on R4 instead?

something like this:

R4

ip prefix-list NETWORK permit 172.16.7.0/24

ip prefix-list AGGREGATE permit 172.16.0.0/16

ip prefix-list R3 permit 10.1.2.3/24 ( i am asuming this is a 24 bit towards R3 from R4)

route-map EXIST permit 10

match ip address prefix-list AGGREGATE

match ip address prefix-list R3

route-map INJECT permit 10

match ip address prefix-list NETWORK

router bgp 1000

bgp inject-map INJECT exist-map EXIST

so if i am correct - this is telling the router to check if the 172.16.0.0/16 exists and  R3 is up then call the inject map and inject the 172.16.7.0/24

res

Paul



Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

milan.kulik
Level 10
Level 10

Hi,

according to http://www.cisco.com/en/US/customer/docs/ios/12_2t/12_2t4/feature/guide/ftbgpri.html

your config looks correct.

I suppose sh ip bgp injected-paths does not show the  172.16.7.0/24 prefix withion the R3 BGP table?

I guess there might be some bug in your IOS?

Possibly bringing a trouble with this feature while using eBGP multihop?

What about trying to use a simple peering using interface IP addresses?

Or removing the  set community no-export command from your route-map?

BR,

Milan

Jose Jara
Level 3
Level 3

Hi Balajee,

I see two things in your config:

1.

R3#show route-map check

route-map check, permit, sequence 10

  Match clauses:

    ip address prefix-lists: leanred --------------- it should be learned, the name of your prefix-list created

    ip route-source prefix-lists: source

2.

R3#show route-map advert

route-map advert, permit, sequence 10

  Match clauses:

  Set clauses:

    ip address (prefix-list) adver

    community no-export ---------------------------- it should be removed here, if you want to apply the no-export community to apply it for the eBGP neighbor, put a route-map in the outbound direction.

For verification you can use: show ip bgp injected-paths

Hope this telps,

Jose.

Ohhhhhh.....great catch. Stupid mistake from me. Thanks a lot and appreciate your help.

Thanks,

Balajee

Forgot to add....after making the changes suggested by you, it worked.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card