01-11-2006 06:36 PM - edited 03-03-2019 11:26 AM
ip route 2.2.2.2 255.255.255.255 1.1.1.1
ip route 2.2.2.2 255.255.255.255 1.1.1.5
interface e0/0
ip address 1.1.1.2 255.255.255.252
interface e0/1
ip address 1.1.1.6 255.255.255.252
interface loopback 0
ip address 3.3.3.3 255.255.255.255
router bgp 100
neighbor 2.2.2.2 remote-as 200
neighbor 2.2.2.2 update-source loopback0
neighbor 2.2.2.2 multihop 3
ip route 1.1.1.0 255.255.255.0 null0
i config a summary route using ip route 1.1.1.0 255.255.255.0 null 0, but interface e0/0 e0/1 ip address is 1.1.1.0/252 and 1.1.1.4/252.
i use two static route direct loopback route on another router to 1.1.1.1,and 1.1.1.5, the problem is when interface e0/0 is down, because point to null0 route can't disappear. so ip route 2.2.2.2 255.255.255.255 1.1.1.1 can't disappear, there are two static routes in routing table, traffic can't be changed to another line.
how to deal with this situation
thank you!
01-11-2006 06:50 PM
Hi,
Why don't you change the routes to be:
ip route 2.2.2.2 255.255.255.255 e0/0 1.1.1.1
ip route 2.2.2.2 255.255.255.255 e0/1 1.1.1.5
If you specify the interface through which the next hop should be found, you will install the floating static route only if the next hop IP address is reachable through the specified interface.
See this link for more details:
http://www.cisco.com/warp/public/105/ip_static_routes.html
Hope this helps - pls rate the post if it does.
Cheers,
Paresh.
01-12-2006 12:22 AM
Hello,
just on a side note, make sure that whatever static route you want to be the floating static has a higher administrative distance:
ip route 2.2.2.2 255.255.255.255 e0/0 1.1.1.1
ip route 2.2.2.2 255.255.255.255 e0/1 1.1.1.5 200
Regards,
GP
01-12-2006 05:20 PM
we don't want to be the floating static, we want load balance on these two lines.
01-12-2006 05:26 PM
Hello,
Did you try my suggestion config from my previous post ?
Regards,
Paresh.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide