cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
351
Views
0
Helpful
2
Replies

BGP over L3 problem

mohammedsalih
Level 1
Level 1

hi everyone,

i have to establish iBGP connection between the CSR towards the edge routers like (126,101,107,136,14,40)

i have more than one service provider towards the edges and the BGP connections is normally established.

the CSR reach to all Edge routers normally.

i already make the CSR Route-reflector to Readvertise the routes. 

all router learned the routes normally but when i try to ping from one site (edge) to another, the host unreachable

example :

126#sh ip bgp

Network Next Hop Metric LocPrf Weight Path
*>i 20.20.14.0/24 10.120.98.17 0 100 0 i
*>i 20.20.40.0/24 10.120.98.17 0 100 0 i
*>i 20.20.101.0/24 10.120.98.17 0 100 0 i
*>i 20.20.107.0/24 10.120.98.17 0 100 0 i
*> 20.20.126.0/24 0.0.0.0 0 32768 i
*>i 20.20.136.0/24 10.120.98.17 0 100 0 i
*>i 172.19.255.254/32 10.120.98.17 0 100 0 i

126#ping 20.20.14.254 source lo0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.20.14.254, timeout is 2 seconds:
Packet sent with a source address of 20.20.126.254
.....
Success rate is 0 percent (0/5)

_______________

but the WIMAX Service provider is work fine because the connection between CSR and the edge(14,40) is L2

14#sh ip bgp

Network Next Hop Metric LocPrf Weight Path
*> 20.20.14.0/24 0.0.0.0 0 32768 i
*>i 20.20.40.0/24 192.168.29.100 0 100 0 i
*>i 20.20.101.0/24 192.168.29.100 0 100 0 i
*>i 20.20.107.0/24 192.168.29.100 0 100 0 i
*>i 20.20.126.0/24 192.168.29.100 0 100 0 i
*>i 20.20.136.0/24 192.168.29.100 0 100 0 i
*>i 172.19.255.254/32 192.168.29.100 0 100 0 i

 

14#ping 20.20.40.254 source lo0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.20.40.254, timeout is 2 seconds:
Packet sent with a source address of 20.20.14.254
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/3/5 ms

_______________

the problem is the L3 provider (IZFN and VSAT)

_______________

the configuration:

CSR

interface Loopback0
ip address 172.19.255.254 255.255.255.255
!
interface GigabitEthernet1
no ip address
negotiation auto
no mop enabled
no mop sysid
!
interface GigabitEthernet1.29
encapsulation dot1Q 29
ip address 192.168.29.100 255.255.255.0
!
interface GigabitEthernet1.30
encapsulation dot1Q 30
ip address 192.168.30.100 255.255.255.0
!
interface GigabitEthernet1.98
encapsulation dot1Q 98
ip address 10.120.98.17 255.255.255.0
!
interface GigabitEthernet1.172
encapsulation dot1Q 172
ip address 172.22.8.6 255.255.255.0

router bgp 65001
bgp log-neighbor-changes
bgp listen range 192.168.0.0/16 peer-group WIMAX
bgp listen range 172.22.0.0/16 peer-group VSAT
bgp listen range 10.120.0.0/16 peer-group IZFN
network 172.19.255.254 mask 255.255.255.255
neighbor IZFN peer-group
neighbor IZFN remote-as 65001
neighbor IZFN route-reflector-client
neighbor IZFN next-hop-self all
neighbor WIMAX peer-group
neighbor WIMAX remote-as 65001
neighbor WIMAX route-reflector-client
neighbor WIMAX next-hop-self all
neighbor VSAT peer-group
neighbor VSAT remote-as 65001
neighbor VSAT route-reflector-client
neighbor VSAT next-hop-self all

ip route 10.120.0.0 255.255.0.0 10.120.98.1
ip route 172.22.0.0 255.255.0.0 172.22.8.1
ip route 192.168.29.0 255.255.255.0 192.168.29.254
ip route 192.168.30.0 255.255.255.0 192.168.30.254

 

ASR-1000#sh ip bgp


Network Next Hop Metric LocPrf Weight Path
*>i 20.20.14.0/24 192.168.29.200 0 100 0 i
*>i 20.20.40.0/24 192.168.30.200 0 100 0 i
*>i 20.20.101.0/24 10.120.101.200 0 100 0 i
*>i 20.20.107.0/24 10.120.107.200 0 100 0 i
*>i 20.20.126.0/24 10.120.126.200 0 100 0 i
*>i 20.20.136.0/24 172.22.9.200 0 100 0 i
*> 172.19.255.254/32 0.0.0.0 0 32768 i

 126

 interface Loopback0
ip address 20.20.126.254 255.255.255.0
!
interface Ethernet0/0
ip address 10.120.126.200 255.255.255.0

router bgp 65001
bgp log-neighbor-changes
network 20.20.126.0 mask 255.255.255.0
neighbor 10.120.98.17 remote-as 65001

ip route 10.120.98.0 255.255.255.0 10.120.126.1

101

interface Loopback0
ip address 20.20.101.254 255.255.255.0
!
interface Ethernet0/0
ip address 10.120.101.200 255.255.255.0
!

router bgp 65001
bgp log-neighbor-changes
network 20.20.101.0 mask 255.255.255.0
neighbor 10.120.98.17 remote-as 65001

ip route 10.120.98.0 255.255.255.0 10.120.101.1

 

107

interface Loopback0
ip address 20.20.107.254 255.255.255.0
!
interface Ethernet0/0
ip address 10.120.107.200 255.255.255.0
!

router bgp 65001
bgp log-neighbor-changes
network 20.20.107.0 mask 255.255.255.0
neighbor 10.120.98.17 remote-as 65001

ip route 10.120.98.0 255.255.255.0 10.120.107.1

 

136

interface Loopback0
ip address 20.20.136.254 255.255.255.0
!
interface Ethernet0/0
ip address 172.22.9.200 255.255.255.0
!

router bgp 65001
bgp log-neighbor-changes
network 20.20.136.0 mask 255.255.255.0
neighbor 172.22.8.6 remote-as 65001

ip route 172.22.0.0 255.255.0.0 172.22.9.1

 

14

interface Loopback0
ip address 20.20.14.254 255.255.255.0
!
interface Ethernet0/0
ip address 192.168.29.200 255.255.255.0
!

router bgp 65001
bgp log-neighbor-changes
network 20.20.14.0 mask 255.255.255.0
neighbor 192.168.29.100 remote-as 65001

ip route 192.168.0.0 255.255.0.0 192.168.29.254

 

40

interface Loopback0
ip address 20.20.40.254 255.255.255.0
!
interface Ethernet0/0
ip address 192.168.30.200 255.255.255.0
!

router bgp 65001
bgp log-neighbor-changes
network 20.20.40.0 mask 255.255.255.0
neighbor 192.168.30.100 remote-as 65001


ip route 192.168.0.0 255.255.0.0 192.168.30.254

____________

all edges have these route in routing table

sh ip route bgp

Gateway of last resort is not set

20.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
B 20.20.14.0/24 [200/0] via 192.168.30.100, 00:21:53
B 20.20.101.0/24 [200/0] via 192.168.30.100, 00:21:53
B 20.20.107.0/24 [200/0] via 192.168.30.100, 00:21:53
B 20.20.126.0/24 [200/0] via 192.168.30.100, 00:21:53
B 20.20.136.0/24 [200/0] via 192.168.30.100, 00:21:52
172.19.0.0/32 is subnetted, 1 subnets
B 172.19.255.254 [200/0] via 192.168.30.100, 00:21:53

BGP.jpg

 

BGP.jpg

2 Replies 2

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello @mohammedsalih ,

you need to deploy an overlay network for example p2p GRE tunnels from hub router to all the remote sites.

Your connectivity is not working because the Service Providers that are working at Layer3 are not aware of each site LAN IP subnet so they cannot route packets with this kind of destination addresses.

Hope to help

Giuseppe

 

126#ping 20.20.14.254 source lo0

This LO0 is known by 20.20.14.x router?

Review Cisco Networking for a $25 gift card