cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Popup Hotspot Using ISR 1000 with WiFi/LTE for Teleworkers and Micro Branchesr
295
Views
0
Helpful
6
Replies
Highlighted
Beginner

BGP table have route but unable to ping

All have the router have 192.168.5.1 and 192.168.6.1 route in routing table via BGP. But unable to ping from 192.168.5.1 to 192.168.6.1
R5
router bgp 200
bgp log-neighbor-changes
network 10.0.15.0 mask 255.255.255.0
network 192.168.5.0
neighbor 10.0.15.2 remote-as 100

 

R1
router bgp 100
bgp log-neighbor-changes
neighbor 10.0.15.1 remote-as 200
neighbor 192.168.3.1 remote-as 100
neighbor 192.168.3.1 update-source Loopback0
neighbor 192.168.3.1 next-hop-self

 

R3
router bgp 100
bgp log-neighbor-changes
neighbor test peer-group
neighbor test remote-as 100
neighbor test update-source Loopback0
neighbor test route-reflector-client
neighbor 192.168.1.1 peer-group test
neighbor 192.168.2.1 peer-group test
neighbor 192.168.4.1 peer-group test

 

R4
router bgp 100
bgp log-neighbor-changes
neighbor 192.168.3.1 remote-as 100
neighbor 192.168.3.1 update-source Loopback0

 

R2
router bgp 100
bgp log-neighbor-changes
neighbor 192.168.3.1 remote-as 100
neighbor 192.168.3.1 update-source Loopback0
neighbor 192.168.3.1 next-hop-self
neighbor 192.168.6.1 remote-as 300
neighbor 192.168.6.1 ebgp-multihop 255
neighbor 192.168.6.1 update-source Loopback0
ip route 192.168.6.0 255.255.255.0 10.0.62.2
ip route 192.168.6.0 255.255.255.0 10.0.26.2


router bgp 300
bgp log-neighbor-changes
network 192.168.6.0
neighbor 192.168.2.1 remote-as 100
neighbor 192.168.2.1 ebgp-multihop 255
neighbor 192.168.2.1 update-source Loopback0
ip route 192.168.2.0 255.255.255.0 10.0.26.1
ip route 192.168.2.0 255.255.255.0 10.0.62.1

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Hall of Fame Expert

Re: BGP table have route but unable to ping

Hello @NayAungLin7876 ,

I think you have an R6 router in AS300 that has an eBGP session with R2 but you didn't provide its configuration.

 

we can see on R2:

router bgp 100

neighbor 192.168.6.1 remote-as 300
neighbor 192.168.6.1 ebgp-multihop 255
neighbor 192.168.6.1 update-source Loopback0
ip route 192.168.6.0 255.255.255.0 10.0.62.2
ip route 192.168.6.0 255.255.255.0 10.0.26.2

 

here I see two static routes to 192.168.6.0/24 via 10.0.62.2 and via 10.0.26.2 that can be two direct links between R2 and R6

 

From R5 what is the output of:

show ip bgp 192.168.6.0

 

You need to check the next-hop if it is 192.168.6.1 you have an issue the next-hop to a prefix must be outside the prefix / address block.

It shouldn't be because you have a lot of next-hop self in your network that are hiding this fact.

Check on R2

show ip bgp 192.168.6.0

 

and verify the BGP next-hop it is likely 192.168.6.1 with your setup and this is the root cause of your issues.

 

I would suggest for making tests to use additional loopbacks . This is very handy on Cisco routers.

 

Example

R6:

int loop66

desc net for BGP

ip address 192.168.66.6 255.255.255.0

no shut

 

router bgp 300

network 192.168.66.0

 

Hope to help

Giuseppe

 

View solution in original post

6 REPLIES 6
Highlighted
Hall of Fame Expert

Re: BGP table have route but unable to ping

Hello @NayAungLin7876 ,

I think you have an R6 router in AS300 that has an eBGP session with R2 but you didn't provide its configuration.

 

we can see on R2:

router bgp 100

neighbor 192.168.6.1 remote-as 300
neighbor 192.168.6.1 ebgp-multihop 255
neighbor 192.168.6.1 update-source Loopback0
ip route 192.168.6.0 255.255.255.0 10.0.62.2
ip route 192.168.6.0 255.255.255.0 10.0.26.2

 

here I see two static routes to 192.168.6.0/24 via 10.0.62.2 and via 10.0.26.2 that can be two direct links between R2 and R6

 

From R5 what is the output of:

show ip bgp 192.168.6.0

 

You need to check the next-hop if it is 192.168.6.1 you have an issue the next-hop to a prefix must be outside the prefix / address block.

It shouldn't be because you have a lot of next-hop self in your network that are hiding this fact.

Check on R2

show ip bgp 192.168.6.0

 

and verify the BGP next-hop it is likely 192.168.6.1 with your setup and this is the root cause of your issues.

 

I would suggest for making tests to use additional loopbacks . This is very handy on Cisco routers.

 

Example

R6:

int loop66

desc net for BGP

ip address 192.168.66.6 255.255.255.0

no shut

 

router bgp 300

network 192.168.66.0

 

Hope to help

Giuseppe

 

View solution in original post

Highlighted
Beginner

Re: BGP table have route but unable to ping

Thank you man. Your suggestions work for pinging from R5 to 192.168.66.1. But i still have a little confusions. Why I cannot ping from R5 to 192.168.6.1 although have route in routing table? Could you explain me more details if you have time?

Highlighted
Hall of Fame Expert

Re: BGP table have route but unable to ping

Hello @NayAungLin7876 ,

thanks for your kind remark

when BGP has to decide if an IPv4 prefix is usable it looks at the BGP next-hop.

In your case:

 

if the network 192.168.6.0 BGP command is on R6 router bgp 300 the BGP next-hop is part of the prefix advertised being 192.168.6.1.

This make BGP to stop considering 192.168.6.0/24 a prefix with a valid indipendent BGP next-hop.

if in your lab you configure R2 under router bgp 100 with network 192.168.6.0 the problem is fixed.

 

Hope to help

Giuseppe

 

Highlighted
VIP Mentor

Re: BGP table have route but unable to ping

Hello,

 

the topology drawing does not match the partial configuration you have posted, so it is hard to tell which one is right. Your R1 router is peering with R3 only, and not with R4. Your R4 router is peering with R3 only, and not with R1. In the drawing, it looks like you have the loopback interfaces reversed, R1 seems to have 192.168.3.1, and R3 192.168.1.1, make sure the loopback addresses match the routers, and that the peering is correct.

Highlighted
Beginner

Re: BGP table have route but unable to ping

R1 have the full mesh session in the iBGP network with all routers R1, R2,R3 and R4. Because R3 is the RR and R1,R2 and R4 is the route-reflector clients. So these all iBGP routers have the full mesh sessions.

Highlighted
VIP Mentor

Re: BGP table have route but unable to ping

Hello,

 

in the drawing, your R3 router appears to have IP address 192.168.1.1, and R1 192.168.3.1, which seem to be reversed...