cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1643
Views
0
Helpful
0
Replies

BPDU over L2TPv3

hideura
Level 1
Level 1

I'm connecting routers over ip network with L2TPv3.

R1 and R3 are located in a same site and R2 and R4 are in the other site.

L2TP connection between R1 and R2 looks fine but connection between R3 and R4 is not correctly tranfering bpdu.

I'm not using switch port on any routers.

1941 or 1812J has any problem with handling bpdu over l2tp?

Plus, I found some cisco document mention "promiscuous mode" but how can I set a interface to promiscuous mode?

"Because of the way in which L2TPv3 handles VLAN packets, the Ethernet interface must be configured
in promiscuous mode to capture all traffic received on the Ethernet segment attached to the router. All
frames are tunneled through the L2TP pseudowire."

R1 is 1921-01 Universal - 15.0(1)M4

R2 is 1921-02 Universal - 15.0(1)M4

R3 is 1941-01 Universal - 15.0(1)M4

R4 is 1812-01 Adv.Ent.Svc - 15.0(1)M4

R1

pseudowire-class L2TPv3
encapsulation l2tpv3
ip local interface Loopback0
!
pseudowire-class v201
encapsulation l2tpv3
ip local interface Loopback201
!
pseudowire-class v202
encapsulation l2tpv3
ip local interface Loopback202
!
pseudowire-class v203
encapsulation l2tpv3
ip local interface Loopback203
!
pseudowire-class v204
encapsulation l2tpv3
ip local interface Loopback204
!
interface Loopback0
ip address 1.1.1.21 255.255.255.255
ip ospf 1 area 0
!
!
interface Loopback201
ip address 1.1.1.201 255.255.255.255
ip ospf 1 area 0
!
!
interface Loopback202
ip address 1.1.1.202 255.255.255.255
ip ospf 1 area 0
!
!
interface Loopback203
ip address 1.1.1.203 255.255.255.255
ip ospf 1 area 0
!
!
interface Loopback204
ip address 1.1.1.204 255.255.255.255
ip ospf 1 area 0
!
!
interface GigabitEthernet0/0
ip address 10.102.1.1 255.255.255.0
ip ospf 1 area 0
duplex auto
speed auto
!
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
no keepalive
!
!
interface GigabitEthernet0/1.201
encapsulation dot1Q 201
xconnect 2.2.2.201 201 pw-class v201
!
interface GigabitEthernet0/1.202
encapsulation dot1Q 202
xconnect 2.2.2.202 202 pw-class v202
!
interface GigabitEthernet0/1.203
encapsulation dot1Q 203
xconnect 2.2.2.203 203 pw-class v203
!
interface GigabitEthernet0/1.204
encapsulation dot1Q 204
xconnect 2.2.2.204 204 pw-class v204
!
router ospf 1
router-id 1.1.1.21
log-adjacency-changes
!

R2

pseudowire-class L2TPv3
encapsulation l2tpv3
ip local interface Loopback0
!
pseudowire-class v201
encapsulation l2tpv3
ip local interface Loopback201
!
pseudowire-class v202
encapsulation l2tpv3
ip local interface Loopback202
!
pseudowire-class v203
encapsulation l2tpv3
ip local interface Loopback203
!
pseudowire-class v204
encapsulation l2tpv3
ip local interface Loopback204
!
interface Loopback0
ip address 2.2.2.22 255.255.255.255
ip ospf 1 area 0
!
!
interface Loopback201
ip address 2.2.2.201 255.255.255.255
ip ospf 1 area 0
!
!
interface Loopback202
ip address 2.2.2.202 255.255.255.255
ip ospf 1 area 0
!
!
interface Loopback203
ip address 2.2.2.203 255.255.255.255
ip ospf 1 area 0
!
!
interface Loopback204
ip address 2.2.2.204 255.255.255.255
ip ospf 1 area 0
!
!
interface GigabitEthernet0/0
ip address 10.102.2.2 255.255.255.0
ip ospf 1 area 0
duplex auto
speed auto
!
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
no keepalive
!
!
interface GigabitEthernet0/1.201
encapsulation dot1Q 201
xconnect 1.1.1.201 201 pw-class v201
!
interface GigabitEthernet0/1.202
encapsulation dot1Q 202
xconnect 1.1.1.202 202 pw-class v202
!
interface GigabitEthernet0/1.203
encapsulation dot1Q 203
xconnect 1.1.1.203 203 pw-class v203
!
interface GigabitEthernet0/1.204
encapsulation dot1Q 204
xconnect 1.1.1.204 204 pw-class v204
!
router ospf 1
router-id 2.2.2.22
log-adjacency-changes
!

R3

pseudowire-class L2TPv3
encapsulation l2tpv3
ip local interface Loopback0
!
pseudowire-class v201
encapsulation l2tpv3
ip local interface Loopback201
!
pseudowire-class v202
encapsulation l2tpv3
ip local interface Loopback202
!
pseudowire-class v203
encapsulation l2tpv3
ip local interface Loopback203
!
pseudowire-class v204
encapsulation l2tpv3
ip local interface Loopback204
!
interface Loopback0
ip address 3.3.3.23 255.255.255.255
!
!
interface Loopback201
ip address 3.3.3.201 255.255.255.255
!
!
interface Loopback202
ip address 3.3.3.202 255.255.255.255
!
!
interface Loopback203
ip address 3.3.3.203 255.255.255.255
!
!
interface Loopback204
ip address 3.3.3.204 255.255.255.255
!
!
interface GigabitEthernet0/0
ip address 10.102.3.3 255.255.255.0
duplex auto
speed auto
!
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
no keepalive
!
!
interface GigabitEthernet0/1.201
encapsulation dot1Q 201
xconnect 4.4.4.201 201 pw-class v201
!
interface GigabitEthernet0/1.202
encapsulation dot1Q 202
xconnect 4.4.4.202 202 pw-class v202
!
interface GigabitEthernet0/1.203
encapsulation dot1Q 203
xconnect 4.4.4.203 203 pw-class v203
!
interface GigabitEthernet0/1.204
encapsulation dot1Q 204
xconnect 4.4.4.204 204 pw-class v204
!
router ospf 200
log-adjacency-changes
network 3.3.3.0 0.0.0.255 area 0
network 10.102.3.0 0.0.0.255 area 0
!


R4

pseudowire-class L2TPv3
encapsulation l2tpv3
ip local interface Loopback0
!
pseudowire-class v201
encapsulation l2tpv3
ip local interface Loopback201
!
pseudowire-class v202
encapsulation l2tpv3
ip local interface Loopback202
!
pseudowire-class v203
encapsulation l2tpv3
ip local interface Loopback203
!
pseudowire-class v204
encapsulation l2tpv3
ip local interface Loopback204
!

interface Loopback0
ip address 4.4.4.24 255.255.255.255
!
!
interface Loopback201
ip address 4.4.4.201 255.255.255.255
!
!
interface Loopback202
ip address 4.4.4.202 255.255.255.255
!
!
interface Loopback203
ip address 4.4.4.203 255.255.255.255
!
!
interface Loopback204
ip address 4.4.4.204 255.255.255.255
!
!
interface FastEthernet0
ip address 10.102.4.4 255.255.255.0
duplex auto
speed auto
!
!
interface FastEthernet1
no ip address
duplex auto
speed auto
no keepalive
!
!
interface FastEthernet1.201
encapsulation dot1Q 201
xconnect 3.3.3.201 201 pw-class v201
!
interface FastEthernet1.202
encapsulation dot1Q 202
xconnect 3.3.3.202 202 pw-class v202
!
interface FastEthernet1.203
encapsulation dot1Q 203
xconnect 3.3.3.203 203 pw-class v203
!
interface FastEthernet1.204
encapsulation dot1Q 204
xconnect 3.3.3.204 204 pw-class v204
!
router ospf 200
log-adjacency-changes
network 4.4.4.0 0.0.0.255 area 0
network 10.102.4.0 0.0.0.255 area 0
!

Thanks in advance,

0 Replies 0
Review Cisco Networking for a $25 gift card