07-16-2023 11:07 AM - last edited on 10-18-2023 11:03 AM by Translator
show ip routecommand lists all subnets, I can
pingand traceroute any local address in either LAN.
LAN 172.16.5.0however NAT is not working for the Branch Office
LAN 172.16.4.0
pingtraffic from the Branch Office LAN to the internet and nothing displays when
debug ip natis enabled on the HQ NAT Router, nor does
show ip nat translationsshow any traffic to the Branch Office LAN
Solved! Go to Solution.
07-18-2023 09:19 AM - last edited on 10-18-2023 11:47 AM by Translator
IOU5#show run
hostname IOU5
!
interface Ethernet0/0
ip address 200.0.0.5 255.255.255.0
ip nat outside
ip virtual-reassembly in
!
interface Ethernet1/1
ip address 10.0.0.5 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
router eigrp 5
network 10.0.0.0 0.0.0.255
redistribute static metric 100 100 255 1 1500
!
ip nat inside source list 1 interface Ethernet0/0 overload
ip route 0.0.0.0 0.0.0.0 200.0.0.6
!
access-list 1 permit 3.3.3.3
access-list 1 permit 2.2.2.2
IOU1#show run
!
crypto isakmp policy 10
hash md5
authentication pre-share
crypto isakmp key mhm address 120.0.0.3
crypto isakmp key mhm address 0.0.0.0
!
crypto ipsec transform-set mhm esp-des
mode tunnel
!
crypto ipsec profile mhmspoke
set transform-set mhm
!
crypto map mhmtunnel 10 ipsec-isakmp
set peer 120.0.0.3
set transform-set mhm
match address 100
!
interface Tunnel0
ip address 5.0.0.1 255.255.255.0
no ip redirects
no ip next-hop-self eigrp 5
no ip split-horizon eigrp 5
ip nhrp map multicast dynamic
ip nhrp network-id 5
tunnel source Ethernet0/0
tunnel mode gre multipoint
tunnel key 5
tunnel protection ipsec profile mhmspoke
!
interface Tunnel1ip address 15.0.0.1 255.255.255.0tunnel source Ethernet0/0tunnel destination 120.0.0.3
!
interface Ethernet0/0
ip address 100.0.0.1 255.255.255.0
crypto map mhmtunnel
!
interface Ethernet1/1
ip address 10.0.0.1 255.255.255.0
!
router eigrp 5
network 5.0.0.0 0.0.0.255
network 10.0.0.0 0.0.0.255
!router eigrp 15network 15.0.0.0 0.0.0.255
!
ip forward-protocol nd
!
ip route 110.0.0.2 255.255.255.255 100.0.0.4
ip route 120.0.0.3 255.255.255.255 100.0.0.4
!access-list 100 permit gre host 15.0.0.1 host 15.0.0.3access-list 100 permit gre host 100.0.0.1 host 120.0.0.3
IOU2#show running-config
!
crypto isakmp policy 10
hash md5
authentication pre-share
crypto isakmp key mhm address 100.0.0.1
crypto isakmp key mhm address 0.0.0.0
!
!
crypto ipsec transform-set mhm esp-des
mode tunnel
!
!
crypto ipsec profile mhmspoke
set transform-set mhm
!
!
crypto map mhmtunnel 10 ipsec-isakmp
! Incomplete
set peer 100.0.0.1
set transform-set mhm
match address 100
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Tunnel0
ip address 5.0.0.2 255.255.255.0
no ip redirects
ip nhrp map 5.0.0.1 100.0.0.1
ip nhrp map multicast 100.0.0.1
ip nhrp network-id 5
ip nhrp nhs 5.0.0.1
tunnel source Ethernet0/1
tunnel mode gre multipoint
tunnel key 5
tunnel protection ipsec profile mhmspoke
!
interface Ethernet0/1
ip address 110.0.0.2 255.255.255.0
crypto map mhmtunnel
!
router eigrp 5
network 2.2.2.2 0.0.0.0
network 5.0.0.0 0.0.0.255
!
ip route 100.0.0.1 255.255.255.255 110.0.0.4
07-20-2023 07:05 AM
07-16-2023 12:52 PM - last edited on 10-18-2023 11:05 AM by Translator
"
pingtraffic from the Branch Office LAN to the internet and nothing displays when
debug ip natis enabled on the HQ NAT Router, nor does
show ip nat translationsshow any traffic to the Branch Office LAN"
Did you try to remote the
default route
on Branch side? I believe the traffic is leaving through ISP2
07-16-2023 03:06 PM - last edited on 10-18-2023 11:09 AM by Translator
ping 8.8.8.8from a PC in the Branch Office the
pingfails.
ping 8.8.8.8from the Branch Office Router the
pingsucceeds and a traceroute shows it that does leave through the ISP2.
default routeDid your mean remove the
default route
07-16-2023 03:20 PM - last edited on 10-18-2023 11:11 AM by Translator
Hi @JamesLilley1746 Yes I meant remove! haha...it was a typo, sorry.
If you run a tracert from the PC, it probably are going to ISP2, right? I believe the
default route
is taking preference over the EIGRP
The reason the
ping
fail from PC but not the router is probably because you have no NAT on the Branch Router towards ISP 2. When you
ping
from the router itselt the ISP2 knows how to reply but when you
ping
from the PC, the ISP2 does not know the
network 172.16.4.0
and that´s why the response from 8.8.8.8 does not come.
07-16-2023 03:29 PM - last edited on 10-18-2023 11:13 AM by Translator
default routeon the Branch Office router:
no ip route 0.0.0.0 0.0.0.0 32.221.21.150will the router still function? I thought there had to be a
default routefor routing to function.
ip route 0.0.0.0 0.0.0.0 GigabithEthernet 0/0/1
07-16-2023 03:40 PM - last edited on 10-18-2023 11:16 AM by Translator
default routeon the Branch Office router:
no ip route 0.0.0.0 0.0.0.0 32.221.21.150will the router still function? I thought there had to be a
default routefor routing to function.
If you want to sent the internet traffic towards ISP1 which I believe it on HQ, you can not have a
default route
pointing to ISP2. Yes, the router will function. If you need to send any traffic to ISP2, you can add specific route to ISP2 or you can stablish a routing protocol between Router branch and ISP2.
ip route 0.0.0.0 0.0.0.0 GigabithEthernet 0/0/1
Dont configure
default route
like that. Use IP address instead.
07-16-2023 04:04 PM - last edited on 10-18-2023 11:17 AM by Translator
default routeI lost connection with the Branch Office Router.
07-16-2023 04:29 PM
Then you access was through the ISP2?
But do you have access to HQ? If you access the router on HQ and try to access the router on Branch it should work, they have direct connection, dont they?
07-16-2023 04:38 PM - last edited on 10-18-2023 11:18 AM by Translator
default routeon the Branch Router the connection went down and I have not been able to reconnect.
ping or sshinto the Branch Router. I will have to go onsite tomorrow and connect directly.
07-16-2023 04:48 PM - last edited on 10-18-2023 11:22 AM by Translator
Sorry to hear that. If I knew you could lost access I would suggest to you add the commamd "
reload in x(time)
and not save the config.
This way whe you lost access you just need to wait X time.
Another option is config archive and setup rollback
What you can do tomorrow is return the
default route
and create a static route to 8.8.8..8 sending to HQ just for test purpose. As soon as you figure out how it works, you remove the
default route
and add it pointing to HQ.
But the conclusion to me is, with default routing sending to ISP2, the internet traffic will not go to HQ.
07-16-2023 03:26 PM - last edited on 10-18-2023 11:23 AM by Translator
this need some work, I will share with you the way to config but before that why you use
default route
in branch ?
07-16-2023 03:36 PM - last edited on 10-18-2023 11:25 AM by Translator
default routeI thought a router had to have a
default routein order to function.
default routeon the Branch Router:
no ip route 0.0.0.0 0.0.0.0 32.221.21.150and do not replace it with anything else the router will still function?
07-16-2023 03:39 PM - last edited on 10-18-2023 11:26 AM by Translator
two steps here
first default information in Hub toward Spoke
in Spoke you need static route for
Hub IP (tunnel)
toward ISP2
that it
07-16-2023 03:50 PM
One more note, you need to add Spoke Lan subnet in acl of NAT overload of hub.
Thanks
MHM
07-17-2023 07:40 AM - last edited on 10-18-2023 11:27 AM by Translator
LAN subnet 172.16.4.0to the ACL named NAT on the HUB (I assume you mean WAN Router)?
ip access-list extended NAT
permit ip 172.16.4.0 0.0.255 any
permit ip 172.16.5.0 0.0.0.255 any
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide