cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2552
Views
5
Helpful
10
Replies
jellybeanshiba
Beginner

Bridging on IOS XE (ISR 1100 Series) ??

Could any of you please tell me why I don't see the bridging related commands on IOS XE 16.6.6 (C1116-4P, IP Base) ?

 

C1116-4P(config)#interface Ethernet0/2/0
C1116-4P(config-if)#bridge?
% Unrecognized command
C1116-4P(config-if)#interface GigabitEthernet0/0/0
C1116-4P(config-if)#bridge?
% Unrecognized command
C1116-4P(config-if)#interface Vlan16              
C1116-4P(config-if)#bridge?
% Unrecognized command
1 ACCEPTED SOLUTION

Accepted Solutions
Georg Pauwen
VIP Expert

Hello,

 

IOS-XE doesn't support the legacy bridge groups, it uses BDI. Check the document below. IP Base should in theory be sufficient. Can you create service instances ?

 

https://www.cisco.com/c/en/us/support/docs/lan-switching/integrated-routing-bridging-irb/200650-Understanding-Bridge-Virtual-Interface.html

View solution in original post

10 REPLIES 10
balaji.bandi
VIP Master

try

 

bridge irb

bridge 1 protocol ieee

bridge 1 route ip

!

interface GigabitEthernet0/0/1

bridge-group 1

!

interface GigabitEthernet0/0/2

bridge-group 1

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

Thank you very much for your comment, but unfortunately it doesn't seem to work...

C1116-4P(config)#bridge 1 protocol ?
  dec          DEC protocol
  ibm          IBM protocol
  vlan-bridge  vlan-bridge protocol
! missing ieee C1116-4P(config)#bridge 1 protocol vlan-bridge C1116-4P(config)#bridge 1 route ip C1116-4P(config)#interface GigabitEthernet0/0/0 C1116-4P(config-if)#bridge-group ? % Unrecognized command C1116-4P(config-if)#bridge? % Unrecognized command
! neither bridge-group nor bridge-domain

 

Georg Pauwen
VIP Expert

Hello,

 

IOS-XE doesn't support the legacy bridge groups, it uses BDI. Check the document below. IP Base should in theory be sufficient. Can you create service instances ?

 

https://www.cisco.com/c/en/us/support/docs/lan-switching/integrated-routing-bridging-irb/200650-Understanding-Bridge-Virtual-Interface.html

View solution in original post

Thank you Georg, I tried it and it seems like working, except for the VDSL2-Interface (Ethernet0/2/0) or the integrated switch. As I originally intended to bridge between the VDSL2-Interface and a routed interface or a Vlan interface, it didn't achieve anything in the end, but I'm glad to have learned that bridging is configured differently on IOS XE.

C1116-4P(config)#interface Ethernet0/2/0 ! The VDSL-Interface
C1116-4P(config-if)#service ?
% Unrecognized command
C1116-4P(config-if)#interface GigabitEthernet0/0/0 ! The «regular» interface.
C1116-4P(config-if)#service ?
  instance  Configure Ether Service Instance

C1116-4P(config-if)#interface GigabitEthernet0/1/0 ! The first port of the integrated switch.
C1116-4P(config-if)#service ?
% Unrecognized command
C1116-4P(config-if)#interface Vlan16 ! An VLAN-Interface.
C1116-4P(config-if)#service ?
  instance  Configure Ether Service Instance

 

Dear Georg,

I tried configuring the bridging on the C1100 platform again – Turned out, that I hadn't read the documentation you suggested as I should. Bridging is now working and I'm very grateful for your help. Thank you so much!

ip-100-127-11-11(config)#do show running-config | section Ethernet0/2/0|GigabitEthernet0/0/0
interface GigabitEthernet0/0/0
 no ip address
 negotiation auto
 service instance 100 ethernet
  encapsulation dot1q 10
  rewrite ingress tag pop 1 symmetric
  bridge-domain 100
 !
interface Ethernet0/2/0
 no ip address
 no negotiation auto
 no cdp enable
 service instance 100 ethernet
  encapsulation untagged
  bridge-domain 100
 !
ip-100-127-11-11(config)#do show bridge-domain 100                                          
Bridge-domain 100 (2 ports in all)
State: UP                    Mac learning: Enabled
Aging-Timer: 300 second(s)
    GigabitEthernet0/0/0 service instance 100
    Ethernet0/2/0 service instance 100
   AED MAC address    Policy  Tag       Age  Pseudoport
   0   AAAA.AAAA.AAAA forward dynamic   299  Ethernet0/2/0.EFP100
   0   BBBB.BBBB.BBBB forward dynamic   299  GigabitEthernet0/0/0.EFP100

 

Hi!

 

I'm about to do the same thing - can I ask please what it was you were doing wrong as it looks like to me the service instance command should be available on all interfaces on this platform?

Hi @scidoner,

 

Thank you for your reply. Unfortunately though, I don’t remember what the issue was, nor have I the bridging configuration in place anymore. But if you see the command service instance being accepted where you need, I don’t see any reason why it shouldn’t work. Go ahead and configure it as you need, I’ll be happy to have a look on your config if it won’t work

 

Best regards,

 

iichikocchi

Awesome thank you for your reply!!! 

Just came here to say, the VDSL bridging works just fine on this platform  

MarcelSmal
Beginner

Hey guys,

 

I was wondering if anyone tried bridging a ISR C1117-4PLTE to bridge the LTE port to the GI0/0/0 ports?

 

I cant seem to follow these commands to get it working as I dont have the options displayed in this link:

https://www.cisco.com/c/en/us/support/docs/lan-switching/integrated-routing-bridging-irb/200650-Understanding-Bridge-Virtual-Interface.html