cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
12789
Views
10
Helpful
16
Replies

C819-4G-LTE-G 4G connection don't come up

hencar
Contributor
Contributor

Hi,

 

Cant get 4G connection to work in a C819 router.

Get this error message in the log:

*Mar  5 07:15:54.335: %PLATFORM-4-CELLULAR_MODEM_SKU_MISMATCH: Mismatch detected between installed modem Unknown modem on SKU type C819-4G-LTE-G. Expected modem for this SKU is MC7710

Anyone know how to fix it?

//HC

16 Replies 16

mziyada
Cisco Employee
Cisco Employee

Hi hencar,,

 

try to upgrade your firmware version to the release 3.5.29.2. let me know if you already have this version installed in your modem.

I already upgraded the router with version 15.4(3)M2 and the modem with version SWI9200X_03.05.29.02ap and it still does not work.

I got this error message when i run "sh cellular 0 all"

Warning: Mismatch detected between platform/module
and installed modem.Check system log for details

//Henrik

 

Hi Hencar,

I Just had the exact the same problem with a 1921

my router came with IOS 15.5.1T preinstalled

After reading this post I decided to downgrade the software even further so i installed 15.3.3M5(MD) which is a suggested release at the moment

 

The 4G card is recognized with that IOS!

 

Regards

 

Pim

try downgrade ios

I am having the eaxact same problem, I tried to downgrade to the version you mention aboe and others with no luck... did you manage to find a solution?

regards,

Panos

Hi,

Did you downgrade to 15.3.3M5(MD) or 15.3.3M6(MD)?

That software is working for me!

Thank you,

c1900-universalk9-mz.SPA.153-3.M6 did the trick.., I thought I had allready tested but I was confused with 154-3

regards,

Panos

I have 1921 with EHWIC-4G-LTE-G. Every time I reboot my router, the 4G internet will not come up. But if I shut and unshut the cell 0/0/0, then the 4G will work.

I google it and find someone write a EEM script and it works for me.

event manager applet ResetCellOnBoot
 event timer countdown name ResetIn2Mins time 120
 action 1   cli command "enable"
 action 2   cli command "clear interface cellular 0/0/0"
 action 9   cli command "end"
 action 9.9 cli command "logout"

Hi Chanhkt,

Which Version of IOS are you using?

After using c1900-universalk9-mz.SPA.153-3.M6 the Modem is working but I can't get it to connect.

I can send sms messages but it doesn't get an IP, I am using the following config.

and tried both chat scripts

chat-script lte "" "AT!CALL" TIMEOUT 60 "OK"
chat-script HSPAPLUS "" "AT!SCACT=1,1" TIMEOUT 60 "OK"


interface Cellular0/0/0
 ip address negotiated
 ip nat outside
 ip virtual-reassembly in
 encapsulation slip
 dialer in-band
 dialer idle-timeout 0
 dialer string HSPAPLUS
 dialer-group 1
 async mode interactive

line 0/0/0
 script dialer HSPAPLUS
 no exec

I am getting the following from debug

Mar 17 10:37:59.331: CHAT0/0/0: Attempting async line dialer script
Mar 17 10:37:59.331: CHAT0/0/0: Dialing using Modem script: HSPAPLUS & System script: none
Mar 17 10:37:59.331: CHAT0/0/0: process started
Mar 17 10:37:59.331: CHAT0/0/0: Asserting DTR
Mar 17 10:37:59.331: CHAT0/0/0: Chat script HSPAPLUS started
Mar 17 10:37:59.331: CHAT0/0/0: Sending string: AT!SCACT=1,1
Mar 17 10:37:59.331: CHAT0/0/0: Expecting string: OK.....

Mar 17 10:38:59.331: CHAT0/0/0: Timeout expecting: OK
Mar 17 10:38:59.331: CHAT0/0/0: Chat script HSPAPLUS finished, status = Connection timed out; remote host not responding..

also tried the clear interface cell 0/0/0

Thank you

Panos

Please give me:

sh cel 0 profile

and the profile config for cel 0 HSPAPLUS

regards Tom

ATHGW#sh cell 0/0/0 all
Hardware Information
====================
Modem Firmware Version = SWI9200X_03.05.29.02
Modem Firmware built = 2014/06/16 17:56:29
Hardware Version = 1.0
International Mobile Subscriber Identity (IMSI) = 202010906029492
International Mobile Equipment Identity (IMEI) = 3XXXXXXXXXXXX
Integrated Circuit Card ID (ICCID) = 89300100120719546122
Mobile Subscriber International Subscriber
IDentity Number (MSISDN) =
Current Modem Temperature = 26 deg C

Profile Information
====================
Profile password Encryption level: 7


Profile 1 = INACTIVE* **
--------
PDP Type = IPv4
Access Point Name (APN) = i-amadeus
Authentication = None

  * - Default profile
 ** - LTE attach profile

br,

Panos

Give me the config:

beginning with

controller cel 0

like:

HSPAPLUS sim dataprofile 1 attach-profile 1 slot 0

- i will use LTE

 

rg

Tom

Hi,


controller Cellular 0/0
!
track 1 ip sla 1 reachability
!
ip tftp source-interface GigabitEthernet0/0
!
!
interface Cellular0/0/0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer idle-timeout 0
dialer string HSPAPLUS
dialer-group 1
async mode interactive


!
control-plane
!
!
!
line con 0
line aux 0
line 2

line 0/0/0
script dialer HSPAPLUS
no exec
line vty 0 4
exec-timeout 120 0
password 7 xxxxxxxxxxxxx
login local
transport input telnet ssh
!

regards,

Panos

pboot
Beginner
Beginner

Hi all,

I have two new C819G-4G-G-K9 with exact the same error message. (both have a MC7710)

Both are running:

Cisco IOS Software, C800 Software (C800-UNIVERSALK9-M), Version 15.4(3)M1, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2014 by Cisco Systems, Inc.
Compiled Sat 25-Oct-14 07:36 by prod_rel_team

ROM: System Bootstrap, Version 15.2(2r)T1, RELEASE SOFTWARE (fc1)

VPN_HEERLEN uptime is 3 hours, 3 minutes
System returned to ROM by power-on
System image file is "flash:c800-universalk9-mz.SPA.154-3.M1.bin"

#show cellular 0 hardware
Modem Firmware Version = SWI9200X_03.05.24.00Aap
Modem Firmware built = 2013/11/01 21:34:04
Hardware Version = 10
International Mobile Subscriber Identity (IMSI) = 204080666314816
International Mobile Equipment Identity (IMEI) = 359470040276307
Integrated Circuit Card ID (ICCID) = 8931086113113999169
Mobile Subscriber Integrated Services
Digital Network-Number (MSISDN) =
Current Modem Temperature = 0 deg C
PRI SKU ID = 9903047, PRI version = 01.00

Any solutions yet?

With kind regards.

Paulb.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: