C887 adsl configuration
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
08-02-2013 05:57 AM - edited 03-04-2019 08:38 PM
Dear every body,
i am a biginner in cisco, i am trying to configure an adsl connection on a cisco 887,but i stuck
i will appreciate your help
here is the sh run
wampo#sh run
Building configuration...
Current configuration : 3845 bytes
!
! Last configuration change at 12:27:01 UTC Fri Aug 2 2013
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname wampo
!
boot-start-marker
boot-end-marker
!
!
no logging buffered
enable secret 5 $1$QyfG$jZ54E5XQIVqGLSRLqiMng.
enable password xxxxxxx
!
no aaa new-model
memory-size iomem 10
!
crypto pki trustpoint TP-self-signed-180731608
enrollment selfsi
subject-name cn=IOS-Self-Signed-Certificate-180731608
revocation-check none
rsakeypair TP-self-signed-180731608
!
!
crypto pki certificate chain TP-self-signed-180731608
certificate self-signed 01
30820229 30820192 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
quit
!
!
ip dhcp excluded-address 10.99.51.1 10.99.51.10
ip dhcp excluded-address 10.99.51.100 10.99.51.254
!
ip dhcp pool dhcppool1
import all
network 10.99.51.0 255.255.255.0
dns-server 213.154.95.126 213.154.64.13
!
!
!
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
license udi pid CISCO887VA-SEC-K9 sn FCZ1719C3EQ
!
!
username afaye privilege 15 secret 4 SMZzYgSsGZk9/MyjLnM0C0lJGVQpcrrU1zcxGMEqr9U
!
!
!
!
!
controller VDSL 0
!
!
!
interface Ethernet0
no ip address
!
interface ATM0
no ip address
no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
ip dhcp client client-id Dialer3
pvc 0/35
pppoe-client dial-pool-number 2
!
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
shutdown
!
interface FastEthernet2
no ip address
shutdown
!
interface FastEthernet3
no ip address
shutdown
!
interface Vlan1
ip address 10.99.51.2 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1412
!
interface Dialer0
no ip address
shutdown
!
interface Dialer1
no ip addre
shutdown
!
interface Dialer2
no ip address
shutdown
!
interface Dialer3
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 2
dialer-group 3
ppp authentication chap callin
ppp chap hostname warmer2-adsl
ppp chap password 0 wwfwamer
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 600 life 86400 requests 10000
!
!
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0
!
dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit
dialer-list 3 protocol ip permit
!
!
control-plane
!
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
privilege level 15
password panda1
login local
transport input telnet ssh
!
!
end
- Labels:
-
Other Routing
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
08-02-2013 10:46 PM
Hello Aliou,
First of all, kindly let me know what exactly is the issue.
We need to understand if the DSL line is failing to train up (Layer 1 i.e Controller is UP or DOWN) or is it the Layer 2 (PPP) that is failing.
However, to start with, I will provide you with the configuration to set-up the PPPOA connection from scratch.
1. Sample configuration to set-up the PPPOA connection,
a. Configure Ingress (LAN) interface:
Router(config)#interface Gig 0/0 (Any Ethernet/LAN facing port)
Router(config-if)#description internal interface
Router(config-if)#ip address x.x.x.x x.x.x.x
Router(config-if)#ip nat inside
Router(config-if)#no shut
b. Configure Egress(WAN) interface:
Router(config)#interface ATM0
Router(config-if)#no ip address
Router(config-if)#no shut
Router(config-if)#no atm ilmi-keepalive
Router(config-if)#dsl operating-mode auto
Router(config)#interface ATM0.1 point-to-point
Router(config-subif)#pvc 0/38
Router(config-if-atm-vc)# encapsulation aal5mux ppp dialer
Router(config-if-atm-vc)# dialer pool-member 1
Router(config-if-atm-vc)# exit
c. Configure Dialer interface:
Router(Config)#interface dialer1
Router(Config)#ip address negotiated
Router(Config)#ip mtu 1492
Router(Config)#ip nat outside
Router(Config)#encapsulation ppp
Router(Config)#dialer pool 1
Router(Config)#dialer-group 1
Router(Config)#ppp authentication chap pap callin
Router(Config)#ppp chap hostname xxxxx
Router(Config)#ppp chap password xxxxx
Router(Config)#end
Once you configure the above, plug in the DSL line onto the ATM port and wait for 5 minutes to see the DSL train up.
Once the DSL trains up, if everything goes fine, you should be able to see an IP address on the Dialer interface.
Use the command "Show ip int brief" to check whether the Dialer interface has an IP address or not.
In case, if the Dialer interface fails to get an Ip address, we should then start investigating the cause of failure.
Use the below commands and provide me the outputs in case of failure,
1. Show dsl int atm0 (if this does not work use "show controller vdsl 0"
This would tell us whether teh DSL line has trained UP or not. In a working state, you should be able to see "MODEM in SHOWTIME" state.
In case, if the Controller is UP and still the Dialer interface has no IP address (if & only if the you are negotiating an IP address from the ISP), it means the DSL has trained UP successfully but failed to establish a connection due to a possible failure in Layer 2.
2. To troubleshoot Layer 2, we need to run the following debugs,
Ensure you log the debugging to the buffer,
(config)#no logging console
(Config)#logging buffered debug
(config)#logging buffered 12288
(config)# exit
In privilege mode, enable the debugs.
debug ppp negotiation
debug ppp authentication
debug ppp error
Try the above and let me know the outcome
Cheers,
Mithun
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
08-03-2013 06:29 AM
Hi Mithun
Thanks a lot for your reply
I did not try your solution yet
But just to precise that i did not use the interface Gig 0/0 , i ve used Vlan1 with ip address 10.99.51.2 , to connect to the pc
For the pvc, it s 0/35
the ppp is alos pppoe insted of pppoa , it s given by ISP
After my 1st config, it did use the dialer3 as dialer interface and atm0.1 as atm interface
I did get a public ip address on dialer3 when i type sh ip int brief command, that mean that dialer3 is getting ip addres from isp
i can ping from console this public address too, and the vlan1 address also
but if i ping another public ip, like 213.154.95.126 or google.com; it fails
I will try your commands, and let your know
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
08-03-2013 09:48 AM
Hello Aliou,
Like you've mentioned, getting an IP address on the Dialer interface simply means that the DSL has trained UP and connection has been successfully established.
Now, in order to reach out to any IP address on the internet, make sure you have the below configurations on the device,
1. (config)# ip route 0.0.0.0 0.0.0.0 Dialer 3 (Default route)
With this, you should be able to reach other public IP addresses.
2. in order to be able to ping a website like "www.google.com", your router should be able to resolve this to an IP address, for which we need to configure a DNS server and in the config below, i'm using the public DNS 4.2.2.2
(config)# ip domain-lookup
(config)# ip name-server 4.2.2.2
With these commands in place, you should be able to ping any Public address or any domain.
Cheers,
Mithun
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
08-05-2013 06:04 AM
Hi Mithun,
i do try but i still can't any public ip address
here s the outcome of the : i ve used the "!!" to comment my understanding!!
show controller vdsl 0
wampo#sh controller vsdl 0
Controller VDSL 0 is UP
Daemon Status: Up
XTU-R (DS) XTU-C (US)
Chip Vendor ID: 'BDCM' 'BDCM'
Chip Vendor Specific: 0x0000 0xA341
Chip Vendor Country: 0xB500 0xB500
Modem Vendor ID: 'CSCO' ' '
Modem Vendor Specific: 0x4602 0x0000
Modem Vendor Country: 0xB500 0x0000
Serial Number Near: FCZ1719C3EQ 887VA-S 15.2(4)M
Serial Number Far:
Modem Version Near: 15.2(4)M
Modem Version Far: 0xa341
Modem Status: TC Sync (Showtime!)
DSL Config Mode: AUTO
Trained Mode: G.992.1 (ADSL) Annex A
TC Mode: ATM
Selftest Result: 0x00
DELT configuration: disabled
DELT state: not running
Trellis: ON ON
SRA: disabled disabled
SRA count: 1 0
Bit swap: enabled enabled
Bit swap count: 0 1
Line Attenuation: 47.5 dB 31.5 dB
Signal Attenuation: 47.5 dB 0.0 dB
Noise Margin: 21.3 dB 30.0 dB
Attainable Rate: 3708 kbits/s 1204 kbits/s
Actual Power: 16.5 dBm 11.9 dBm
Total FECC: 1144 0
Total ES: 39 0
Total SES: 35 0
Total LOSS: 5 0
Total UAS: 89 89
Total LPRS: 0 0
Total LOFS: 27 0
Total LOLS: 0 0
Full inits: 4
Failed full inits: 0
Short inits: 0
Failed short inits: 0
odem PHY Version: A2pv6C035j.d23j
Vendor Version: Ap6v35j.23j 68
DS Channel1 DS Channel0 US Channel1 US Channel0
Speed (kbps): 0 1024 0 256
SRA Previous Speed: 0 1024 0 0
Previous Speed: 0 1024 0 256
Total Cells: 0 7626695 0 0
User Cells: 0 932 0 0
Reed-Solomon EC: 0 0 0 0
CRC Errors: 0 1485 0 0
Header Errors: 0 0 0 0
Interleave (ms): 0.00 16.00 0.00 16.00
Actual INP: 0.00 4.21 0.00 5.81
Training Log : Stopped
Training Log Filename : flash:vdsllog.bin
wampo# sh ip int brief
col
ATM0 unassigned YES NVRAM up up
ATM0.1 unassigned YES unset up up
Dialer0 unassigned YES TFTP administratively down down
Dialer1 unassigned YES TFTP administratively down down
Dialer2 unassigned YES TFTP administratively down down
Dialer3 172.31.38.183 YES IPCP up up
Ethernet0 unassigned YES NVRAM down down
FastEthernet0 unassigned YES unset up up
FastEthernet1 unassigned YES unset administratively down down
FastEthernet2 unassigned YES unset administratively down down
FastEthernet3 unassigned YES unset administratively down dow
NVI0 unassigned YES unset administratively down down
Virtual-Access1 unassigned YES unset up up
Virtual-Access2 unassigned YES unset up up
Vlan1 10.99.51.2 YES manual up up
-----------------------------------------------------------
wampo#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
Gateway of last resort is 0.0.0.0 to network 0.0.0.0
S* 0.0.0.0/0 is directly connected, Dialer3
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.99.51.0/24 is directly connected, Vlan1
L 10.99.51.2/32 is directly connected, Vlan1
172.31.0.0/32 is subnetted, 2 subnets
C 172.31.32.1 is directly connected, Dialer3
C 172.31.38.183 is directly connected, Dialer3
!! i think the 2nd line(10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks)
!!must be delete, but i don't know how,can you give the command
!! i don't understand also the 4th line(L 10.99.51.2/32 is directly connected, Vlan1) is it necessary to have it
!! is the gateway correct !!
------------------------
wampo#sh ip access-list
Extended IP access list 101
10 permit ip 10.99.51.0 0.0.0.255 any (6001 matches)
!! we use in the LAN this ip address 10.99.51.0 255.255.255.0!! check if this access-list is corect!!
--------------------------------------
wampo#sh ip name-server
213.154.95.126
!!this the dns we use from isp on other routers to connect to the internet!!
Regards
