03-14-2020 06:12 PM
Trying to setup soho internet with C891 to Verizon ONT(FiOS) but receiving encapsulation failed in debug ip packet.
Config and debug log below:
version 15.3
!
ip dhcp excluded-address 192.168.1.1 192.168.1.5
!
ip dhcp pool InsideDHCP
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8 8.8.4.4
! class any
vpdn enable
!
vpdn-group 1
!
vpdn-group pppoe
!
interface FastEthernet0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0
switchport access vlan 10
no ip address
!
interface GigabitEthernet1
no ip address
!
interface GigabitEthernet2
no ip address
!
interface GigabitEthernet3
no ip address
!
interface GigabitEthernet4
no ip address
!
interface GigabitEthernet5
no ip address
!
interface GigabitEthernet6
no ip address
!
interface GigabitEthernet7
no ip address
!
interface GigabitEthernet8
ip address dhcp
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1452
!
interface Async3
no ip address
encapsulation slip
!
interface Dialer1
ip address dhcp client-id GigabitEthernet8
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1452
ip flow ingress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname guest
ppp chap password 7 040A0D0F1DF05155C
ppp pap sent-username guest password 7 0055150FC07032D15
no cdp enable
!
ip nat inside source list 10 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 10 permit 0.0.0.0 255.255.255.0
sh ip int br output:
Interface IP-Address OK? Method Status Protocol
Async3 unassigned YES unset down down
BRI0 unassigned YES unset administratively down down
BRI0:1 unassigned YES unset administratively down down
BRI0:2 unassigned YES unset administratively down down
FastEthernet0 unassigned YES unset administratively down down
GigabitEthernet0 unassigned YES unset up up
GigabitEthernet1 unassigned YES unset down down
GigabitEthernet2 unassigned YES unset down down
GigabitEthernet3 unassigned YES unset down down
GigabitEthernet4 unassigned YES unset down down
GigabitEthernet5 unassigned YES unset down down
GigabitEthernet6 unassigned YES unset down down
GigabitEthernet7 unassigned YES unset down down
GigabitEthernet8 108.18.151.203 YES DHCP up up
NVI0 108.18.151.203 YES unset up up
Vlan1 unassigned YES unset administratively down down
Vlan10 192.168.1.1 YES manual up up
ping 108.18.151.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 108.18.151.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
debug ip packet output:
Mar 15 12:47:23 EDT: IP: s=108.18.151.203 (local), d=3.93.76.89 (Dialer1), len 84, output feature, Post-routing NAT Outside(24), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 15 12:47:23 EDT: IP: s=108.18.151.203 (local), d=3.93.76.89 (Dialer1), len 84, output feature, Common Flow Table(27), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 15 12:47:23 EDT: IP: s=108.18.151.203 (local), d=3.93.76.89 (Dialer1), len 84, output feature, Stateful Inspection(28), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 15 12:47:23 EDT: IP: s=108.18.151.203 (local), d=3.93.76.89 (Dialer1), len 84, output feature, NAT ALG proxy(59), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 15 12:47:23 EDT: IP: s=108.18.151.203 (local), d=3.93.76.89 (Dialer1), len 84, output feature, Post-Ingress-NetFlow(74), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 15 12:47:23 EDT: IP: s=108.18.151.203 (local), d=3.93.76.89 (Dialer1), len 84, output feature, Dialer idle reset(93), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 15 12:47:23 EDT: IP: s=108.18.151.203 (local), d=3.93.76.89 (Dialer1), len 84, encapsulation failed
Solved! Go to Solution.
03-15-2020 02:49 PM
Hello,
try the simplified config below (important parts marked in bold):
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface FastEthernet0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0
switchport access vlan 10
no ip address
!
interface GigabitEthernet1
no ip address
!
interface GigabitEthernet2
no ip address
!
interface GigabitEthernet3
no ip address
!
interface GigabitEthernet4
no ip address
!
interface GigabitEthernet5
no ip address
!
interface GigabitEthernet6
no ip address
!
interface GigabitEthernet7
no ip address
!
interface GigabitEthernet8
ip address dhcp
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Async3
no ip address
encapsulation slip
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat inside source list 10 interface GigabitEthernet8 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet8 dhcp
!
access-list 10 permit 192.168.1.0 0.0.0.255
!
03-14-2020 10:18 PM
Hello,
change access list 10 to:
access-list 10 permit 192.168.1.0 0.0.0.255
03-15-2020 04:55 AM
updated ACL:
#sh ip access-list 10
Standard IP access list 10
10 permit 192.168.1.0, wildcard bits 0.0.0.255 (124 matches)
#sh ip access-list 10
Standard IP access list 10
10 permit 192.168.1.0, wildcard bits 0.0.0.255 (126 matches)
#sh ip access-list 10
Standard IP access list 10
10 permit 192.168.1.0, wildcard bits 0.0.0.255 (127 matches)
but no change in access, not able to access internet.
NAT translations show none:
#sh ip nat translations
#
NAT statistics show:
#sh ip nat statistics
Total active translations: 0 (0 static, 0 dynamic; 0 extended)
Peak translations: 0
Outside interfaces:
Dialer1
Inside interfaces:
Vlan10
Hits: 0 Misses: 0
CEF Translated packets: 0, CEF Punted packets: 0
Expired translations: 0
Dynamic mappings:
-- Inside Source
[Id: 1] access-list 10 interface Dialer0 refcount 0
Total doors: 0
Appl doors: 0
Normal doors: 0
Queued Packets: 0
Debug ip packet still shows encapsulation failed:
Mar 16 07:41:47 EDT: IP: s=192.168.1.8 (Vlan10), d=192.168.1.255 (Vlan10), len 78, output feature, NAT Inside(8), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=192.168.1.8 (Vlan10), d=192.168.1.255 (Vlan10), len 78, output feature, Common Flow Table(27), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=192.168.1.8 (Vlan10), d=192.168.1.255 (Vlan10), len 78, output feature, Stateful Inspection(28), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=192.168.1.8 (Vlan10), d=192.168.1.255 (Vlan10), len 78, rcvd 3
Mar 16 07:41:47 EDT: IP: s=192.168.1.8 (Vlan10), d=192.168.1.255, len 78, stop process pak for forus packet
Mar 16 07:41:47 EDT: IP: s=192.168.1.8 (Vlan10), d=192.168.1.255, len 78, enqueue feature, TCP Adjust MSS(5), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=192.168.1.8 (Vlan10), d=192.168.1.255, len 78, input feature, Common Flow Table(5), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=192.168.1.8 (Vlan10), d=192.168.1.255, len 78, input feature, Stateful Inspection(7), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=192.168.1.8 (Vlan10), d=192.168.1.255, len 78, input feature, Virtual Fragment Reassembly(36), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=192.168.1.8 (Vlan10), d=192.168.1.255, len 78, input feature, Virtual Fragment Reassembly After IPSec Decryption(52), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=192.168.1.8 (Vlan10), d=192.168.1.255, len 78, input feature, MCI Check(94), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=192.168.1.8 (Vlan10), d=192.168.1.255, len 78, input feature, TCP Adjust MSS(96), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: tableid=0, s=192.168.1.8 (Vlan10), d=192.168.1.255 (Vlan10), routed via RIB
Mar 16 07:41:47 EDT: IP: s=192.168.1.8 (Vlan10), d=192.168.1.255 (Vlan10), len 78, output feature, NAT Inside(8), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=192.168.1.8 (Vlan10), d=192.168.1.255 (Vlan10), len 78, output feature, Common Flow Table(27), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=192.168.1.8 (Vlan10), d=192.168.1.255 (Vlan10), len 78, output feature, Stateful Inspection(28), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=192.168.1.8 (Vlan10), d=192.168.1.255 (Vlan10), len 78, rcvd 3
Mar 16 07:41:47 EDT: IP: s=192.168.1.8 (Vlan10), d=192.168.1.255, len 78, stop process pak for forus packet
Mar 16 07:41:47 EDT: IP: s=192.168.1.8 (Vlan10), d=192.168.1.255, len 78, enqueue feature, TCP Adjust MSS(5), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=185.175.93.105 (GigabitEthernet8), d=72.83.148.109, len 40, input feature, Common Flow Table(5), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=185.175.93.105 (GigabitEthernet8), d=72.83.148.109, len 40, input feature, Stateful Inspection(7), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=185.175.93.105 (GigabitEthernet8), d=72.83.148.109, len 40, input feature, MCI Check(94), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: tableid=0, s=185.175.93.105 (GigabitEthernet8), d=72.83.148.109 (GigabitEthernet8), routed via RIB
Mar 16 07:41:47 EDT: IP: s=185.175.93.105 (GigabitEthernet8), d=72.83.148.109 (GigabitEthernet8), len 40, output feature, Common Flow Table(27), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=185.175.93.105 (GigabitEthernet8), d=72.83.148.109 (GigabitEthernet8), len 40, output feature, Stateful Inspection(28), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=185.175.93.105 (GigabitEthernet8), d=72.83.148.109 (GigabitEthernet8), len 40, rcvd 3
Mar 16 07:41:47 EDT: IP: s=185.175.93.105 (GigabitEthernet8), d=72.83.148.109, len 40, stop process pak for forus packet
Mar 16 07:41:47 EDT: IP: s=185.175.93.105 (GigabitEthernet8), d=72.83.148.109, len 40, enqueue feature, TCP Adjust MSS(5), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=72.83.148.109 (local), d=185.175.93.105, len 40, local feature, NAT(2), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=72.83.148.109 (local), d=185.175.93.105 (Dialer1), len 40, sending
Mar 16 07:41:47 EDT: IP: s=72.83.148.109 (local), d=185.175.93.105 (Dialer1), len 40, output feature, Post-routing NAT Outside(24), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=72.83.148.109 (local), d=185.175.93.105 (Dialer1), len 40, output feature, Common Flow Table(27), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=72.83.148.109 (local), d=185.175.93.105 (Dialer1), len 40, output feature, Stateful Inspection(28), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=72.83.148.109 (local), d=185.175.93.105 (Dialer1), len 40, output feature, NAT ALG proxy(59), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=72.83.148.109 (local), d=185.175.93.105 (Dialer1), len 40, output feature, Post-Ingress-NetFlow(74), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=72.83.148.109 (local), d=185.175.93.105 (Dialer1), len 40, output feature, Dialer idle reset(93), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 07:41:47 EDT: IP: s=72.83.148.109 (local), d=185.175.93.105 (Dialer1), len 40, encapsulation failed
03-15-2020 06:09 AM
Hello,
add:
dialer-list 1 protocol ip permit
to your configuration...
03-15-2020 06:15 AM
Hello,
also remove 'ip address dhcp' from the physical interface:
interface GigabitEthernet8
--> no ip address dhcp
03-15-2020 07:20 AM
no change after adding the dialer-list command
before removing 'ip address dhcp' from Gig8 there was an ip address assigned:
Interface IP-Address OK? Method Status Protocol
Async3 unassigned YES unset down down
BRI0 unassigned YES unset administratively down down
BRI0:1 unassigned YES unset administratively down down
BRI0:2 unassigned YES unset administratively down down
Dialer1 unassigned YES DHCP up up
FastEthernet0 unassigned YES unset administratively down down
GigabitEthernet0 unassigned YES unset up up
GigabitEthernet1 unassigned YES unset down down
GigabitEthernet2 unassigned YES unset down down
GigabitEthernet3 unassigned YES unset down down
GigabitEthernet4 unassigned YES unset down down
GigabitEthernet5 unassigned YES unset down down
GigabitEthernet6 unassigned YES unset down down
GigabitEthernet7 unassigned YES unset down down
GigabitEthernet8 108.51.198.232 YES DHCP up up
NVI0 108.51.198.232 YES unset up up
Vlan1 unassigned YES unset administratively down down
Vlan10 192.168.1.1 YES manual up up
#sh ip arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 108.51.198.1 0 3e61.040b.5ded ARPA GigabitEthernet8
Internet 108.51.198.232 - 1c6a.7ac6.9d91 ARPA GigabitEthernet8
Internet 192.168.1.1 - 1c6a.7ac6.9d7e ARPA Vlan10
once removing the dhcp command from Gig8 the WAN IP goes away. The Dialer1 int does not get any WAN IP:
#sh ip int brief
Interface IP-Address OK? Method Status Protocol
Async3 unassigned YES unset down down
BRI0 unassigned YES unset administratively down down
BRI0:1 unassigned YES unset administratively down down
BRI0:2 unassigned YES unset administratively down down
Dialer1 unassigned YES DHCP up up
FastEthernet0 unassigned YES unset administratively down down
GigabitEthernet0 unassigned YES unset up up
GigabitEthernet1 unassigned YES unset down down
GigabitEthernet2 unassigned YES unset down down
GigabitEthernet3 unassigned YES unset down down
GigabitEthernet4 unassigned YES unset down down
GigabitEthernet5 unassigned YES unset down down
GigabitEthernet6 unassigned YES unset down down
GigabitEthernet7 unassigned YES unset down down
GigabitEthernet8 unassigned YES unset up up
NVI0 unassigned NO unset up up
Vlan1 unassigned YES unset administratively down down
Vlan10 192.168.1.1 YES manual up up
debug still shows encapsulation failed:
Mar 16 09:53:09 EDT: IP: s=192.168.1.98 (Vlan10), d=8.8.8.8, len 66, input feature, Common Flow Table(5), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 09:53:09 EDT: IP: s=192.168.1.98 (Vlan10), d=8.8.8.8, len 66, input feature, Stateful Inspection(7), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 09:53:09 EDT: IP: s=192.168.1.98 (Vlan10), d=8.8.8.8, len 66, input feature, Virtual Fragment Reassembly(36), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 09:53:09 EDT: IP: s=192.168.1.98 (Vlan10), d=8.8.8.8, len 66, input feature, Virtual Fragment Reassembly After IPSec Decryption(52), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 09:53:09 EDT: IP: s=192.168.1.98 (Vlan10), d=8.8.8.8, len 66, input feature, MCI Check(94), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 09:53:09 EDT: IP: s=192.168.1.98 (Vlan10), d=8.8.8.8, len 66, input feature, TCP Adjust MSS(96), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 09:53:09 EDT: IP: s=192.168.1.1 (local), d=192.168.1.98, len 56, local feature, NAT(2), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 09:53:09 EDT: IP: s=192.168.1.1 (local), d=192.168.1.98 (Vlan10), len 56, sending
Mar 16 09:53:09 EDT: IP: s=192.168.1.1 (local), d=192.168.1.98 (Vlan10), len 56, output feature, NAT Inside(8), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 09:53:09 EDT: IP: s=192.168.1.1 (local), d=192.168.1.98 (Vlan10), len 56, output feature, Common Flow Table(27), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 09:53:09 EDT: IP: s=192.168.1.1 (local), d=192.168.1.98 (Vlan10), len 56, output feature, Stateful Inspection(28), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 09:53:09 EDT: IP: s=192.168.1.1 (local), d=192.168.1.98 (Vlan10), len 56, output feature
Mar 16 09:53:09 EDT: IP: s=192.168.1.55 (Vlan10), d=192.168.1.1, len 67, stop process pak for forus packet
Mar 16 09:53:09 EDT: IP: s=192.168.1.55 (Vlan10), d=192.168.1.1, len 67, enqueue feature, TCP Adjust MSS(5), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 09:53:09 EDT: IP: s=192.168.1.96 (Vlan10), d=66.172.17.41, len 76, input feature, Common Flow Table(5), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 09:53:09 EDT: IP: s=192.168.1.96 (Vlan10), d=66.172.17.41, len 76, input feature, Stateful Inspection(7), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 09:53:09 EDT: IP: s=192.168.1.96 (Vlan10), d=66.172.17.41, Stateful Inspection(28), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 09:53:10 EDT: IP: s=192.168.1.55 (Vlan10), d=192.168.1.1 (Vlan10), len 67, rcvd 3
Mar 16 09:53:10 EDT: IP: s=192.168.1.55 (Vlan10), d=192.168.1.1, len 67, stop process pak for forus packet
Mar 16 09:53:10 EDT: IP: s=192.168.1.55 (Vlan10), d=192.168.1.1, len 67, enqueue feature, TCP Adjust MSS(5), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 09:53:11 EDT: IP: s=192.168.1.152 (Vlan10), d=162.247.242.19, len 52, input feature, Common Flow Table(5), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE (Dialer1), len 316, encapsulation failed
03-15-2020 07:45 AM
Hello,
on the dialer interface, configure:
ip address negotiated
The entire config should look like this (important parts marked in bold):
ip dhcp excluded-address 192.168.1.1 192.168.1.5
!
ip dhcp pool InsideDHCP
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8 8.8.4.4
! class any
vpdn enable
!
vpdn-group 1
!
vpdn-group pppoe
!
interface FastEthernet0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0
switchport access vlan 10
no ip address
!
interface GigabitEthernet1
no ip address
!
interface GigabitEthernet2
no ip address
!
interface GigabitEthernet3
no ip address
!
interface GigabitEthernet4
no ip address
!
interface GigabitEthernet5
no ip address
!
interface GigabitEthernet6
no ip address
!
interface GigabitEthernet7
no ip address
!
interface GigabitEthernet8
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1452
!
interface Async3
no ip address
encapsulation slip
!
interface Dialer1
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1452
ip flow ingress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname guest
ppp chap password 7 040A0D0F1DF05155C
ppp pap sent-username guest password 7 0055150FC07032D15
no cdp enable
!
ip nat inside source list 10 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 10 permit 192.168.1.0 0.0.0.255
!
dialer-list 1 protocol ip permit
03-15-2020 11:21 AM
all bold items and non-bold items match exactly just no ip address is received/given to the Dialer1 interface.
debug ip packet log still shows encapsulation failed.
Mar 16 13:42:48 EDT: IP: s=192.168.1.59 (Vlan10), d=216.234.64.130, len 496, input feature, Common Flow Table(5), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 13:42:48 EDT: IP: s=192.168.1.59 (Vlan10), d=216.234.64.130, len 496, input feature, Stateful Inspection(7), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 13:42:48 EDT: IP: s=192.168.1.59 (Vlan10), d=216.234.64.130, len 496, input feature, Virtual Fragment Reassembly(36), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 13:42:48 EDT: IP: s=192.168.1.59 (Vlan10), d=216.234.64.130, len 496, input feature, Post-Ingress-NetFlow(74), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 13:42:48 EDT: IP: s=192.168.1.59 (Vlan10), d=216.234.64.130 (Dialer1), len 496, output feature, Dialer idle reset(93), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 13:42:48 EDT: IP: s=192.168.1.59 (Vlan10), d=216.234.64.130 (Dialer1), g=216.234.64.130, len 496, forward
Mar 16 13:42:48 EDT: IP: s=192.168.1.59 (Vlan10), d=216.234.64.130 (Dialer1), len 496, encapsulation failed
Mar 16 13:42:48 EDT: IP: s=192.168.1.152 (Vlan10), d=192.168.1.1, len 61, input feature, Common Flow Table(5), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 13:42:49 EDT: IP: s=192.168.1.152 (Vlan10), d=192.168.1.255 (Vlan10), len 78, rcvd 3
Mar 16 13:42:49 EDT: IP: s=192.168.1.152 (Vlan10), d=192.168.1.255, len 78, stop process pak for forus packet
Mar 16 13:42:49 EDT: IP: s=192.168.1.152 (Vlan10), d=192.168.1.255, len 78, enqueue feature, TCP Adjust MSS(5), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 13:42:49 EDT: IP: tableid=0, s=192.168.1.152 (Vlan10), d=192.168.1.255 (Vlan10), routed via RIB
Mar 16 13:42:50 EDT: IP: s=192.168.1.59 (Vlan10), d=216.234.64.130, len 496, input feature, Common Flow Table(5), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 13:42:50 EDT: IP: s=192.168.1.59 (Vlan10), d=216.234.64.130, len 496, input feature, Stateful Inspection(7), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 13:42:50 EDT: IP: s=192.168.1.59 (Vlan10), d=216.234.64.130, len 496, input feature, Virtual Fragment Reassembly(36), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 13:42:50 EDT: IP: s=192.168.1.59 (Vlan10), d=216.234.64.130, len 496, input feature, Virtual Fragment Reassembly After IPSec Decryption(52), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 13:42:50 EDT: IP: s=192.168.1.59 (Vlan10), d=216.234.64.130, len 496, input feature
Mar 16 13:42:50 EDT: IP: s=192.168.1.98 (Vlan10), d=8.8.8.8 (Dialer1), g=8.8.8.8, len 66, forward
Mar 16 13:42:50 EDT: IP: s=192.168.1.98 (Vlan10), d=8.8.8.8 (Dialer1), len 66, encapsulation failed
Mar 16 13:42:52 EDT: IP: s=192.168.1.59 (Vlan10), d=216.234.64.130, len 496, input feature, Common Flow Table(5), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 13:42:52 EDT: IP: s=192.168.1.59 (Vlan10), d=216.234.64.130, len 496, input feature, Stateful Inspection(7), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 13:42:52 EDT: IP: s=192.168.1.59 (Vlan10), d=216.234.64.130, len 496, input feature, Virtual Fragment Reassembly(36), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 13:42:52 EDT: IP: s=192.168.1.59 (Vlan10), d=216.234.64.130, len 496, input feature, Post-Ingress-NetFlow(74), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 13:42:52 EDT: IP: s=192.168.1.59 (Vlan10), d=216.234.64.130 (Dialer1), len 496, output feature, Dialer idle reset(93), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
Mar 16 13:42:52 EDT: IP: s=192.168.1.59 (Vlan10), d=216.234.64.130 (Dialer1), g=216.234.64.130, len 496, forward
Mar 16 13:42:52 EDT: IP: s=192.168.1.59 (Vlan10), d=216.234.64.130 (Dialer1), len 496, encapsulation failed
maybe this configuration is not supported by service-provider, Verizon for FiOS service?
03-15-2020 12:48 PM
Hello,
save the configuration (wr mem), then reboot the router. Also, post the running configuration just to check if everything is correct...
03-15-2020 01:07 PM
Hello,
try to make the changes marked in bold:
ip dhcp excluded-address 192.168.1.1 192.168.1.5
!
ip dhcp pool InsideDHCP
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8 8.8.4.4
! class any
vpdn enable
!
vpdn-group 1
!
vpdn-group pppoe
!
interface FastEthernet0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0
switchport access vlan 10
no ip address
!
interface GigabitEthernet1
no ip address
!
interface GigabitEthernet2
no ip address
!
interface GigabitEthernet3
no ip address
!
interface GigabitEthernet4
no ip address
!
interface GigabitEthernet5
no ip address
!
interface GigabitEthernet6
no ip address
!
interface GigabitEthernet7
no ip address
!
interface GigabitEthernet8
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
--> no ip tcp adjust-mss 1452
!
interface Async3
no ip address
encapsulation slip
!
interface Dialer1
ip address negotiated
--> ip mtu 1460
no ip redirects
no ip unreachables
no ip proxy-arp
--> ip tcp adjust-mss 1420
ip flow ingress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname guest
ppp chap password 7 040A0D0F1DF05155C
ppp pap sent-username guest password 7 0055150FC07032D15
no cdp enable
!
ip nat inside source list 10 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 10 permit 192.168.1.0 0.0.0.255
03-15-2020 01:49 PM
made changes and reloaded but still no ip on the Dialer1 interface. debug still shows encapsulation failed on Dialer1 int.
below is config:
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface FastEthernet0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0
switchport access vlan 10
no ip address
!
interface GigabitEthernet1
no ip address
!
interface GigabitEthernet2
no ip address
!
interface GigabitEthernet3
no ip address
!
interface GigabitEthernet4
no ip address
!
interface GigabitEthernet5
no ip address
!
interface GigabitEthernet6
no ip address
!
interface GigabitEthernet7
no ip address
!
interface GigabitEthernet8
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1452
!
interface Async3
no ip address
encapsulation slip
!
interface Dialer1
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1460
ip flow ingress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1420
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname guest
ppp chap password 7 040A0D0F1DF05155C
ppp pap sent-username guest password 7 0055150FC07032D15
no cdp enable
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 10 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
dialer-list 1 protocol ip permit
!
access-list 10 permit 192.168.1.0 0.0.0.255
!
03-15-2020 02:49 PM
Hello,
try the simplified config below (important parts marked in bold):
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface FastEthernet0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0
switchport access vlan 10
no ip address
!
interface GigabitEthernet1
no ip address
!
interface GigabitEthernet2
no ip address
!
interface GigabitEthernet3
no ip address
!
interface GigabitEthernet4
no ip address
!
interface GigabitEthernet5
no ip address
!
interface GigabitEthernet6
no ip address
!
interface GigabitEthernet7
no ip address
!
interface GigabitEthernet8
ip address dhcp
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Async3
no ip address
encapsulation slip
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat inside source list 10 interface GigabitEthernet8 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet8 dhcp
!
access-list 10 permit 192.168.1.0 0.0.0.255
!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide