01-15-2017 11:14 AM - edited 03-05-2019 07:51 AM
Hi Experts,
I have this GNS3 lab prepared and have virtual link between R5(area0) and R7(area 2) passing through area 1(R6). Everything seems to be right but I cannot figure out why the VL cost is 65535. No 'auto-cost reference-bandwidth' command is configured. Please see below for the needed config.
R5#sh ip ospf int bri
Interface PID Area IP Address/Mask Cost State Nbrs F/C
VL0 1 0 0.0.0.0/0 65535 DOWN 0/0
Fa0/1 1 0 5.5.5.5/24 1 DR 3/3
Fa0/0 1 1 56.56.56.5/24 1 BDR 1/1
R5#
R6#sh ip ospf int bri
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Fa0/0 1 1 56.56.56.6/24 1 DR 1/1
Fa0/1 1 2 67.67.67.6/24 1 BDR 1/1
R6#
R6#
R7#
R7#sh ip ospf int bri
Interface PID Area IP Address/Mask Cost State Nbrs F/C
VL0 1 0 0.0.0.0/0 65535 DOWN 0/0
Fa0/1 1 2 67.67.67.7/24 1 DR 1/1
R7#
R7#
R5
===
interface FastEthernet0/0
ip address 56.56.56.5 255.255.255.0
ip ospf 1 area 1
speed auto
duplex auto
!
interface FastEthernet0/1
ip address 5.5.5.5 255.255.255.0
ip ospf 1 area 0
speed auto
duplex auto
!
router ospf 1
router-id 5.5.5.5
area 1 virtual-link 7.7.7.7
redistribute connected
!
R6
===
interface FastEthernet0/0
ip address 56.56.56.6 255.255.255.0
ip ospf 1 area 1
speed auto
duplex auto
!
interface FastEthernet0/1
ip address 67.67.67.6 255.255.255.0
ip ospf 1 area 2
speed auto
duplex auto
!
router ospf 1
router-id 6.6.6.6
redistribute connected
!
R7
===
interface FastEthernet0/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet0/1
ip address 67.67.67.7 255.255.255.0
ip ospf 1 area 2
speed auto
duplex auto
!
router ospf 1
router-id 7.7.7.7
area 1 virtual-link 5.5.5.5
redistribute connected
!
Solved! Go to Solution.
01-15-2017 03:19 PM
cost is 65535 because VL is down not the other way around.
You made a mistake in your configuration, this should be a fix:
R5
router ospf 1
no area 1 virtual-link 7.7.7.7
area 1 virtual-link 6.6.6.6
R6
router ospf 1
area 1 virtual-link 5.5.5.5
R7
router ospf 1
no area 1 virtual-link 5.5.5.5
- R7 has no connection to area 1, it;s internal router to area 2
- VL needs to be established between ABR routers:
-- R5 is ABR between area 0 and area 1
-- R6 is ABR between area 1 and area 2
- you need to establish VL between R5 an R6 to connect area 2 to area 0
01-15-2017 11:28 AM
Hello,
your VL is down, that is why the cost is LSInfinity (65535). Once your VL is up, the cost will probably change to something like 20.
01-15-2017 11:56 AM
gpauwen, I got that. My question is, why the cost is so high causing the link to go down?
01-15-2017 12:18 PM
Hello,
one question:
Is this interface on R5:
interface FastEthernet0/1
ip address 5.5.5.5 255.255.255.0
ip ospf 1 area 0
speed auto
duplex auto
actually up ? It looks like you are trying to create a loopback ?
01-15-2017 03:19 PM
cost is 65535 because VL is down not the other way around.
You made a mistake in your configuration, this should be a fix:
R5
router ospf 1
no area 1 virtual-link 7.7.7.7
area 1 virtual-link 6.6.6.6
R6
router ospf 1
area 1 virtual-link 5.5.5.5
R7
router ospf 1
no area 1 virtual-link 5.5.5.5
- R7 has no connection to area 1, it;s internal router to area 2
- VL needs to be established between ABR routers:
-- R5 is ABR between area 0 and area 1
-- R6 is ABR between area 1 and area 2
- you need to establish VL between R5 an R6 to connect area 2 to area 0
01-15-2017 07:51 PM
Ah!!! Thats what it is. I knew the virtual link command should be between the border router and thought I was configuring it that way. But I was thinking of connectivity between R5 and R7 and hence the confusion.
I feel so stupid :0
Thanks blau Grana!!!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide