10-21-2011 02:22 AM - edited 03-04-2019 02:00 PM
Good day colleagues.
I'm having issue with subinterfaces. I've connected two routers and created subinterfaces on both ends. I configured both sides but can't ping neighbor router. More than that I can't ping local address on subinterface.
Pleace check my config and tell me what I did wrong.
Thanks in advanced.
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
interface Serial0/0
no ip address
serial restart-delay 0
!
interface Serial0/0.10
ip address 192.168.1.1 255.255.255.0
!
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
end
*****
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
interface Serial0/0
no ip address
serial restart-delay 0
clock rate 128000
!
interface Serial0/0.10
ip address 192.168.1.2 255.255.255.0
!
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
end
****
There is also show ip interface brief comand output
R1#sh ip int brief
Interface IP-Address OK? Method Status Protocol
Serial0/0 unassigned YES unset up up
Serial0/0.10 192.168.1.1 YES manual up up
R1#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
****
R2#sh ip int brief
Interface IP-Address OK? Method Status Protocol
Serial0/0 unassigned YES unset up up
Serial0/0.10 192.168.1.2 YES manual up up
R2#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Solved! Go to Solution.
10-21-2011 02:58 AM
Hi,
I don't think it will work as subinterfaces on serial interfaces are done for frame-relay encapsulation.
PPP won't let you do that and hdlc does let you configure the subinterface but it can't work imho.
Regards.
Alain.
10-21-2011 03:27 AM
Hi,
it will only work with Frame-relay on serial interfaces as it seems that this feature is not supported for HDLC or PPP.
Alain.
10-21-2011 02:43 AM
May we get router series detail along with inventory.
Regards
Mahesh
10-21-2011 02:47 AM
R1#sh version
Cisco IOS Software, 3600 Software (C3640-JK9S-M), Version 12.4(16), RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Wed 20-Jun-07 11:43 by prod_rel_team
ROM: ROMMON Emulation Microcode
ROM: 3600 Software (C3640-JK9S-M), Version 12.4(16), RELEASE SOFTWARE (fc1)
R1 uptime is 36 minutes
System returned to ROM by unknown reload cause - suspect boot_data[BOOT_COUNT] 0x0, BOOT_COUNT 0, BOOTDATA 19
System image file is "tftp://255.255.255.255/unknown"
Cisco 3640 (R4700) processor (revision 0xFF) with 124928K/6144K bytes of memory.
Processor board ID FF1045C5
R4700 CPU at 100MHz, Implementation 33, Rev 1.2
4 Serial interfaces
DRAM configuration is 64 bits wide with parity enabled.
125K bytes of NVRAM.
8192K bytes of processor board System flash (Read/Write)
Configuration register is 0x2102
*****
NAME: "3640 chassis", DESCR: "3640 chassis"
PID: , VID: 0xFF, SN: FF1045C5
NAME: "3640 Chassis Slot 0", DESCR: "3640 Chassis Slot"
PID: , VID: , SN:
NAME: "Four Port High-Speed Serial", DESCR: "Four Port High-Speed Serial"
PID: NM-4T= , VID: 1.1, SN: 10300772
NAME: "Serial0/0", DESCR: "M4T"
PID: , VID: , SN:
NAME: "Serial0/1", DESCR: "M4T"
PID: , VID: , SN:
NAME: "Serial0/2", DESCR: "M4T"
PID: , VID: , SN:
NAME: "Serial0/3", DESCR: "M4T"
PID: , VID: , SN:
NAME: "3640 Chassis Slot 1", DESCR: "3640 Chassis Slot"
PID: , VID: , SN:
NAME: "3640 Chassis Slot 2", DESCR: "3640 Chassis Slot"
PID: , VID: , SN:
NAME: "3640 Chassis Slot 3", DESCR: "3640 Chassis Slot"
PID: , VID: , SN:
10-21-2011 02:58 AM
Hi,
I don't think it will work as subinterfaces on serial interfaces are done for frame-relay encapsulation.
PPP won't let you do that and hdlc does let you configure the subinterface but it can't work imho.
Regards.
Alain.
10-21-2011 03:02 AM
if I will choose other than serial interface type (FastEthernet for example) I also cnat create sub interfaces without configuring encapsulation dot.1q and creating vlans. Maybe you will give me an advice how can I configure and make works few VRF via 1 physical link?
Sincerely,
GRinch
10-21-2011 03:14 AM
You can create SVI interfaces, put single VRF on each SVI and pass those VLANs through a physical link making it trunk.
Nik
10-21-2011 03:39 AM
In this case I will not face any problem. I was wondering if ti's possible to make it works through serial links. Thanks.
10-21-2011 03:17 AM
Hi Can you try below FR config.
interface Se/0/0
no ip address
no ip redirects
no ip proxy-arp
encapsulation frame-relay
interface Se0/0.101 point-to-point
ip vrf forwarding test1
ip address 10.10.10.1 255.255.255.252
frame-relay interface-dlci 101
interface Se0/0.102 point-to-point
ip vrf forwarding test2
ip address 10.10.10.5 255.255.255.252
frame-relay interface-dlci 102
Same way at other end.
Regards
Mahesh
10-21-2011 03:20 AM
I know there is no problem with FR, but I would like to use IP. Thanks for advice.
Sincerely,
GRinch
10-21-2011 03:27 AM
Hi,
it will only work with Frame-relay on serial interfaces as it seems that this feature is not supported for HDLC or PPP.
Alain.
10-21-2011 03:46 AM
Thank you guys for your help and so fast reaction. Discussion is done =)
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide