cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3199
Views
9
Helpful
4
Replies
Highlighted
Beginner

Can't ping with BGP in GNS3 lab environment

Here is a section of my BGP lab inside GNS3:

gns3bgp.jpg

My issue is not being able to ping anything on R5 from R2 even though R2 is recieving the routes from R5 and has placed them in it's routing table.

Thanks in advance for any help or advice!

-Steve

**********************************

R2#sho ip bgp

BGP table version is 5, local router ID is 10.1.96.2

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

* i150.1.50.0/24    10.1.36.2                0    700      0 777 711 911 ?

*>                  10.1.24.2                              0 777 911 ?

* i150.2.50.0/24    10.1.36.2                0    700      0 777 711 911 ?

*>                  10.1.24.2                              0 777 911 ?

* i200.50.2.0       10.1.36.2                0    700      0 777 711 i

*>                  10.1.24.2                              0 777 911 711 i

* i200.60.2.0       10.1.36.2                0    700      0 777 711 i

*>                  10.1.24.2                              0 777 911 711 i

R2#sho ip route

Gateway of last resort is not set

B    200.50.2.0/24 [20/0] via 10.1.24.2, 00:23:17

B    200.60.2.0/24 [20/0] via 10.1.24.2, 00:23:17

     10.0.0.0/24 is subnetted, 3 subnets

C       10.1.12.0 is directly connected, Serial0/0

C       10.1.24.0 is directly connected, Serial0/2

C       10.1.96.0 is directly connected, Serial0/1

     150.1.0.0/24 is subnetted, 1 subnets

B       150.1.50.0 [20/0] via 10.1.24.2, 00:23:17

     150.2.0.0/24 is subnetted, 1 subnets

B       150.2.50.0 [20/0] via 10.1.24.2, 00:23:17

R2#ping 150.1.50.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 150.1.50.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

R2#trace 150.1.50.1

Type escape sequence to abort.

Tracing the route to 150.1.50.1

  1 10.1.24.2 52 msec 44 msec 24 msec

  2  *  *  *

        ^ so the ping make it to the next AS but stops there

R2#sho run

Building configuration...

Current configuration : 1183 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R2

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

ip cef

!

!

!

!

no ip domain lookup

ip domain name lab.local

!        

!

!

interface Serial0/0

ip address 10.1.12.2 255.255.255.0

clock rate 64000

!

interface Serial0/1

ip address 10.1.96.2 255.255.255.0

clock rate 64000

!

interface Serial0/2

ip address 10.1.24.1 255.255.255.0

clock rate 64000

!        

router bgp 5500

no synchronization

bgp log-neighbor-changes

neighbor 10.1.12.1 remote-as 5500

neighbor 10.1.12.1 next-hop-self

neighbor 10.1.24.2 remote-as 777

neighbor 10.1.96.1 remote-as 5500

no auto-summary

!

!

!

no ip http server

no ip http secure-server

!

!

!

!

!

control-plane

!

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

exec-timeout 0 0

privilege level 15

logging synchronous

line vty 0 4

login

!

!

end

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Re: Can't ping with BGP in GNS3 lab environment

Hi

You will need to enable some sort of internal routing protocol on your routers if they were in the same AS or configure static routing between them in case they were in different Autonomous Systems.

You can refer to the following links for more information about the BGP configuration

http://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a008009456d.shtml#directlyconnected

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800c95bb.shtml

Hope it will help

Ahmed Sonba

View solution in original post

4 REPLIES 4
Beginner

Re: Can't ping with BGP in GNS3 lab environment

Hi

You will need to enable some sort of internal routing protocol on your routers if they were in the same AS or configure static routing between them in case they were in different Autonomous Systems.

You can refer to the following links for more information about the BGP configuration

http://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a008009456d.shtml#directlyconnected

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800c95bb.shtml

Hope it will help

Ahmed Sonba

View solution in original post

Beginner

Can't ping with BGP in GNS3 lab environment

Thank you very much for your response, I was able to get the lab to work by adding:

R2

ip route 10.1.99.1 255.255.255.255 10.1.24.2 2

R5

ip route 10.1.24.1 255.255.255.255 10.1.99.2 2

So now my question is, why? R2 knows the way to get to R5 is by going to R4, so when R4 gets the ping why does it not forward it to where it needs to go? Furthermore R2 has marked the route with a ">" which says "this is a valid route".

In real world BGP environments, is it not a common thing for a router to be connected to autonomous systems that are not directly connected?

Thanks again, I may just be a little trown off after my brain has only thought RIP, OSPF, and EIGRP for my entire Cisco carrer.

-Steve

Advisor

Can't ping with BGP in GNS3 lab environment

Hi,

does R5 has a route for the 10.1.24.0  network ?

either put a network command or redistribute this subnet into BGP in AS 5500(R2) or  use a static route pointing to ISP router for this network

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Beginner

I ran into the same issue on

I ran into the same issue on GNS3

 

I think the actual reason your pings will not work is due to the source of the icmp packet.

By default the packet will send from the ip on the physical interface going out to the ISP (whereas the remote router you ping only knows the bgp advertised subnet, not the subnet of the WAN link)

So you can add a static route to the respective subnets if you want, but a more secure option would be to specify the source of of the ping as the interface the remote router knows via BGP.

This is what I did with no extra static routes added.

 

I realise this post is v old by now, just adding this for anyone who stumbles across it in future.

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards