cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
763
Views
10
Helpful
3
Replies

Cannot ping between non-adjacent routers, ICMP Host Unreachable

Vicyorus
Level 1
Level 1

Salutations!

I am currently having an issue setting up a statically-routed network for an assignment. While the network I am showcasing here is not the network we are working on, it showcases the issue I'm currently having. Included with the post comes the Packet Tracer file I'm using.

 

An image of the topology:

Screenshot_7.png

The issue I'm having is that I cannot do any pings or traceroute between Router0 (left side router) and Router2 (right side router), however, if I use the laptops in the respective networks, I can do pings and tracert without any issue.

 

Digging further with the simulator, the ICMP packages (for ping) are being sent correctly out of either Router0 to Router2, or Router2 to Router0, however, when it is time for the package to return, once it reaches the router, it fails with an ICMP Host Unreachable message.

 

Just to note down, Router1 can ping without any issues.

 

Configuration for the routers:

Router0:

!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 1.0.0.1 255.0.0.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 10.0.0.1 255.255.255.252
 clock rate 2000000
!
interface Serial0/0/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 2.0.0.0 255.0.0.0 10.0.0.2 
ip route 3.0.0.0 255.0.0.0 10.0.0.2 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Router1:

!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 2.0.0.1 255.0.0.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 10.0.0.2 255.255.255.252
!
interface Serial0/0/1
 ip address 10.0.0.5 255.255.255.252
 clock rate 2000000
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 1.0.0.0 255.0.0.0 10.0.0.1 
ip route 3.0.0.0 255.0.0.0 10.0.0.6 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Router2:

!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 3.0.0.1 255.0.0.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/0/1
 ip address 10.0.0.6 255.255.255.252
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 1.0.0.0 255.0.0.0 10.0.0.5 
ip route 2.0.0.0 255.0.0.0 10.0.0.5 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

Any help and tips are appreciated.

1 Accepted Solution

Accepted Solutions

You just need to add the static route for the non directly connected subnet in R0 and R2.

 

R0:

ip route 10.0.0.4 255.255.255.252 10.0.0.2

 

R2:

ip route 10.0.0.0 255.255.255.252 10.0.0.5

 

Regards

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

View solution in original post

3 Replies 3

Harold Ritter
Cisco Employee
Cisco Employee

The issue is that you do not have static route for the links between R0 and R1 and R1 and R2. By default, the ping will use the egress interface towards the destination as the source address of the ping packet. Try specifying the source interface when you ping from R0 to R2 or vice versa.

 

From R0:

ping 3.0.0.1 source 1.0.0.1

From R2:

ping 1.0.0.1 source 3.0.0.1

 

Regards,

 

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Odd, the Packet Tracer version I have (7.1.1.0138, the Student version) doesn't seem to support the source parameter for ping.

 

In any case, you mention that I do not have static routes for the links between R0/R1 and R1/R2, how would I go into fixing this?

 

Thanks for the help.

You just need to add the static route for the non directly connected subnet in R0 and R2.

 

R0:

ip route 10.0.0.4 255.255.255.252 10.0.0.2

 

R2:

ip route 10.0.0.0 255.255.255.252 10.0.0.5

 

Regards

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card