cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
303
Views
10
Helpful
4
Replies

CBWFQ over FR

ikizoo4
Level 1
Level 1

Hello,

I'd like to configure CBWFQ over FR as below, one subinterface is for TCP user and another is for voice user.

Does subinterfaces inherently support CBWFQ?

class-map match-all TCP

match access-group 103

class-map match-all VOICE

match access-group 102

!

policy-map CBWFQ

class VOICE

bandwidth percent 45

class TCP

bandwidth percent 30

class class-default

fair-queue

!

interface Serial0/0

no ip address

encapsulation frame-relay

service-policy out CBWFQ

!

interface Serial0/0.1 point-to-point

ip address 192.168.10.1 255.255.255.0

frame-relay interface-dlci 400

!

interface Serial0/0.2 point-to-point

ip address 192.168.11.1 255.255.255.0

frame-relay interface-dlci 500

Thanks

4 Replies 4

Hello,

no, the policy is not inherited on the subinterfaces. For your configuration to work, you need to apply the following:

class-map match-all TCP

match access-group 103

class-map match-all VOICE

match access-group 102

!

policy-map CBWFQ

class VOICE

bandwidth percent 45

class TCP

bandwidth percent 30

class class-default

fair-queue

!

interface Serial0/0

no ip address

encapsulation frame-relay

--> frame-relay traffic-shaping

!

interface Serial0/0.1 point-to-point

ip address 192.168.10.1 255.255.255.0

frame-relay interface-dlci 400

--> class DLCI_400

!

interface Serial0/0.2 point-to-point

ip address 192.168.11.1 255.255.255.0

frame-relay interface-dlci 500

--> class DLCI_500

--> map-class frame-relay DLCI_400

service-policy output CBWFQ

--> map-class frame-relay DLCI_500

service-policy output CBWFQ

Watch out though, once you have enabled Frame Relay Traffic Shaping on your main interface, all the DLCI configured on the subinterfaces will default to 56000kbps. If, and that is likely, that is not what your DLCIs actually have available as bandwidth, configure the cir and bc/be values in the frame relay classes as well...

Let me know if you have problems with this.

Regards,

GP

http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a0080110bc6.html

Check this link out. It replaces the legacy FRTS with MQC based commands. So ur restriction of 56K per PVC is removed in this.

HTH

Regds

Hi GP/THT

thanks for answering, I knew CBWFQ for every logical interface is shape function need first,,,

what i am asking is somehow i should apply CBWFQ on main interface with ip addess based classes, and some cisco document saying that it works like single pipe, because subinterface is just logical interface.

configuration is more like this

class-map match-all TCP

match access-group 103

class-map match-all VOICE

match access-group 102

!

policy-map CBWFQ

class VOICE

bandwidth percent 45

class TCP

bandwidth percent 30

class class-default

fair-queue

!

interface Serial0/0

no ip address

encapsulation frame-relay

service-policy out CBWFQ

!

interface Serial0/0.1 point-to-point

ip address 192.168.10.1 255.255.255.0

frame-relay interface-dlci 400

!

interface Serial0/0.2 point-to-point

ip address 192.168.11.1 255.255.255.0

frame-relay interface-dlci 500

access-list 102 permit ip any 192.168.11.1 0.0.0.255

access-list 103 permit ip any 192.168.10.1 0.0.0.255

Had anybody been through before?

Thanks

Iam not sure this will work. But i was going through some document on using PVC bundles and mapping to IP QoS etc. It didnt make much of sense to me. Hope it helps you.

http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a0080153e16.html

Regds

p.s:- Let me know if it is path-breaking. Iam exploring this too.

Review Cisco Networking for a $25 gift card