cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
788
Views
0
Helpful
5
Replies

Changing configuration

dneb
Level 1
Level 1

Hello, There is a Cisco router configured by another IT guy with specified addresses from ISP, now the problem is that the ISP give us new net mask and default gateway addresses, so what i did was changing the following addresses

old ISP address -

ip address: 10.131.61.246

net mask: 255.255.255.252

Default : 10.131.61.245

 

new ISP address - 

ip address: 10.131.61.246

net mask: 255.255.240.0

Default : 10.131.48.1

 

Old Configuration on router

---------------------------------------------------------------------------------

flow monitor MellaFMon

 record netflow ipv4 original-input

 exporter MellaFEX

 cache timeout active 5

!

ip source-route

ip cef

!

!

!

ip dhcp excluded-address 192.168.1.2 192.168.1.50

ip dhcp excluded-address 192.168.1.0 192.168.1.50

ip dhcp excluded-address 192.168.1.1 192.168.1.50

!

ip dhcp pool 101

 network 192.168.1.0 255.255.255.0

 default-router 192.168.1.1

 dns-server 192.168.1.4 8.8.8.8 4.2.2.2

!

ip dhcp pool WiFi

 network 192.168.10.0 255.255.255.0

 default-router 192.168.10.1

 dns-server 8.8.8.8 4.2.2.2

!

ip dhcp pool LAN

 network 192.168.40.0 255.255.255.0

 default-router 192.168.40.1

 dns-server 192.168.1.4 8.8.8.8 4.2.2.2

!

ip dhcp pool CC-Cam

 network 192.168.30.0 255.255.255.0

 default-router 192.168.30.1

 dns-server 8.8.8.8

!

!

!

interface Embedded-Service-Engine0/0

 no ip address

 shutdown

!

interface GigabitEthernet0/0

 no ip address

 ip flow ingress

 ip flow egress

 duplex auto

 speed auto

!

interface GigabitEthernet0/0.10

 description Wifi-Vlan-Int

 encapsulation dot1Q 10

 ip address 192.168.10.1 255.255.255.0

 ip flow monitor MellaFMon input

 ip flow monitor MellaFMon output

 ip nat inside

 ip virtual-reassembly in

!

interface GigabitEthernet0/0.20

 description Server-VLAN-In

 encapsulation dot1Q 1 native

 ip address 192.168.1.1 255.255.255.0

 ip flow monitor MellaFMon input

 ip flow monitor MellaFMon output

 ip nat inside

 ip virtual-reassembly in

!

interface GigabitEthernet0/0.30

 description CC-Camera-Int

 encapsulation dot1Q 30

 ip address 192.168.30.1 255.255.255.0

 ip flow monitor MellaFMon input

 ip flow monitor MellaFMon output

!

interface GigabitEthernet0/0.40

 description LAN-Int

 encapsulation dot1Q 40

 ip address 192.168.40.1 255.255.255.0

 ip flow monitor MellaFMon input

 ip flow monitor MellaFMon output

!

interface GigabitEthernet0/1

 ip address 197.156.90.82 255.255.255.248 secondary

 ip address 10.131.61.246 255.255.255.252

 ip flow monitor MellaFMon input

 ip flow monitor MellaFMon output

 ip flow ingress

 ip flow egress

 ip nat outside

 ip virtual-reassembly in

 duplex auto

 speed auto

!

ip forward-protocol nd

!

no ip http server

ip http authentication local

no ip http secure-server

!

ip nat pool Server 197.156.90.85 197.156.90.85 netmask 255.255.255.248

ip nat pool USER 197.156.90.83 197.156.90.83 netmask 255.255.255.248

ip nat pool server 197.156.90.85 197.156.90.85 netmask 255.255.255.248

ip nat pool CC-Cam 197.156.90.86 197.156.90.86 netmask 255.255.255.248

ip nat inside source list 10 pool USER overload

ip nat inside source static 192.168.1.4 197.156.90.84

ip nat inside source static 192.168.1.3 197.156.90.85

ip route 0.0.0.0 0.0.0.0 10.131.61.245

!

access-list 10 permit 192.168.10.0 0.0.0.255

access-list 10 permit 192.168.1.0 0.0.0.255

access-list 20 deny   192.168.1.1

access-list 20 deny   192.168.1.3

access-list 20 deny   192.168.1.4

access-list 20 permit 192.168.1.0 0.0.0.255

!

!

!

!

 

so what i have changed is :

 

on interface GigabitEthernet0/1

 

IP address 10.131.61.246 255.255.240.0

IP route 0.0.0.0 0.0.0.0 10.131.61.245

 

is there anything i have to change on the configuration ? Thanks!

1 Accepted Solution

Accepted Solutions

Seb Rupik
VIP Alumni
VIP Alumni

Hi there,

Remove the old primary address from Gi0/1 and also remove the old default route:

!
int gi0/1
 no ip address 10.131.61.246 255.255.255.252
 ip address 10.131.61.246 255.255.240.0
!
no ip route 0.0.0.0 0.0.0.0 10.131.61.245
ip route 0.0.0.0 0.0.0.0 10.131.48.1
!

...the rest of the config is OK to leave.

 

cheers,

Seb.

View solution in original post

5 Replies 5

Seb Rupik
VIP Alumni
VIP Alumni

Hi there,

Remove the old primary address from Gi0/1 and also remove the old default route:

!
int gi0/1
 no ip address 10.131.61.246 255.255.255.252
 ip address 10.131.61.246 255.255.240.0
!
no ip route 0.0.0.0 0.0.0.0 10.131.61.245
ip route 0.0.0.0 0.0.0.0 10.131.48.1
!

...the rest of the config is OK to leave.

 

cheers,

Seb.

Thanks for your reply sir, but the previous configuration is already deleted. let me show you current running config on gi0/1 : 

interface GigabitEthernet0/1
ip address 197.156.90.82 255.255.255.248 secondary
ip address 10.131.61.246 255.255.240.0
ip flow monitor MellaFMon input
ip flow monitor MellaFMon output
ip flow ingress
ip flow egress
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
ip forward-protocol nd
!
no ip http server
ip http authentication local
no ip http secure-server
!
ip nat pool Server 197.156.90.85 197.156.90.85 netmask 255.255.255.248
ip nat pool USER 197.156.90.83 197.156.90.83 netmask 255.255.255.248
ip nat pool server 197.156.90.85 197.156.90.85 netmask 255.255.255.248
ip nat pool CC-Cam 197.156.90.86 197.156.90.86 netmask 255.255.255.248
ip nat inside source list 10 pool USER overload
ip nat inside source static 192.168.1.4 197.156.90.84
ip nat inside source static 192.168.1.3 197.156.90.85
ip route 0.0.0.0 0.0.0.0 10.131.48.1
!
access-list 10 permit 192.168.10.0 0.0.0.255
access-list 10 permit 192.168.1.0 0.0.0.255
access-list 20 deny 192.168.1.1
access-list 20 deny 192.168.1.3
access-list 20 deny 192.168.1.4
access-list 20 permit 192.168.1.0 0.0.0.255
!
!
!
!

so whats not working since the change over ?
can you ping the internet ?
can you reach the default gateway ?

Assuming the topology of the network detailed in the 'secondary' configuration (197.156.90.80/29) has not changed the configuration should still work? 

Is the NAT configuration still in use? Was it supposed to be used as part of a migration?

 

cheers,

Seb.

Hello,

 

on a side note, the (presumably public) IP address space given to you looks odd/ 10.131.48.0/20 would give you 4094 hosts. Check if by any chance that should have been 10.131.48.0/28...?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card