cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
3347
Views
0
Helpful
6
Replies
Highlighted
Beginner

Checksum Error in Cisco 1841

Can somone please help, the router is always giving the below error:

Error : compressed image checksum is incorrect 0xDC5C5348

        Expected a checksum of 0x066C5349

I have uploaded a new firmware but same issue after booting, I have check the MD5 checksum in the image and Cisco and they are matching and verified, what could be the reason for all of this ??

Thanks in advance for the help.

6 REPLIES 6
Cisco Employee

Checksum Error in Cisco 1841

if  the image is good, check the flash.

Beginner

Checksum Error in Cisco 1841

I have checked the flash, I can access it from any card reader and format, copy...etc, and from the rommon If I issue the command "dir flash:" I can see the IOS file inside the flash, so I don't think it is from the flash card, any other ideas ??

Checksum Error in Cisco 1841

Hello

There are 3 chances

1. Software Image is currepected : Since it is verified ok, that option is ruled out

2. Flash disk curreption: You can format the flash ( do not reload)  and copy a fresh copy of the image and see whether the issue reappear

3. A software bug which shows this error.. ( what is the IOS Name you are using )

regards

Harish

Beginner

Checksum Error in Cisco 1841

I have formated the flash before and reloaded new firmware but still same result, if the flash is corrupted will I be able to see the directory and see the IOS on it ?

The software I'm using IOS i'm using is

c1841-ipbasek9-mz.124-24.T3.bin

I have tried with other IOSs and got the same checksum error, can it be the RAM is faulty or something like that ??

The full error is as below:

program load complete, entry point: 0x8000f000, size: 0x12e6ec8

Error : compressed image checksum is incorrect 0xF5F020B7

        Expected a checksum of 0x1F1020B8

*** System received a Software forced crash ***

signal= 0x17, code= 0x5, context= 0x80014340

PC = 0x8000f0d4, Cause = 0x20, Status Reg = 0x3041e803

System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

Thanks for the help

Checksum Error in Cisco 1841

Hello

Alright, as per cisco, if you face a software crash along with this error , it can be a memory issue as well ( link provided)

http://www.cisco.com/en/US/products/hw/routers/ps359/products_tech_note09186a008010260c.shtml

by the way , there is no matching bug in your IOS

regards

Harish

Please rate helpful posts!

Beginner

Checksum Error in Cisco 1841

Thanks A lot Harish for the help, It seems to be a hardware issue for sure, but which memory they are refering to ? the RAM or the Compact Flash ??

I will try to see if I can get another CF to test with

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards