- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
06-22-2016 04:31 PM - edited 03-05-2019 04:17 AM
Hello,
I am having issues with my 1841 that I recently bought. I am trying to configure my router to get on to my ISP, CenturyLink. I have tried configuring FE0/0 as the WAN port and FE0/1 as the LAN port, when I try to get on the Internet, it simply doesn't work and gives me the error "There is no Internet connection", note that this is in Google Chrome. I then tried to ping the backend of my ISP only to figure out that doesn't work either. I tried to ping my backend from the router itself and it worked. So I assumed that there wasn't a route to get to the backend. I then configured a default route to get there and ultimately it didn't work. I need help getting it configured.
Solved! Go to Solution.
- Labels:
-
Other Routing
Accepted Solutions
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
06-22-2016 11:39 PM
do:
no ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
no ip access-list extended NAT
access-list 1 permit 192.168.1.0 0.0.0.255
ip route 0.0.0.0 0.0.0.0 dhcp
ip nat inside source list 1 interface f0/0 overload
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
06-22-2016 05:16 PM
Hi
Let me do a recap just to be sure I understood your issue.
- You have your fe0/0 interface that's in DHCP, right?
- From your router, you have a default route, right?
- From your router, if you ping 8.8.8.8, you get answer, right ?
- From your PC, you don't have internet access, right?
For the default route on the router, in case the router itself don't have internet access:
ip route 0.0.0.0 0.0.0.0 f0/0
OR
ip route 0.0.0.0 0.0.0.0 dhcp ==> If your ISP is sending a default route from DHCP
Now, let's assume your internal LAN subnet is 192.168.0.0/24
you need to do batting, below a sample config (need to be adapted if your LAN subnet is different):
ip access-list extended NAT
deny ip 192.168.0.0 0.0.0.255 192.168.0.0 0.0.0.255
permit ip 192.168.0.0 0.0.0.255 any
!
interf f0/0
ip nat outside
interf f0/1
ip nat inside
!
ip nat inside source list NAT int f0/0 overload
Hope this is clear.
PS: Please don't forget to rate and mark as correct answer if this solved your issue.
Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
06-22-2016 06:56 PM
I have done that, still doesn't work. Anything else I can do? Btw, my internal address is 192.168.1.0 255.255.255.0.
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
06-22-2016 07:05 PM
and the subnet for my external address is 138.210.32.0 255.255.248.0
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
06-22-2016 08:12 PM
hi,
kindly post a show run output.
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
06-22-2016 08:18 PM
You have modified the subnet on the NAT acl?
In addition of sh run output, could you provide the sh ip route output?
Are you able to ping 8.8.8.8 through your router?
Thanks
PS: Please don't forget to rate and mark as correct answer if this solved your issue
Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
06-22-2016 08:20 PM
I am unable to ping 8.8.8.8 let alone the default gateway for my ISP. I will provide the sh IP route and sh run when I get home.
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
06-22-2016 08:52 PM
SVR-RT(config)#do sh run
Building configuration...
Current configuration : 1108 bytes
!
version 12.4
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SVR-RT
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$k872$R73zLckuOCrgOBnnqFk0k.
enable password mario240
!
no aaa new-model
no ip routing
no ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
no ip route-cache
speed auto
full-duplex
no mop enabled
!
interface FastEthernet0/1
no ip address
ip nat outside
ip virtual-reassembly
no ip route-cache
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
ip route 138.210.32.0 255.255.248.0 FastEthernet0/0
!
!
ip http server
no ip http secure-server
ip nat inside source list NAT interface FastEthernet0/0 overload
!
ip access-list extended NAT
deny ip 192.168.1.0 0.0.0.255 192.168.1.0 0.0.0.255
permit ip 192.168.1.0 0.0.0.255 any
!
snmp-server community public RO
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
password mario24
login
!
scheduler allocate 20000 1000
end
SVR-RT(config)#do sh ip route
Default gateway is not set
Host Gateway Last Use Total Uses Interface
ICMP redirect cache is empty
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
06-22-2016 09:16 PM
You said that f0/0 was your wan and f0/1 was your lan.
In your config, f0/0 is your lan and no ip on f0/1.
If you have connected your wan link on f0/0 you need to invert the config of your interfaces.
Ip nat outside as to be set in wan interface.
Why you have set a route to 138.210.32.0?
Are these addresses your public IPs?
If yes you need to configure one of this pool on your wan interface. In that case your isp gave you the IP of their router in this range. If that's the case, your default route must point to this isp router ip instead of f0/0.
If your wan has to be in dhcp then you need to set the command ip address dhcp on your wan interface configuration and default route ip 0.0.0.0 0.0.0.0 dhcp
Right now your default route is pointing to f0/1 that's your lan interface (based on your 1st post description)
How this is clear?
Thanks
PS: Please don't forget to rate and mark as correct answer if this solved your issue
Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
06-22-2016 09:20 PM
I got lazy and put F0/1 as WAN as that was connected to my modem and F0/0 as my LAN. *facepalm*
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
06-22-2016 09:22 PM
I have set the IP as DHCP and I did a ping to my backend default gateway from my PC and it failed the ping
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
06-22-2016 09:23 PM
I am able to ping 8.8.8.8 from my router.
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
06-22-2016 09:27 PM
I also have a Cisco switch that connects to the 1841.
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
06-22-2016 11:19 PM
Here is the new config:
SVR-RT(config)#do sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 0.0.0.0 to network 0.0.0.0
138.210.0.0/21 is subnetted, 1 subnets
C 138.210.32.0 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 is directly connected, FastEthernet0/0
SVR-RT(config)#do sh run
Building configuration...
Current configuration : 810 bytes
!
version 12.4
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SVR-RT
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
shutdown
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
!
!
ip http server
no ip http secure-server
!
ip access-list extended NAT
deny ip 192.168.1.0 0.0.0.255 192.168.1.0 0.0.0.255
permit ip 192.168.1.0 0.0.0.255 any
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
06-22-2016 11:39 PM
do:
no ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
no ip access-list extended NAT
access-list 1 permit 192.168.1.0 0.0.0.255
ip route 0.0.0.0 0.0.0.0 dhcp
ip nat inside source list 1 interface f0/0 overload
