11-07-2021 01:46 PM
Hi guys,
I've got a Cisco 2612 router and trying to route traffic between my Ethernet network (192.168.1.0/24) and TokenRing network (192.168.2.0/24). I'm trying to create a bridge between both networks.
The router has the interface Ethernet0/0 configured as 192.168.1.101 and the TokenRing0/0 interface configured with 192.168.2.1.
On the actual router I can ping both interfaces do I need to setup a static route? If so how?
Thanks,
11-07-2021 02:22 PM
Hi @Gypsy Dave ,
You do not need a static route, as the router is directly connected to both interfaces. Just make sure that devices on these two subnets are configured with a default gateway corresponding to the router respective interface IP address and you should be able to ping from the ethernet to the token-ring devices and vice versa.
Regards,
11-09-2021 04:56 AM
Hi Harold Ritter Do I need to config a gateway per interface? I can ping the device on the token ring interface from the router and it gets assigned an ip from the IP helper I've created but I can't telnet to it or trace route it. I get a "Destination unreachable; gateway or host down" seems like it cant find the path to that device. Also my firewall can ping the token ring interface but not the device on the token ring side. Something is not correct.
Regards,
11-07-2021 02:36 PM
Hello,
--> On the actual router I can ping both interfaces do I need to setup a static route? If so how?
Not really sure what you are after. You can assign an IP address to the Token Ring interface, and both interfaces should be able to talk to each others. Do you have an actual TokenRing network attached ?
11-07-2021 03:06 PM
ok great thanks for the reply. I just need to work out how to create a route on one of the older machine so I can reach the token ring network via its ethernet card.
@Georg Pauwen yep I've got a real token ring network connected to it. I've old MSDOS devices on the Token ring side and modern MacOs and Windows on the ethernet side.
11-10-2021 06:23 AM - edited 11-10-2021 07:22 AM
So the current problem is clients on the Ethernet network can only ping the Cisco 2600 router's ethernet and token ring interface. I can't ping the clients on the Token ring network.
Computers on the token ring network can ping the Cisco 2600 token ring interface but not the ethernet interface and clients on the ethernet network.
I've seen this other posting that seems like a simular problem and talks about source-bridge but my 2600 does not have that command?
https://community.cisco.com/t5/switching/routing-between-token-ring-and-ethernet/td-p/1068716
Here is my config. It looks like its a source route bridging command configuration I'm missing?
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname BRI-TOKEN
!
enable secret 5 *********
enable password **********
!
!
!
!
!
no ip subnet-zero
no ip routing
ip dhcp excluded-address 192.168.2.1 192.168.2.10
!
ip dhcp pool TOKENPOOL
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 192.168.2.1
netbios-name-server 192.168.2.1
!
bridge crb
!
!
process-max-time 200
!
interface Ethernet0/0
ip address 192.168.1.101 255.255.255.0
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
bridge-group 1
!
interface Serial0/0
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
no fair-queue
!
interface TokenRing0/0
ip address 192.168.2.1 255.255.255.0
ip helper-address 192.168.2.1
ip directed-broadcast
no ip route-cache
ring-speed 16
bridge-group 1
!
interface Serial0/1
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
!
ip classless
no ip http server
!
snmp-server engineID local 00000009020000B064263AA0
snmp-server community public RO
bridge 1 protocol ieee
bridge 1 bitswap-layer3-addresses
bridge 1 route ip
!
line con 0
transport input none
line aux 0
line vty 0 4
password ******
login
!
no scheduler allocate
end
11-10-2021 05:13 PM
Thanks for posting the configuration. There are several things that we might want to talk about. But the most important issue in the config is this
no ip routing
Since you have one subnet on the Ethernet and a different subnet on the Token Ring you want to route between the subnets. But "no ip routing" disables routing. Remove that line and let us know if the behavior changes.
The issue here is that your configuration has some elements of a solution based on routing and some elements of a solution based on bridging. You should try to accomplish one or the other, but not both.
The solution based on routing is more simple and more robust. A solution based on bridging is more complex. Think about what you really want and if it is the solution based on bridging we can make some suggestions about how to accomplish that.
11-11-2021 12:54 AM
Hi Rick,
Thanks for responding. I've removed that line by using the command "ip routing" and still have the same problems. From what I read I need to setup Source Route Bridging but I think my iOS version does not support it as I don't have the commands. Can this be done then via ip routing? What am I' missing?
Regards,
11-11-2021 01:46 AM
Hello,
I think you need an IOS that supports DEC in order to be able to configure SRB.
I wonder if just IRB can accomplish what you want (all Ethernet and Token Ring PCs would be in the same subnet, but at least you would have connectivity):
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname BRI-TOKEN
!
enable secret 5 *********
enable password **********
!
no ip subnet-zero
!
ip dhcp excluded-address 192.168.2.1 192.168.2.10
!
ip dhcp pool TOKENPOOL
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 192.168.2.1
netbios-name-server 192.168.2.1
!
--> bridge irb
!
process-max-time 200
!
interface Ethernet0/0
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
--> bridge-group 1
!
interface Serial0/0
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
no fair-queue
!
interface TokenRing0/0
no ip address
ip directed-broadcast
no ip route-cache
ring-speed 16
--> bridge-group 1
!
interface Serial0/1
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
!
--> interface BVI1
--> ip address 192.168.2.1 255.255.255.0
!
ip classless
no ip http server
!
snmp-server engineID local 00000009020000B064263AA0
snmp-server community public RO
--> bridge 1 protocol ieee
--> bridge 1 route ip
!
line con 0
transport input none
line aux 0
line vty 0 4
password ******
login
!
no scheduler allocate
end
11-11-2021 02:29 AM - edited 11-11-2021 02:56 AM
Thanks for that. I'm a little confused. How will this route between the ethernet 192.168.1.0/24 and token ring 192.168.2-0/24 subnets?
Edit: Just read above again. I could try to move all the devices to one subnet to test. If I have a DHCP server on the ethernet side will the token ring network be able to get an ip address from it?
11-11-2021 03:20 AM
Hello,
in the suggested config, the DHCP server (pool) would serve both the Ethernet and the Token Ring clients...
11-11-2021 03:44 AM
ok I've changed everything over to the subnet 192.168.1.0/24 And the devices on the token ring network with static ip address can now ping some device on the ethernet network but not everything like the internet router/firewall located at 192.168.1.1 (ping is enabled on it)?
The devices on the token ring network that are configured as dynamic IP can't reach the DHCP server which is on the router/firewall at 192.168.1.1. I've removed the IP helper commands (see bellow) so that the devices use the main DHCP server on the ethernet side.
Current configuration: ! version 12.0 service timestamps debug uptime service timestamps log uptime service password-encryption ! hostname BRI-TOKEN ! enable secret 5 ******* enable password 7 ***** ! ! ! ! ! ip subnet-zero ! bridge irb ! ! process-max-time 200 ! interface Ethernet0/0 no ip address no ip directed-broadcast no ip route-cache no ip mroute-cache bridge-group 1 ! interface Serial0/0 no ip address no ip directed-broadcast no ip mroute-cache shutdown no fair-queue ! interface TokenRing0/0 no ip address ip directed-broadcast no ip route-cache no ip mroute-cache ring-speed 16 bridge-group 1 ! interface Serial0/1 no ip address no ip directed-broadcast no ip mroute-cache shutdown ! interface BVI1 ip address 192.168.1.101 255.255.255.0 no ip directed-broadcast ! ip classless ip http server ! snmp-server engineID local 00000009020000B064263AA0 snmp-server community public RO bridge 1 protocol ieee bridge 1 bitswap-layer3-addresses bridge 1 route ip ! line con 0 transport input none line aux 0 line vty 0 4 password 7 ****** login ! end
11-11-2021 04:05 AM
Hello,
I think the 'bridge 1 bitswap-layer3-addresses' line is only needed for Source Route Translational Bridging. Not sure what if any effect this has in IRB, but remove that line anyway...
11-11-2021 04:14 AM
Yeah I did remove that and the same issues. Token ring devices can't reach 192.168.1.1 (DHCP or ping) and they can't reach ping to some ethernet devices.
Do I need to declare the router/firewall (192.168.1.1) as a gateway somewhere in the config?
11-11-2021 04:38 AM
Hello,
your current configuration is different from the one I suggested/posted earlier.
Either way, if this is still in your configuration:
interface BVI1
ip address 192.168.1.101 255.255.255.0
Then this (192.168.1.101) must be the default gateway for all Ethernet and Token Ring clients...
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide