08-06-2018 06:04 PM - edited 03-05-2019 10:50 AM
Hello everyone,
I would again like to thank anyone in advance that maybe able to help me.
Here is my situation, I got a router configured with help from the community, but I am experiencing a very odd issue. I have never had this happen before.
Here is my network. I have an 8 port Gigabit switch, with a Server, a desktop, and a Picostation.
Normally when I transfer files from my server, I transfer at 100MBps, the full Gigabit connection.
Prior to using this router, I had no trouble doing this. I never have had trouble transferring Gigabit speed on any network I have done with a 10/100 router as the dhcp server.
But, when using this router I can only transfer files at 10MBps. So it is like the network is transferring at 10/100 not 100/1000. Unplug it from the switch. Bam gigabit speed between desktop and server. Plug 2600 in, bam 10/100. Both devices show 1 Gbps on the Nic Stats.. I just don't understand what I did wrong in the config. But, all the traffic must be going through the router itself then back to the switch then to the clients, therefore making it 10/100 as the 2651XM is two 10/100 ports.
Any thoughts on this? Thanks so much!
I have included my router config, but omitted the working IPs.
Erik :)
Config - As Is:
Current configuration : 2034 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname WANETROUTER
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$2f7M$33U1px0E5ttjJtkLakofc/
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.75.1
ip dhcp excluded-address 192.168.75.2
ip dhcp excluded-address 192.168.75.3
ip dhcp excluded-address 192.168.75.4
ip dhcp excluded-address 192.168.75.250
ip dhcp excluded-address 192.168.75.251
ip dhcp excluded-address 192.168.75.252
ip dhcp excluded-address 192.168.75.253
ip dhcp excluded-address 192.168.75.254
!
ip dhcp pool wanet
network 192.168.75.0 255.255.255.0
default-router 192.168.75.254
dns-server 65.110.96.131 8.8.8.8
domain-name wanetworking.biz
lease 0 12
!
ip dhcp pool wanet2
host 192.168.75.5 255.255.255.0
client-identifier 0100.1517.ce1b.4c
default-router 192.168.75.254
dns-server 65.110.96.131 8.8.8.8
!
!
ip name-server 65.110.96.131
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 65.x.x.x 255.255.255.248
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.75.254 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 65.x.x.x
!
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/0 overload
!
access-list 1 deny 10.0.0.0
access-list 1 permit 192.168.75.0
access-list 1 deny 127.0.0.0
access-list 1 deny 169.0.0.0
access-list 1 deny 192.0.0.0
access-list 1 permit 192.168.75.0 0.0.0.255
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
transport input none
line vty 5 15
login
transport input none
!
!
end
08-06-2018 07:46 PM
hi,
this router is very old and won't be able to support gig speed.
are you transferring files 'locally' or over the internet?
try to hardcode interface speed/duplex on both the router and the 8-port switch (if not a dumb switch) and see if it helps.
08-06-2018 07:57 PM
Are both the server and the desktop on the same vlan (subnet)? if they are, traffic shouldn't make it to the router in the first place (the switch will be the one handling the traffic instead). check the configs on the switch ports that the desktop and the server are connected to and let us know how they are configured.
08-06-2018 08:57 PM
Howdy,
They are both on the same subnet and there is no vlan configured. The traffic is local. The switch isnt Cisco, it is an unmanaged TPLink switch. All the router is doing is providing DHCP, and internet to the LAN. When I unplug the router fron the network and static both machines I get full gigabit. When the router is plugged in, and providing DHCP, the speed on the LAN is equivalent to 10/100. The NICs obviously still show Gbit uplinks to the switch. It really does not make sense.
08-06-2018 09:03 PM - edited 08-06-2018 09:04 PM
hi,
local traffic won't hit the router and DHCP only assigns IP and should having nothing to do with the speed on your machines.
does the TP link switch supports gig ports? are you able to hardcode the machines' NIC speed/duplex settings and make sure you're using cat6 UTP cable (try also to swap cables)?
08-06-2018 09:13 PM
Howdy,
Yes, the switch is gigabit. I have this router setup as a test/play router. When I use my normal router, a Ubiquiti Air Router, the traffic is normal. It is also only a 10/100 router. I know local traffic does not go through the router, which is why this doesnt make any sense really. I just thought maybe I put a bad line of code in the config. The cables are good.
08-07-2018 01:12 AM
Hello,
just an idea, but you might as well give it a try: configure the router for bridging, that way, the interface (FastEthernet0/1) that is connected to the TP Link is a layer 2 interface, not sure if that makes a difference. Below is the config (important parts marked in bold):
urrent configuration : 2034 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname WANETROUTER
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$2f7M$33U1px0E5ttjJtkLakofc/
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.75.1
ip dhcp excluded-address 192.168.75.2
ip dhcp excluded-address 192.168.75.3
ip dhcp excluded-address 192.168.75.4
ip dhcp excluded-address 192.168.75.250
ip dhcp excluded-address 192.168.75.251
ip dhcp excluded-address 192.168.75.252
ip dhcp excluded-address 192.168.75.253
ip dhcp excluded-address 192.168.75.254
!
ip dhcp pool wanet
network 192.168.75.0 255.255.255.0
default-router 192.168.75.254
dns-server 65.110.96.131 8.8.8.8
domain-name wanetworking.biz
lease 0 12
!
ip dhcp pool wanet2
host 192.168.75.5 255.255.255.0
client-identifier 0100.1517.ce1b.4c
default-router 192.168.75.254
dns-server 65.110.96.131 8.8.8.8
!
ip name-server 65.110.96.131
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
bridge irb
!
interface FastEthernet0/0
ip address 65.x.x.x 255.255.255.248
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
bridge-group 1
ip virtual-reassembly
duplex auto
speed auto
!
interface BVI 1
ip address 192.168.75.254 255.255.255.0
ip nat inside
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 65.x.x.x
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/0 overload
!
access-list 1 deny 10.0.0.0
access-list 1 permit 192.168.75.0
access-list 1 deny 127.0.0.0
access-list 1 deny 169.0.0.0
access-list 1 deny 192.0.0.0
access-list 1 permit 192.168.75.0 0.0.0.255
!
bridge 1 protocol ieee
bridge 1 route ip
!
control-plane
!
line con 0
line aux 0
line vty 0 4
login
transport input none
line vty 5 15
login
transport input none
!
end
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide