cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
2511
Views
15
Helpful
8
Replies
scottastafford5
Beginner

Cisco 4321 issues DNS and Internet connection?

I'm having issues connecting ISR 4321, i can't access the internet at all. I can ping the ISP on the router but i can't ping 8.8.8.8 and when connected i don't get default gateway on laptop and only get ip address. Below is current configuration on the router.

 

 

Building configuration...

Current configuration : 3046 bytes
!
! Last configuration change at 23:52:43 UTC Sun Sep 30 2018
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no platform punt-keepalive disable-kernel-core
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
vrf definition Mgmt-intf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
!
no aaa new-model
!
ip name-server 8.8.8.8
!
ip dhcp pool Planet
network 192.168.1.0 255.255.255.0
!
subscriber templating
!
multilink bundle-name authenticated
!
domain lookup
!
redundancy
mode none

interface GigabitEthernet0/0/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
negotiation auto
!
interface GigabitEthernet0/0/1
ip address dhcp
ip nat outside
negotiation auto
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
no ip address
negotiation auto
!
router rip
version 2
network 192.168.1.0
no auto-summary
!
ip default-gateway 192.168.1.1
ip nat inside source list 50 interface GigabitEthernet0/0/0 overload
ip forward-protocol nd
ip http server
ip http secure-server
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/0
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/0 dhcp
!
!
access-list 50 permit 192.168.1.0 0.0.0.255
!
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end

8 REPLIES 8
Eric101
Beginner

Looking at your configs very briefly, I assume Gi0/0/1 is your ISP connection. 

Your static IP routes are pointing out the wrong interface. It should be gi0/0/1

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/0
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/0 dhcp

I agree with the suggestion that your static default routes are pointing at the wrong interface. But I believe that this is not the only issue with your static default routes. As configured both of them include reference to what should be the outbound interface (if you correct which interface you point at).

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/0
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/0 dhcp

 

But when a static route points at an outbound interface without specifying the next hop (especially if the interface is Ethernet) then IOS assumes that the destination addresses are locally connected and will arp for each destination address.

 

My suggestion is to remove the first static default route which specifies only the interface and to modify the second static default route to remove the reference to the interface. So you would have 

ip route 0.0.0.0 0.0.0.0 dhcp

 

HTH

 

Rick

HTH

Rick

The route was configured on the inside nat interface so it would not work and Richard's suggestion is the correct solution because it takes the interface off of the command.

 

Duplicate post - with this



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

I have working configuration but i'm not sure if my phone is jacked up or the its router. I use app called speedtest.net and i should be getting 75/75 and on my laptop i'm getting about 50/50 but phone is 70/5 which is odd. I also found out that if i turn off the Cisco router i lose my configuration, is that correct.

 

Current configuration : 1383 bytes
!
! Last configuration change at 21:00:28 UTC Mon Oct 1 2018
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no platform punt-keepalive disable-kernel-core
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
vrf definition Mgmt-intf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
!
no aaa new-model
!
!
!
!
!
!
!
!
!

 

!
ip dhcp pool Planet
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 192.168.1.1
lease 0 12
!
ip dhcp pool planet
!
!
!
!
!
!
!
!
!
!
subscriber templating
!
multilink bundle-name authenticated
!
!

!
!
redundancy
mode none
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
negotiation auto
!
interface GigabitEthernet0/0/1
ip address dhcp
ip nat outside
negotiation auto
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
no ip address
negotiation auto
!
ip nat inside source list 50 interface GigabitEthernet0/0/1 overload
ip forward-protocol nd
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/1 dhcp
!
!
access-list 50 permit 192.168.1.0 0.0.0.255
!
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!

You tell us that " i'm not sure if my phone is jacked up or the its router". But you give us very little detail to work with to find answers to that. Is the app speediest run on the phone? How does the phone connect in this environment?

 

As far as losing the configuration if you turn off the router, this is not normal. It suggests that the config register may not be set correctly. Please post the output of show version which is the best way to check the setting of the config register.

 

The original post was about the fact that you did not have access to Internet. Now it appears that this is resolved and now the question is not access but is performance. This is good progress. I notice that your static default route still points to Gig0/0/1. I suggest that you remove this parameter so that the static default route specifies only DHCP. Try this and let us know if performance changes.

 

HTH

 

Rick

HTH

Rick

Sorry i thought i attached the config file, the phone is connect through
wifi using ap access point. I appreciate all the advice i'm getting.

version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no platform punt-keepalive disable-kernel-core
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
vrf definition Mgmt-intf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
!
no aaa new-model
!



!
ip dhcp pool Planet
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 192.168.1.1
lease 0 12
!
ip dhcp pool planet
!
!
!
!
subscriber templating
!
multilink bundle-name authenticated
!
!
!
!
license udi pid ISR4321/K9 sn FDO2036170Z
!
!
redundancy
mode none
!
!
!
interface GigabitEthernet0/0/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
negotiation auto
!
interface GigabitEthernet0/0/1
ip address dhcp
ip nat outside
negotiation auto
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
no ip address
negotiation auto
!
ip nat inside source list 50 interface GigabitEthernet0/0/1 overload
ip forward-protocol nd
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/1 dhcp
!
!
access-list 50 permit 192.168.1.0 0.0.0.255
!
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!

I have looked through the config that you posted and other than the change that I have suggested in the static default route I do not see any issues in the config that seem to relate to the symptoms that you describe. It is obvious that you have some kind of switch attached to Gig0/0/0, with ap and other devices connected through that switch. If you are seeing performance differences between several connected devices I might look at the possibility that something in the switch or in the ap is affecting the traffic.

 

As far as losing the configuration when you turn off the router I asked that you post the output of show version. Please post that.

 

HTH

 

Rick

HTH

Rick