Showing results for 
Search instead for 
Did you mean: 

Cisco 4451 - Unable to delete tftp line in router

Adam Ayoub
Level 1
Level 1

Good morning, I've tried everything to delete a certain line in the configuration of a Cisco 4451 router.


One of my colleagues was playing around with it I believe and he and I have been looking everywhere trying to figure out how to remove it.


tftp-server flash alias file1


I never played around with or tested "alias" before so it could just be inexperience on our parts. I tried doing a no in front of it and it didn't remove it. I searched on google also, to no avail. Hoping to find someone here who's used this before and knows how to remove it.


Thank you in advance!

4 Replies 4

Seb Rupik
VIP Alumni
VIP Alumni

Hi there,

According to the config guide:

tftp-server rom alias filename1 [access-list-number]
no tftp-server {flash [partition-number:]filename1 | rom alias filename2} it should be sufficient to type (without the alias):

no tftp-server flash file1




Hi Seb,


Thanks for your reply. I just tried it and it didn't work. The line is still there.


I also tried deleting the file itself before trying to remove the line. And no dice. 


Also tried "no tftp-server flash:file1". It's a stubborn little line.

hmmm, do you have a flash card installed?. sh flash:  


There is a bug:

...which will allow you to enter the command but not remove it if the file system is not available.


You could just edit the running config off the box, then copy it back to startup and reload the device.




There is a flash card but it's built in. Can't remove them on these models if I'm not mistaken.

Review Cisco Networking for a $25 gift card