cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1009
Views
0
Helpful
1
Replies

Cisco 4507R with Sup6-E QoS

ralphcarter
Level 1
Level 1

Hey Guys,

I'm trying to use a Sup6-E to do some intelligent shaping. I'm getting an error and I think its because of the architecture of the 4500 QoS. Most likely this type of QoS is not supported so I was wondering if anyone had any ideas on how to implement this QoS policy.

This is what I want to accomplish

!

class-map match-any PRIORITY-QUEUE

match dscp ef

match dscp cs5

match dscp cs4

!

class-map match-any CONTROL-MGMT-QUEUE

match dscp cs7

match dscp cs6

match dscp cs3

match dscp cs2

!

class-map match-any NETWORK-CRITICAL

match dscp cs6

match dscp cs2

!

class-map match-any MULTIMEDIA-CONFERENCING-QUEUE

match dscp af41 af42 af43

!

class-map match-any MULTIMEDIA-STREAMING-QUEUE

match dscp af31 af32 af33

!

class-map match-any TRANSACTIONAL-DATA-QUEUE

match dscp af21 af22 af23

!

class-map match-any BULK-DATA-QUEUE

match dscp af11 af12 af13

!

class-map match-any SCAVENGER-QUEUE

match dscp cs1

!

!

policy-map 1P7Q1T

class PRIORITY-QUEUE

  priority

class CONTROL-MGMT-QUEUE

  bandwidth remaining percent 10

class MULTIMEDIA-CONFERENCING-QUEUE

  bandwidth remaining percent 10

class MULTIMEDIA-STREAMING-QUEUE

  bandwidth remaining percent 10

class TRANSACTIONAL-DATA-QUEUE

  bandwidth remaining percent 10

  dbl

class BULK-DATA-QUEUE

  bandwidth remaining percent 4

  dbl

class SCAVENGER-QUEUE

  bandwidth remaining percent 1

class class-default

  bandwidth remaining percent 25

  dbl

!

!

!

ip access-list extended ACL-SITE1

permit ip any 172.16.1.0 0.0.0.255

!

ip access-list extended ACl-SITE2

permit ip any 172.17.1.0 0.0.0.255

!

!

class-map match-all CLASS-SITE1

match access-group name ACL-SITE1

!

class-map match-all CLASS-SITE2

match access-group name ACL-SITE2

!

!

When I create my Parent/Child Policy-map I get an error. Is there any way i can meet the objective which is, match the ACLs, shape their bandwidth to 10Mbps and within their shaped 10Mbps bandwidth, allocate specific bandwidth percentages for the traffic matching Dscp values?

!

policy-map POLICY-WAN-SHAPER

class NETWORK-CRITICAL

  bandwidth remaining percent 1

class CLASS-ACL1

  shape average 10000000

  service-policy 1P7Q1T

class CLASS-ACL2

  shape average 10000000

  service-policy 1P7Q1T

I get the following error when I try to apply the nested service-policy.

%Queuing actions can be at only one of the policy-maps in a hierarchical policy-map. Configuration failed!

Then apply to Sup6-E interface.

!

policy-map POLICY-WAN

class class-default

  shape average 100000000

  service-policy POLICY-WAN-SHAPER

!

interface ten1/1

service-policy output POLICY-WAN

I know this can be done on the ASR and obviously this is not an ASR router but I'm trying to get this scenario fullfilled. Is it possible?

CCIE 26175
www.techsnips.com
1 Reply 1

Jerry Ye
Cisco Employee
Cisco Employee

The C4500 is not a WAN router, hense, it will not support HQoS.

This is the same story in the C6K LAN line card. But the good part is, the C6K has SIP/SPA to support WAN connectivity and features.

HTH,

jerry

Review Cisco Networking for a $25 gift card