06-06-2018 03:38 PM - edited 03-05-2019 10:33 AM
Hello All,
I have Cisco 4948-10 G switch, and i have created 30 Vlans for my customers. now i want to rate limit the bandwidth on Vlan interfaces. can you please let me know how to do that ?
it is not allowing me to apply the rate-limit command like we apply on sub interfaces of a router.
Thanks,
Sandy
06-07-2018 12:57 AM
Hello,
you cannot rate-limit or police on an SVI on the 4948. You need to create a VLAN policy and apply that to all physical ports belonging to the VLAN. Below is an example - here we limit VLAN 10 to 100MB.
494810G# configure terminal
494810G(config)# class-map vlan10_class
494810G(config-cmap)# match vlan 10
494810G(config-cmap)# exit
494810G(config)# policy-map vlan10_policy
494810G(config-pmap)# class vlan10_class
494810G(config-pmap-c)# police 10000000 conform-action transmit exceed-action drop
494810G(config-pmap-c-police)# end
494810G# configure terminal
494810G(config)# interface gigabitEthernet0/0/1
494810G(config-if)# switchport access vlan 10
494810G(config-if)# service-policy input vlan10_policy
06-13-2018 05:18 AM
is this for download and upload ? i want to limit both.
Thanks
Sandy
06-07-2018 02:33 AM - edited 06-07-2018 02:35 AM
Hello
Is this switch the L3 for all those vlans and do you have all these vlans traversing trunks from this switch?
if so you could possibly look at applying and ingress/egress policer on this switch to the vlans that span those trunks?
Example:
vlan 10 = 10.10.10.0/24
vlan 20 = 10.10.20.0/24
vlan 30 = 10.10.30.0/24
vlan 40 = 10.10.40.0/24
ip access-list 101 permit ip 10.10.10.0 0.0.0.255 any
ip access-list 101 permit ip 10.10.20.0 0.0.0.255 any
ip access-list 102 permit ip 10.10.30.0 0.0.0.255 any
ip access-list 102 permit ip 10.10.40.0 0.0.0.255 any
class-map match-any vl10-20_cm
match ip access-group 101
class-map match-any vl30-40_cm
match ip access-group 102
Policy-map vl10-20_pm
Class vl10-20_cm
Police xxxxx yyyyyy conform transmit exceed drop
Policy-map vl30-40_pm
Class vl30-40_cm
Police xxxxx yyyyyy conform transmit exceed drop
int x/x/
description trunk
Switchport trunk allowed vlan 10-40
vlan range 10-20
Service-policy input vl10-20_pm
Service-policy outputvl10-20_pm
vlan range 30-40
Service-policy input vl30-40_pm
Service-policy output vl30-40_pm
res
Paul
06-13-2018 05:24 AM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide