cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
726
Views
0
Helpful
5
Replies
Highlighted
Beginner

Cisco 887VA ADSL cannot dialup connection

Hi,


Could anyone please help me configure my new CISCO 887VA ADSL router.

I cannot get the dialer to establish a connection.

I have an ADSL2 connection from ISP with an LLC encapsulation and pvc of  0/35, below is my router config.

Router#sh run

Building configuration...

Current configuration : 2068 bytes

!

! Last configuration change at 21:17:24 UTC Mon Sep 3 2012

! NVRAM config last updated at 21:17:25 UTC Mon Sep 3 2012

! NVRAM config last updated at 21:17:25 UTC Mon Sep 3 2012

version 15.1

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

shell processing full

!

no logging console

!

no aaa new-model

memory-size iomem 10

crypto pki token default removal timeout 0

!

!

ip source-route

!

!

!

!

ip dhcp pool LAB-Pool

import all

network 192.168.0.0 255.255.255.0

dns-server 202.62.124.238 202.62.120.4

default-router 192.168.0.1

!

!

ip cef

no ipv6 cef

!

!

license udi pid CISCO887VA-K9 sn FGL163224PV

!

!

!

!

!

!

controller VDSL 0

!

!

!

!

!

!

!

!

interface Ethernet0

no ip address

!

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

no atm ilmi-keepalive

!

interface ATM0.1 point-to-point

pvc 0/35

  encapsulation aal5snap

!

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface Vlan1

description Internal LAN

ip address 192.168.0.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

!

interface Dialer0

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

ip mtu 1492

ip nbar protocol-discovery

ip flow ingress

ip nat outside

ip virtual-reassembly in

encapsulation ppp

ip tcp adjust-mss 1452

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname xxxxxxxxxxx

ppp chap password 0 xxxxxxxxxxxx

ppp pap sent-username xxxxxxxxxx password 0 xxxxxxxxxx

ppp ipcp address accept

no cdp enable

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

ip dns server

ip nat inside source list 101 interface Dialer0 overload

ip route 0.0.0.0 0.0.0.0 Dialer0

!

access-list 101 permit ip 192.168.0.0 0.0.255.255 any

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

login

transport input all

!

end

Router#

5 REPLIES 5
Highlighted
Hall of Fame Master

Start checking "show controller vdsl 0".

Then if it is RFC bridged connction, as opposed to PPPoE, your configuration is completely wrong. Otherwise is only partially wrong. Confirm with ISP, if you are not assigned username/password, it's bridged RFC.

Highlighted

I managed to fix the issue with help from ISP engineer, thanks Masi.

Changed the configs on the ATM0.1

     interface ATM0.1 point-to-point

     pvc 0/35

     pppoe-client dial-pool-number 1

Dialer could establish a connection to ISP after this.

Highlighted

Note that you need

ip tcp adjust-mss 1452

on VLAN interface, not Dialer.

Highlighted
Hall of Fame Cisco Employee

Hi Paolo,

I have actually tested this - and it turned out that the ip tcp adjust-mss applies to both ingress and egress traffic and can be safely placed on Dialer interface as well. That makes it actually even more simple to deploy if there are several internal interfaces, as placing this command on the Dialer interface will make it apply to all traffic exiting the router towards the DSL.

Best regards,

Peter

Highlighted

That makes sense. Good advice Peter.