cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
760
Views
0
Helpful
2
Replies
mukesh.surya
Beginner

Cisco 892 Problem Configuring PPPoE

Hello Guys, 
I need your help. 
I've got a Cisco 892 Router in which I'm trying to configure PPPoE connection. I'm not a pro, I've tried commands which I founded on the internet but it didn't work. I've reset the router. Please help me out. 

Thanks. 

2 REPLIES 2
Georg Pauwen
VIP Expert

Hello,

 

here is a generic sample for the PPPoE part. Post the configuration you currently have, also indicate who your ISP is:

 

interface GigabitEthernet0
description ISP_UPLINK
no ip address
pppoe enable
pppoe-client dial-pool-number 1
no cdp enable
no shutdown
!
interface Dialer1
description DIALER_TO_ISP
ip address negotiated

ip nat outside
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1492
encapsulation ppp
ip tcp adjust-mss 1452
load-interval 30
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap chap callin
ppp chap hostname yourhostname
ppp chap password yourpassword
ppp pap sent-username yourhostname password yourpassword

Deepak Kumar
VIP Advocate

Hi, 

Your configuration will like:

 

 

interface Dialer1
description $PPOE Dailer$
mtu 1492
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
ppp authentication chap pap ms-chap callin
ppp chap hostname <ISP Username>
ppp chap password <ISP password>
ppp pap sent-username <ISP Username> password 0 <ISP password>
!
!

 

interface FastEthernet0
description WAN-PORT-PPOE-CONNECTED
no ip address
pppoe enable group global
pppoe-client dial-pool-number 1

 

 

Regards,

Deepak Kumar

 

 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution if this comment will help you!