cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1073
Views
0
Helpful
6
Replies

Cisco 892 Shape

Hello everybody,

I have Cisco 892FSP with Gi 8 Uplink and 2 inside interfaces Gi0-1:

 

interface GigabitEthernet8
description UPLINK
ip address 192.168.0.1 255.255.255.254

!

interface GigabitEthernet0
switchport access vlan 238
no ip address
no lldp transmit
no lldp receive
no cdp enable
spanning-tree portfast

!

interface GigabitEthernet1
switchport access vlan 238
no ip address
no lldp transmit
no lldp receive
no cdp enable
spanning-tree portfast

!

interface Vlan238
ip address 10.0.0.1 255.255.255.224

 

I need to shape the download and upload as 200Mbitps. Can somebody me help how I can do it with vlan?

 

Best Regards,

6 Replies 6

Hello,

 

the 892 does not even come close to up and download speeds of 200MB. Either way, a simple traffic shaping policy would look like below:

 

policy-map SHAPE_200MB
class class-default
shape average 200000000
fair-queue
!
interface GigabitEthernet8
description UPLINK
ip address 192.168.0.1 255.255.255.254
service-policy output SHAPE_200MB

Joseph W. Doherty
Hall of Fame
Hall of Fame

Shaping egress is generally used so you can manage less bandwidth then the port supports.  (How it might be done is shown in Georg's posting.)  BTW: Do note, I believe some shapers do not account for L2 overhead, and if you need to shape for that overhead too, on such shapers you can shape about 15% "slower" to allow for that overhead.

You cannot shape ingress (except perhaps on another port's egress).  You can police ingress.  However, for what purpose do you wish to limit ingress?  (The reason I ask, a policer [or shaper] will control bandwidth behind it, but their affect upon upstream bandwidth usage, varies.)

Hallo Joseph,

thanks for your reply. I tred to do the shape. It looks like

!
class-map match-any from-inside
match input-interface Vlan238
match input-interface GigabitEthernet0
match input-interface GigabitEthernet1
!
policy-map shape-to-inside
class class-default
shape average 200000000
fair-queue 256
policy-map shape-from-inside
class from-inside
shape average 200000000
fair-queue 256


But It works only for download.
I feel like it's not working right with L2 or I'm doing something wrong

How do you have the policies applied?

interface GigabitEthernet8

service-policy output shape-from-inside

!

interface GigabitEthernet0

service-policy output shape-to-inside

!

interface GigabitEthernet1

service-policy output shape-to-inside

 

So you're problem is with g8?  Further, it's not shaping, you believe?  Any possible traffic not from the three interfaces listed in the class-map?  If you wish to shape all g8 egress traffic, why not use class-default?

Review Cisco Networking for a $25 gift card