Showing results for 
Search instead for 
Did you mean: 

Cisco ASR 1002 not sending Calling Station ID on accounting interim update


Dear community,


We are facing a strange behavior with two Cisco ASR 1002-X routers. 

The routers are running on IOS XE, one of them is running version Version 15.4(1)S while the other is running version Version 15.5(3)S1a.

We use the routers to aggregate PPPoE sessions. Each router holds about 5 to 6 thousand PPPoE subscribers.

What we have noticed is that during accounting interim updates for a few clients the routers are not sending the Calling Station ID attribute in the packet, I would like to point out that this happens only for a few pppoe session not all of them. 

From what we can see the issue happens only when sending interim updates, when  Access Request packet is send the Calling station ID is there but when accounting stop and start messages are sent the Calling Station ID is attribute for the same user is not sent. Meanwhile for other users the same routers include the Calling station ID in the interim Update.

Below is the configuration that we have performed on both routers regarding aaa and pppoe sessions:


aaa authentication login console local
aaa authentication ppp default group radius
aaa authorization network default group radius
aaa accounting delay-start
aaa accounting update periodic 10
aaa accounting network default start-stop group radius


aaa server radius dynamic-author
server-key 7 x.x.x.x
auth-type any
ignore session-key


aaa session-id common
aaa policy interface-config allow-subinterface


multilink bundle-name authenticated
vpdn enable
vpdn-group pppoe
! Default L2TP VPDN group
! Default PPTP VPDN group
protocol any
virtual-template 1

bba-group pppoe global
virtual-template 1
sessions max limit 12000
sessions per-mac limit 22
sessions per-vlan limit 12000
sessions per-mac throttle 1 3 10
sessions auto cleanup


radius server radius01
address ipv4 x.x.x.x auth-port 1812 acct-port 1813
key 7 x.x.x.x


I am also attaching the packets that we have received from the ASR on the Radius server.

1 Reply 1

Georg Pauwen
VIP Master VIP Master
VIP Master



try and add:


radius-server attribute 31 circuit-id"


to your RADIUS configuration...

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers