cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1908
Views
0
Helpful
5
Replies

Cisco IOS-XR VRF configuration

435885
Level 1
Level 1

 I have an ASR 9000 cisco router where I am trying to move the existing global routing table configuration into a VRF.

so the current configuration on the device is as follows:

interface Bundle-Ether1.200
ipv4 address 10.10.10.2 255.255.255.0
load-interval 30
encapsulation dot1q 200
!

route-policy xx_2_IN
if (xx) then
pass
endif
end-policy
!
route-policy xx_2_OUT
if (xx) then
pass
endif
end-policy
!
router bgp 12345
bgp router-id x.x.x.x
bgp graceful-restart
ibgp policy out enforce-modifications
address-family ipv4 unicast
bgp dampening
!
address-family vpnv4 unicast
!
session-group IBGP_x
remote-as 12345
bfd fast-detect
bfd multiplier 3
bfd minimum-interval 150
advertisement-interval 1
password encrypted xxxxxxx
!
neighbor-group x2_peer_v4
use session-group IBGP_x
address-family ipv4 unicast
route-policy xx_2_IN in
route-reflector-client
maximum-prefix 10000 80 warning-only
route-policy xx_2_OUT out
next-hop-self
soft-reconfiguration inbound always
!
neighbor 10.10.10.3
use neighbor-group x2_peer_v4
!
neighbor 10.10.10.4
use neighbor-group x2_peer_v4
!


Can you please guide me with the steps:
so far I have come up with this:
1. shut the bundle interface BE1 to failvoer traffic to the adjacent router
2. configure new vrf named "RED" as follows:
config t
vrf RED
address-family ipv4 unicast
!
3. assign vrf to the BE interface:
config t
interface Bundle-Ether1.200
vrf RED
ipv4 address 10.10.10.2 255.255.255.0
!
commit

4. configure VRF "RED" for bgp
configure terminal
router bgp 12345
vrf RED
rd auto
address-family ipv4 unicast
!
neighbor 10.10.10.3
use neighbor-group x2_peer_v4
!
neighbor 10.10.10.4
use neighbor-group x2_peer_v4
!
5. unshut the BE interface and check the vrf is created?

question:

once I have shut the BE 1 - do I also need to do the "no neighbor 10.10.10.3" under the router bgp 12345 to remove the neighbor from the global routing table and then go ahead with steps 3 and 4?

C

5 Replies 5

balaji.bandi
Hall of Fame
Hall of Fame

If you like to move the BGP config per VRF based, then you need to remove the BGP config and activate per VRF as you mentioned the steps you mentioned to follow.

Note soon you configure VRF on the interface all config will be gone. (if any configuration was before applied)

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

I understand that the L3 configuration on the interfaces will be removed as soon as I configure the interface with VRF but does that mean that all neighbor configuration under the router bgp 12345 will be gone automatically or do I need to remove that first as well?

BGP configuration still there, but you need to remove that and configure VRF based config on BGP.

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

M02@rt37
VIP
VIP

Hello @435885,

Do #commit at point 1.

Don't #commit at point 3.

Do #sh commit changes diff at the end:

The added parts will have a "+" and the removed parts will have a  "-". You check and if it is OK you commit.

 

 

Best regards
.ı|ı.ı|ı. If This Helps, Please Rate .ı|ı.ı|ı.

I recommend to remove nieghor from global and add it again under vrf address family.

Review Cisco Networking for a $25 gift card