cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
256
Views
0
Helpful
4
Replies

Cisco PPP dialer not working

lakhwaraa
Beginner
Beginner

interface Dialer1
mtu 1480
bandwidth 6000
ip address negotiated
ip nat outside
ip virtual-reassembly in
zone-member security outside
encapsulation ppp
ip tcp adjust-mss 1400
dialer pool 2
dialer-group 2
ppp authentication chap pap callin
ppp chap hostname sakkhro
ppp chap password 0 7766
ppp pap sent-username sakkhro password 0 7766
no cdp enable

Sh ip int brief

Interface      IP-Address         OK?             Method       Status         Prot

Dialer1          unassigned         YES          NVRAM          up             up

I am unable to get ip address while dialing through cisco router. My username password is working as i have checked on windows. what is the problem.

 

 

4 Replies 4

balaji.bandi
VIP Community Legend VIP Community Legend
VIP Community Legend

Why are you using both PAP and CHAP username and password to send ? what did that worked in windows so use same method.

here is the standard config that should work :

interface Ethernet0/0/0
no ip address
!
interface Ethernet0/0/0.101   (if the ISP lookingDot1.q)
encapsulation dot1Q 101
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dialer1
description ISP DSL
mtu 1492
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip nbar protocol-discovery
ip flow ingress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
ppp authentication pap chap ms-chap callin
ppp chap hostname <REMOVED>
ppp chap password 0 <REMOVED>
ppp ipcp address accept
no cdp enable

 

still not working

post show run (complete config)

also run debug :

debug ppp negotiation

debug ppp authentication

Troubleshooting guide :

https://www.cisco.com/c/en/us/support/docs/long-reach-ethernet-lre-digital-subscriber-line-xdsl/asymmetric-digital-subscriber-line-adsl/71124-adslguide-pppoedsl-ts.html

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Now the method has changed from automatic to manual

Interface        IP-Address           OK?              Method              Status          Protocol

Dialer1           unassigned          YES                manual             up                 up

also i cant use debug as i dont have access to physical router. only ssh

 

balaji.bandi
VIP Community Legend VIP Community Legend
VIP Community Legend

from SSH you can do debug - issue terminal monitor and run the debug

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

MHM Cisco World
VIP Mentor VIP Mentor
VIP Mentor

friend I write in your other post, please share the Zone config I think there is soemthing in Zone security config.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers